21 апреля 2017

Релиз Firefox 53 с двумя новыми компактными темами

19 апреля сообщество Mozilla выпустило очередное обновление браузера Firefox 53.
В Firefox 52 начался процесс удаления поддержки плагина Netscape Plugin API (NPAPI), путём его отключения по умолчанию, но позволяя пользователю включить его вручную в настройках браузера. В Firefox 53 опция поддержки NPAPI удалена полностью.
Изменён новый визуальный дизайн для элементов управления аудио и видео в заголовке вкладки.
Завершена поддержка Firefox в Linux для процессоров старше Pentium 4 и AMD Opteron.
Windows XP и Vista больше не поддерживаются. Пользователи XP и Vista, использующие Firefox 52, будут продолжать получать обновления безопасности в Firefox 52 ESR.
В Firefox 53 также добавлены две новые компактные темы оформления браузера «Compact Dark» и «Compact Light» (опционально), которые можно включить в Дополнениях браузера по желанию пользователя.


Компактная светлая


Компактная тёмная


Помимо визуальных и технических изменений, Firefox 53 как всегда получил порцию различных исправлений безопасности.

Пользователи Linux могут обновить Firefox 52 до Firefox 53 путём штатной программы обновления приложений:



Источник: https://www.mozilla.org/firefox/53.0/releasenotes/

Удачи.

15 комментариев :

  1. ==В Firefox 53 опция поддержки NPAPI удалена полностью.==
    Они действительно грозились так сделать, но на практике этого не наблюдается, странно. У меня NPAPI-плагины, включенные вручную в предыдущей версии ключом plugin.load_flash_only = false, отображаются в списке плагинов и продолжают работать (если установлено "всегда включать"). То ли лыжи не едут, то ли планы разрабов поменялись...
    http://i.imgur.com/S99fr9K.png

    ОтветитьУдалить
    Ответы
    1. Здравствуйте! У меня тоже самое - NPAPI-плагины, включенные этим же ключом в версии 52( по Вашему совету в комментах статьи про релиз 52 версии - спасибо!) после обновления до 53 отображаются в списке и, как ни странно, работают? Автору статьи конечно благодарность за информацию ))
      http://mepic.ru/view/?id=81d24dc144c36f9e4cfc196d5e158229

      Удалить
  2. Извините, за вопрос не по теме но, очень нужна помощь. Перестали устанавливаться программы ,
    Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение). Как бы и раньше с этим сталкивался но сейчас, предлагает УДАЛИТЬ все пакеты с окончанием amd64 (apg appmenu-qt:amd64 appstream:amd64 avahi-utils:amd64 blt:amd64 cabextract command-not-found-data cpp-5:amd64 cups-pk-helper dc:amd64 .... и так далее) И ПЕРЕУСТАНОВИТЬ на такие же но без amd64 и я так понял что предлагает заменить все ПАКЕТЫ в сестеме, более 400 мбт, что то тут не то . Это что же она хочет пере установить все программы на 386?

    ОтветитьУдалить
    Ответы
    1. Прежде всего выполните команду в терминале, которую Вам предлагаю: sudo apt-get -f install
      Эта команда удовлетворяет зависимости пакетов программ обезличенно, поэтому в выводе написано: "не указывая имени пакета".
      Если не получится исправить положение, тогда зайдите в Источники приложений, отключайте добавленные Вами репозитории по очереди и выполняйте команду: sudo apt update
      Возможно, что Вы подключили нерабочий реп, который и выдаёт ошибку.

      Удалить
    2. меня смущает что в переустановку попало очень много пакетов, и эта фраза
      ВНИМАНИЕ: Эти существенно важные пакеты будут удалены.
      НЕ ДЕЛАЙТЕ этого, если вы НЕ представляете себе все возможные последствия!
      обновлено 0, установлено 889 новых пакетов, для удаления отмечено 590 пакетов, и 0 пакетов не обновлено.
      Необходимо скачать 451 MБ архивов.
      После данной операции, объём занятого дискового пространства возрастёт на 323 MB.

      и также то что пакеты переустанавливаются все

      Удалить
    3. Какой у Вас дистрибутив? И что Вы делали после установки? О чём Вы не пишете в комментарии. Так сложно ответить, как исправить положение.

      Удалить
    4. ubuntu 16.04.2 64
      до этого установил opera-stable_44.0.2510.1218_i386.deb
      после после этого появильсь ошибки

      Удалить
    5. здесь вывод sudo apt-get -f install
      http://forum.ubuntu.ru/index.php?action=dlattach;topic=289017.0;attach=39398

      Удалить
    6. Теперь понятно откуда косяк.) Зачем Вы в ubuntu 16.04.2 64-bit устанавливаете i386.deb. Отсюда и шибки вылазят.
      Удалите эту opera-stable_44.0.2510.1218_i386.deb и всё что с ней связано.

      Удалить
  3. Ответы
    1. Перед смертью не надышишься.

      Удалить
    2. Мне, лично, до фонаря. Я Google Chrome использую.)

      Удалить
  4. ace stream.не могу включить .подскахите как. i 386.

    ОтветитьУдалить
  5. По совету Максима Пузырёва в строке поиска набрал firefox esr ppa. В открывшемся перечне выбрал Ask Ubuntu. A там: How to install Firefox ESR on 16.04?
    sudo add-apt-repository ppa: jonathon/firefox-esr
    sudo apt-get update
    sudo apt-get install firefox-esr
    Выполнил, в Synaptik удалил firefox 53 и активировал firefox-esr. И было мне счастье.

    ОтветитьУдалить