05 августа 2015

Установить GParted 0.23 - Редактор разделов ж/диска в Ubuntu 15.04/14.04 и призводные

 Приложение GParted (Gnome Partition Editor) предназначено для создания, изменения и удаления разделов жёсткого диска. Для работы с устройствами и таблицами разделов GParted использует библиотеку libparted. Для работы с редко используемыми файловыми системами, не поддерживаемыми libparted, есть другие инструменты.

  GParted предназначен для различных операций с разделами (и файловыми системами, находящимися на них), таких как: создание, уничтожение, изменение размера, перемещение, проверка и копирование. Это необходимо при создании пространства для новых операционных систем, реорганизации использования диска, копировании данных, находящихся на жёстких дисках, и зеркалировании одного раздела на другой (создании образа диска). Также существует Live CD версия программы — GParted-Live, выпускаемая командой разработчиков GParted с каждой новой версией этой программы.

Для Ubuntu 15.04/14.04 и призводных стала доступной стабильная версия GParted 0.23.


С помощью GParted можно выполнять следующие задачи:

  1. Создавать таблицы разделов на дисковом устройстве.
  2. Включать и отключать различные флаги разделов, такие как «загрузочный» (boot) или «скрытый» (hidden).
  3. Выполнять различные действия с разделами: создавать, удалять, изменять размер, перемещать, проверять на ошибки, устанавливать метки, копировать и вставлять.
 GParted работает со следующими устройствами хранения данных:

Жесткие диски (например, SATA, IDE и SCSI)
Устройства флэш-памяти, такие как карты памяти USB (флешки) и твердотельные накопителей (SSD-х)
RAID устройства (аппаратные RAID, BIOS материнские платы RAID, и программное обеспечение RAID Linux)
Все размеры секторов (например, устройства с 512, 1024, 2048, 4096 байт секторов и более) 

Примечание 1. С помощью GParted можно легко отформатировать флешку в нужный формат, как для хранения данных, так и для последующей записи iso-образа с дистрибутивом: Как правильно отформатировать флешку в Ubuntu/Linux Mint.

Предостережение

Редактирование разделов является потенциально опасной операцией, которая может привести к ПОТЕРЕ ДАННЫХ НА ЖЁСТКОМ ДИСКЕ.

Программа GParted позволяет редактировать разделы с минимальным риском потерять данные. Программа GParted была внимательно протестирована и используется командой проекта GParted, однако потеря данных все-таки возможна по другим причинам, связанным с проблемами с оборудованием, потерей питания от электрической сети и различными ошибками в программном обеспечении.
Чтобы снизить вероятность потери данных, не выполняйте операции монтирования и размонтирования разделов вне GParted во время работы GParted.
Рекомендуется СДЕЛАТЬ РЕЗЕРВНУЮ КОПИЮ ваших важных данных (документы, фото, видео и др. файлов) прежде чем работать с GParted.

 Установка GParted 0.23 в Ubuntu 15.04/14.04 и производные

Для установки GParted 0.23 в Ubuntu 14.04 необходимо подключить репозиторий getdeb и ключ к нему. Откройте терминал (Ctrl+Alt+T), скопируйте и выполните следующие команды:

wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu trusty-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'

sudo apt-get update
sudo apt-get install gparted


Установка в GParted 0.23 в Ubuntu 15.04

wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu vivid-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'

sudo apt-get update
sudo apt-get install gparted


Примечание 2. Если у вас уже установлена программа  GParted предыдущей версии, то удалять её не обязательно. Во время установки GParted 0.23 командами выше, версия будет перезаписана.

Программа GParted запускается только с правами администратора, т.е. перед запуском обязательно нужно ввести пароль. Вы можете открыть её из системного меню или выполнить команду в терминале:

sudo gparted

Как работать с GParted, можно почитав Руководство пользователя GParted.

Удачи.

11 комментариев :

  1. Работает прекрасно но только не для перемещения раздела с Виндовс

    ОтветитьУдалить
  2. А в чем отличие от стандартной версии (0.18) для 14.04 ?

    ОтветитьУдалить
    Ответы
    1. Любая новая версия программы прежде всего исправляет ошибки, от которых не застрахована ни одна программа.
      В данном релизе устранены ошибки (баги), устранена утечка памяти, добавлены переводы на различные языки, в том числе - русский.
      Вот как-то так.

      Удалить
  3. В 15.04 по командам не установилась. Установилась после замены в репозитарии trusty на vivid.

    ОтветитьУдалить
  4. Программа из категории обязательные, я ей с устновочной флешки создавал разделы перед установкой.

    ОтветитьУдалить
  5. Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    gparted : Зависит: libparted0debian1 (>= 2.2-1) но он не может быть установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    как это можно исправить?

    ОтветитьУдалить
    Ответы
    1. Скорее всего у Вас не Ubuntu 15.04/14.04 или производные от них. Будьте внимательны перед подключением репозитория и установкой программы.

      Удалить
    2. Я добавил в статье команды для 15.04.

      Удалить
  6. Приветствую, Владимир! Имею Mint 17.2 KDE64 с ядром 4.1.6. Попытка установки GParted привела к сообщению следующего вида:
    crazy andrew # apt-get install gparted
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    gparted : Зависит: libglibmm-2.4-1c2a (>= 2.42.0) но 2.39.93-0ubuntu1 будет установлен
    Зависит: libparted-fs-resize0 (>= 3.1) но он не может быть установлен
    Зависит: libparted2 (>= 3.1) но он не может быть установлен
    Зависит: libstdc++6 (>= 4.9) но 4.8.4-2ubuntu1~14.04 будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    Как победить?

    ОтветитьУдалить