01 октября 2013

Вышел Wine 1.7.3


Вышел очередной экспериментальный выпуск - Wine 1.7.3. С момента выпуска версии 1.7.2 было внесено 48 различных исправлений ошибок.

Наиболее важные изменения:
  1. Перевод интегрированного браузера на новую версию движка Gecko, используемую в Firefox 24;
  2. Подготовка к переходу на переработанный код поддержки Direct3D, позволяющий существенно поднять производительность некоторых игр на 50-100%. Ускорение достигается за счёт выноса из wined3d отдельного потока для взаимодействия с OpenGL, позволяющего выполнять отрисовку в асинхронном режиме с распараллеливанием на многоядерных системах.
  3. Внесены связанные с управлением окнами исправления в драйвер для OS X;
  4. Поддержка функций IPHLPAPI на платформе Android. 

 Установка Wine 1.7.3

Установка WineHQ 1.7.3 в Ubuntu 13.04/12.10/12.04 и Linux Mint 15/14/13.

Откройте терминал (Ctrl+Alt+T), скопируйте и выполните следующие команды:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.7 winetricks


Установка WineHQ 1.7.3 из исходников в Ubuntu 13.10 и Linux Mint 16

sudo apt-get install flex bison qt4-qmake
wget http://prdownloads.sourceforge.net/wine/wine-1.7.3.tar.bz2
tar -xjvf wine-1.7.*
cd wine-1.7.*


Для 32-bit:

./configure
cd tools; ./wineinstall


Для 64-bit:

./configure --enable-win64
cd tools; ./wineinstall



Удачи.

19 комментариев :

  1. у меня почему то на ubuntu 13.10 не обновляеться

    ОтветитьУдалить
    Ответы
    1. Потому что репозитьрий не поддерживает 13.10. Надо ставить из иходников. В инструкции ведь указано на это.

      Удалить
  2. опа, на 12.04 - sudo apt-get install wine1.7 winetricks
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Уже установлена самая новая версия winetricks.
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    wine1.7 : Зависит: wine1.7-i386 (= 1.7.3-0ubuntu1~ppa2) но он не будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    ОтветитьУдалить
    Ответы
    1. Попробуй выполнить эту команду для удавлетворения зависимостеё:

      sudo apt-get install -f

      Удалить
    2. Предыдущую версию Wine вынеси из системы, например для 1.6 будет так:

      sudo apt-get purge wine1.6*

      winetrick можешь не пуржить

      Удалить
  3. не помогает команда sudo apt-get install -f

    ОтветитьУдалить
  4. установи через синаптик пакет wine1.7-i386

    ОтветитьУдалить
  5. А минт 16 уже можно пущупать или нет? Просто написано про установку в 16-тый...

    ОтветитьУдалить
    Ответы
    1. Нет. Минт 16 "пощупать", как ты выразился, пока нет возможности. А то что в статье написано про установку в Mint 16, так это по тому, что он основан на пакетной базе Ubuntu 13.10 и с выходом Mint 16 можно будет использовать данную инструкцию для установки. Mint 16 выйдет в конце ноября.

      Удалить
  6. Этот комментарий был удален автором.

    ОтветитьУдалить
  7. Помогите решить проблему,при установке Wine ,пишет Настраивается пакет ttf-mscorefonts-installer , и больше установка не движется,,,
    Linux Mint 13 XFCE 4.10

    ОтветитьУдалить
    Ответы
    1. Это бывает, когда устанавливаешь wine через командную строку. Это происходит потому, что устанавливаемые вместе с Wine шрифты от майкрософт хоть и бесплатные, но не свободные, и для продолжения установки надо принять лицензию. Там должно где-то выскочить окошко терминала с текстом лицензии, поищи его. Возможно, оно есть, просто не активно (в фоне) или скрыто где-то "под спойлером" . С помощью tab переводищь фокус на "ok" и жмешь enter. Если никакого окошка почему-то не выскочило, может помочь установка Wine через Synaptic или Центр Приложений. Там всё то же самое происходит в графическом режиме, и окошко с подтверждением точно какое-нибудь будет.

      Удалить
    2. Если это вопрос ко мне, то порядочно. Как Unity появилась, так почти сразу и перешел.

      Удалить
  8. Спасибо , понял, окошко есть неактивное,я не знад что сим делать

    ОтветитьУдалить