23 апреля 2015

Релиз Ubuntu 15.04

Как известно дистрибутив Ubuntu 15.04 относится к релизам с краткосрочной поддержкой (9 месяцев), до января 2016 года и является своеобразным испытательным полигоном для предстоящего долгосрочного релиза - Ubuntu 16.04 LTS, который выйдет по утверждённому графику разработчиками Canonical в апреле 2016 года. Но это не значит, что дистрибутив Ubuntu 15.04 нельзя использовать как рабочую систему. Все релизы с краткосрочной поддержкой, также как и с долгосрочной - LTS (англ. Long Term Support; дословно «поддержка в течение длительного периода» - в течении 5-ти лет) являются полноценными операционными системами, с разницей лишь в сроках поддержки.

Что нового в Ubuntu 15.04?

Видимых новшеств в Ubuntu 15.04 не так уж и много. Связано это с тем, что команда Canonical в последнее время была больше сосредоточена на мобильной платформе Ubuntu Phone.

1. К наиболее визуально-заметным изменениям можно отнести возврат отображения локального меню приложений - LIM (локально интегрированное меню), т.е. также как в более ранних дистрибутивах меню в окне приложений теперь может отображаться не только при наведении на него курсора, но и постоянно. Переключить данную функцию можно в Параметры системы ->Оформление ->Режим ->В заголовке окна.


А также дополнительно в Редакторе dconf по адресу: com ->canonical -> unity необходимо активировать пункт always-show-menu:


2. Файловый менеджер Files версии 3.14 (бывший Nautilus) приносит несколько новых функций по умолчанию.

Так в контекстном меню менеджера задействована функйия - Open in Terminal (Открыть в терминале):


 Подключенные устройства выделены в левой колонке файлового менеджера:


Другие изменения:

Systemd заменяет Upstart
Ядро Linux версии 3.19.3
Поддержка GTK 3.14

Обновленные приложения:

    Nautilus 3.14.2;
    Firefox 37.0;
    Thunderbird 31.5.0;
    LibreOffice 4.4.1;
    Ubuntu Software Center 13.10;
    Gedit 3.10.4;
    Totem 3.14.2;
    Rhythmbox 3.1;
    Empathy 3.12.8;
    Transmission 2.84;
    Deja Dup 32;
    Shotwell 0.20.2;
    Brasero 3.12;
    Evince 3.14.2;
    GNOME Terminal 3.14.2;
    GNOME System Monitor 3.15.91;
    Eye of GNOME 3.14.3;
    GTK3+ 3.14.9.

Загрузить iso-образы с Ubuntu 15.04 и производные можно по следующим ссылкам:

http://cdimage.ubuntu.com/kubuntu/releases/15.04/release/ (Kubuntu)
http://cdimage.ubuntu.com/lubuntu/releases/15.04/release/ (Lubuntu)
http://cdimage.ubuntu.com/ubuntustudio/releases/15.04/release/ (Ubuntu Studio)
http://cdimage.ubuntu.com/ubuntu-gnome/releases/15.04/release/ (Ubuntu GNOME)
http://cdimage.ubuntu.com/ubuntukylin/releases/15.04/release/ (Ubuntu Kylin)
http://cdimage.ubuntu.com/ubuntu-mate/releases/15.04/release/ (Ubuntu MATE)
http://cdimage.ubuntu.com/xubuntu/releases/15.04/release/ (Xubuntu)

Удачных вам загрузок.

P.S. Настройка Ubuntu 15.04 идентична настройкам Ubuntu 14.04/14.10.

86 комментариев :

  1. Когда можно будет обновится с 14.04 или 14.10?

    ОтветитьУдалить
    Ответы
    1. Прямо сейчас.

      С 14.04 до 15.04 выполни следующее:

      1. Обновить менеджер обновлений.

      sudo apt-get install update-manager-core

      2. Открой файл на редактирование:

      sudo gedit /etc/update-manager/release-upgrades

      И замени lts (долгосрочный на нормальный):

      Prompt=lts на Prompt=normal

      3. Теперь выполни следующие команды в терминале, чтобы начать обновление Ubuntu:

      sudo apt-get update
      sudo do-release-upgrade -d

      или

      sudo apt-get dist-upgrade -d


      Обновление с 14.10 до 15.04:

      Открыть Параметры системы ->Программы и обновления -> вкладка Обновления и переключить на При доступности любой версии и нажать кнопку Обновить.
      Будет предложено обновиться до версии 15.04. Нажать кнопку Начать обновление.


      Удалить
    2. sudo sed -i 's/utopic/vivid/g' /etc/apt/sources.list
      sudo apt-get update
      sudo apt-get dist-upgrade
      давно уже можно. На твой страх и риск естественно,я так с 14.10 обновился пару недель назад.Всё норм,тока пара репозиториев(с темами и фолдер-колор) не обновились.

      Удалить
    3. ==Всё норм,тока пара репозиториев(с темами и фолдер-колор) не обновились==

      И не обновятся, потому, что сторонние репозитории лежат в папке /etc/apt/sources.list, а не в файле /etc/apt/sources.list
      Как говорится, здесь вам не Дебиан :)

      Удалить
    4. а как отменить/удалить sudo sed -i 's/utopic/vivid/g' /etc/apt/sources.list ?

      Удалить
    5. Поменять местами в команде vivid на utopic:

      sudo sed -i 's/vivid/utopic/g' /etc/apt/sources.list

      Удалить
    6. Как говорится, здесь вам не Дебиан :)

      Так я потом после обновления системы, в синаптике сторонние репы отредактировал.Большинство обновились но парочка не спешат )

      Удалить
    7. Не спешат, значит, репозиторий еще под новый дистрибутив не обновился, дело времени :)

      Удалить
  2. Обновился нормально, но при запуске обнаружил что слители все темы. В целом система стала чуть-чуть шустрее и удобнее. Но пропавшие темы жалко... :(

    ОтветитьУдалить
    Ответы
    1. Денис, в следующий раз нужно будет зайти в папку с темами /themes, скопировать их на флешку, а затем начать обновление. По окончании обновления опять встроить скопированные темы в обновлённый дистр. Вот и всё. :)

      Удалить
    2. Отличная идея, Владимир! Спасибо!)

      Удалить
    3. А еще лучше в хоум темы ставить. Поставил систему, а она уже сразу в твоём оформлении.

      Удалить
  3. дада, когда случится сие представление :)) ждемс с не терпеньем!!!

    ОтветитьУдалить
  4. Почему чертежная программа draftsight ужасно тормозит? Видеокарта AMD.

    ОтветитьУдалить
    Ответы
    1. draftsight требует ускоренную графику. Подключи (активируй) проприетарный драйвер, перезагрузись и попробуй.

      Удалить
    2. Проприетарный драйвер через настройки не устанавливается. Нажимаешь выбрать, но ничего не происходит загрузка и установка слетает

      Удалить
    3. Подозреваю что у Вас дистрибутив криво установился. Переустановите.

      Удалить
  5. Ответы
    1. ==ubuntu-tweak не устанавливается== Репозиторий ещё не индексирован для 15.04. Установи deb-пакетом:

      https://launchpad.net/ubuntu-tweak/0.8.x/0.8.7/+download/ubuntu-tweak_0.8.7-1%7Etrusty2_all.deb

      Удалить
    2. Спасибо! Если не сложно ткните носом где описано как флажки установить на раскладке клавиатуры

      Удалить
    3. Здесь: http://compizomania.blogspot.com/2013/11/ubuntu-1310.html

      Удалить
    4. ubuntu-tweak установил но он не запускается.

      Удалить
    5. Попробуйте запустить из терминала командой:

      ubuntu-tweak

      или

      sudo ubuntu-tweak

      Если не запустится, скиньте сюда вывод терминала.

      Удалить
    6. из терминала раз запустилось и всё. Повторно не запускается. Походу надо ждать чтоб подправили .

      Удалить
    7. Попробуйте переустановить ещё раз:

      https://launchpad.net/ubuntu-tweak/0.8.x/0.8.7/+download/ubuntu-tweak_0.8.7-1%7Etrusty2_all.deb

      Удалить
    8. И так работать не хочет. Ладно буду ждать пока подправят

      Удалить
    9. Если и ставить deb-пакетом, то наверное, лучше использовать версию не для trusty, а поновей, для utopic:
      https://launchpad.net/~ubuntu-tweak-testing/+archive/ubuntu/ppa/+files/ubuntu-tweak_0.8.8-0%7Ebzr1999%2B20150207%7Eubuntu14.10.1_all.deb
      Но подождать обновления репозитория будет разумнее, во избежание проблем с совместимостью.

      Удалить
    10. У меня с Ubuntu Tweak тоже косяк. Раз запускается,а потом только после перезагрузки или закрытия сеанса. Надо ждать версии для vivid.

      Удалить
    11. Прошло 4 дня так и не пофиксили..... А есть аналог ubuntu-tweak ?

      Удалить
  6. Написано, что ядро 3.19.3.
    Но стоит 3.19.0-15
    Или 15-ая версия включает все бэкпорты из 19.3?

    ОтветитьУдалить
    Ответы
    1. Совершенно верно. 15-ая версия включает все бэкпорты от Canonical для 3.19.3.

      Удалить
    2. "Ubuntu не использует ванильное ядро, а поддерживает свое, со своими патчами, а зачастую и бекпортирует что-либо с версий НОВЕЕ. Поэтому, чтобы не путаться с нумерацией ванильного ядра, они берут за основу мажорную и минорную версию ванильного ядра, а свою нумерацию пишут через дефис" (Цитата с Хабра).

      Удалить
  7. Вот думаю, как Mate будет себя вести на нетбуке 2012 года с интел атомом. А то винда 7-я там как то адово тупит :) Хотя диск SSD воткнул

    ОтветитьУдалить
    Ответы
    1. SSD это хорошо но мало, значительно важнее сколько памяти, если есть возможность добить до 4ГБ, то нетбук сможет получить новую жизнь)))

      Удалить
  8. Обновился с 14.10 на 15.04, ядро 3.16, как получить 3.19??

    ОтветитьУдалить
    Ответы
    1. Попробуйте выполнить эту команду:

      sudo apt-get install linux-generic-lts-vivid

      и перезегрузите компьютер.

      Удалить
    2. Ну или в Synaptic раздел "Ядро и модули". Или с http://kernel.ubuntu.com/~kernel-ppa/mainline/ скачать. Кому как нравится ))

      Удалить
  9. Скажите пожалуйста, можно ли с неё откатится на 14.04 лтс?
    И, если можно, то как?

    ОтветитьУдалить
  10. После обновления такая фигня http://s017.radikal.ru/i426/1504/d0/fc58f8a35d0a.png!

    ОтветитьУдалить
    Ответы
    1. Попробуйте обновить сервер Xorg следующей командой:

      sudo apt-get install xserver-xorg-lts-vivid

      И перезагрузить компьютер.
      Возможно это поможет.

      Удалить
    2. Это бывает, особенно с SVG-иконками. Думаю, ничего страшного, смените тему иконок. Возможно также, что и тема GTK несовместимая, ведь библиотеки обновились до версии 3.14, а тема старая осталась.

      Удалить
    3. Зчитування інформації про стан... Виконано
      E: Не можу знайти пакунок xserver-xorg-lts-vivid

      Удалить
  11. Поменял иконки и все норм стало! Спс!!!

    ОтветитьУдалить
  12. Я так понял все старые темы GTK можна удалять и искать до 3.14

    ОтветитьУдалить
    Ответы
    1. Если криво отображаются, то лучше удалить. Только не удаляй темы установленные по умолчанию.

      Удалить
  13. Неужели только я один не понимаю, для чего ставить промежуточную версию,
    да ещё и с бубном, парадокс.

    ОтветитьУдалить
    Ответы
    1. А нет ни какого парадокса. Просто хочется попробовать чего-то нового, это нормально. Так уж устроен человек.

      Удалить
  14. Настраивается пакет speech-dispatcher (0.8.1-0ubuntu1) …
    chown: невозможно получить доступ к «/var/log/speech-dispatcher»: Нет такого файла или каталога
    dpkg: ошибка при обработке пакета speech-dispatcher (--configure):
    подпроцесс установлен сценарий post-installation возвратил код ошибки 1
    dpkg: зависимости пакетов не позволяют настроить пакет gnome-orca:
    gnome-orca зависит от speech-dispatcher (>= 0.8), однако:
    Пакет speech-dispatcher пока не настроен.

    dpkg: ошибка при обработке пакета gnome-orca (--configure):
    проблемы зависимостей — оставляем не настроенным
    Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
    При обработке следующих пакетов произошли ошибки:
    speech-dispatcher
    gnome-orca
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Появляется ошибка всегда при установке чего-то из репозитория на примере caffeine

    ОтветитьУдалить
    Ответы
    1. Это вы про что? Типа: Бежали две собаки, к ним прибились ещё две, сколько кошек всего в Лондоне..? :)

      Удалить
  15. При установке любой программы: Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Уже установлена самая новая версия totem.
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 9 пакетов не обновлено.
    не установлено до конца или удалено 2 пакетов.
    После данной операции, объём занятого дискового пространства возрастёт на 0 B.
    Хотите продолжить? [Д/н]
    Настраивается пакет speech-dispatcher (0.8.1-0ubuntu1) …
    chown: невозможно получить доступ к «/var/log/speech-dispatcher»: Нет такого файла или каталога
    dpkg: ошибка при обработке пакета speech-dispatcher (--configure):
    подпроцесс установлен сценарий post-installation возвратил код ошибки 1
    dpkg: зависимости пакетов не позволяют настроить пакет gnome-orca:
    gnome-orca зависит от speech-dispatcher (>= 0.8), однако:
    Пакет speech-dispatcher пока не настроен.

    dpkg: ошибка при обработке пакета gnome-orca (--configure):
    проблемы зависимостей — оставляем не настроенным
    Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
    При обработке следующих пакетов произошли ошибки:
    speech-dispatcher
    gnome-orca
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    ОтветитьУдалить
    Ответы
    1. Вот теперь понятно. Если речь идёт о свеже-установленной Ubuntu 15.04, то это однозначно, что дистрибутив установился с ошибками. Надо просто переустановить Ubuntu 15.04,

      Удалить
  16. всем здрям! При удалении из корзины открывается nautilus, это баг или фишка :)

    ОтветитьУдалить
    Ответы
    1. Ни какого бага или фишки тут нет. Корзина находится в файловом менеджере, поэтому и открывается в нём. В корзину что попадает, файлы? Вот она и очищает файловую систему.

      Удалить
    2. а отключить это можно или нет?

      Удалить
  17. подскажите как установить fallback на 15.04?
    Юнити просто кумарит еще с 9.04 а Гном в оригинале не лучше

    ОтветитьУдалить
  18. вторые сутки крутиться хубунту на вм.
    различий так и не заметил по сравнению с 14.04

    ОтветитьУдалить
    Ответы
    1. В Xfce 4.12 изменений как-раз много по мелочи. Все вместе весьма заметно должно быть. Двухпанельный режим в Thunar, улучшенные превьюшки по Alt+tab, поддержка клиентских декораций в GTK3-приложениях. Добавлена полная поддержка Retina-дисплеев, улучшена поддержка мультимониторных конфигураций, добавлен новый "интелектуальный" режим скрытия панели, расширены настройки управления питанием, в диалогах настройки внешнего вида появились превьюшки, и т.д. Для такого консервативного DE порция улучшений и правда крупная.
      http://www.xfce.org/about/tour

      Удалить
    2. >>>>Двухпанельный режим в Thunar

      а как включить этот режим?

      я в 14.04 делал так:

      sudo add-apt-repository ppa:webupd8team/experiments
      sudo apt-get update
      sudo apt-get install thunar

      режим включается клавишей f3

      Удалить
    3. ==а как включить этот режим?==
      Тут я несколько ошибся - не двухпанельный режим, а "многовкладочный", сорри. А двухпанельный, видимо, можно будет установить из этого же репозитория, когда он обновится под vivid.

      Удалить
    4. >>>>а "многовкладочный"
      так этот и в 14.04 было.
      >>>А двухпанельный, видимо, можно будет установить из этого же репозитория, когда он обновится под vivid.
      как это сделать другим способом привел выше команду.

      Удалить
    5. ==так этот и в 14.04 было.==
      Да, многовкладочный интерфейс уже был - потому, что его бэкпортировали из разрабатываемого xfce 4.12, в ванильном 4.10 он не был предусмотрен, насколько я знаю.
      ==как это сделать другим способом привел выше команду==
      Каким "другим" способом? Если Вы о добавлении того экспериментального репозитория, то я, собственно, о нем и написал - когда обновится. Сейчас он поддерживает только 14.04 и 14.10.

      Удалить
  19. Всем доброго дня не обновляется ядро на 4.0 по инструкции

    Для 64-битной системы:
    1 cd /tmp/
    2 wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000_4.0.0-040000.201504121935_all.deb
    3 wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-headers-4.0.0-040000-generic_4.0.0-040000.201504121935_amd64.deb
    4 wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-vivid/linux-image-4.0.0-040000- generic_4.0.0-040000.201504121935_amd64.deb
    5 sudo dpkg -i linux-headers-4.0.0-*.deb linux-image-4.0.0-*.deb

    Хочу обновить, потому что прога radeon-profile не активирует вкладку fan control.

    После установки нового ядра, тупо остается старое...Помогите, может волшебное слово есть, какое?
    С уважением, Дмитрий

    ОтветитьУдалить
    Ответы
    1. Сколько систем Linux установлено на компьютере?

      Удалить
  20. Ответы
    1. Я не зря спросил, тогда войди в другую систему и обнови груб командой: sudo update-grub
      А затем перезагрузись в ту куда установил новое ядро и проверь версию: uname -r

      Удалить
  21. я так понимаю, судя по вопросу загрузчик надо обновить в той системе в котороЙ он установлен?

    ОтветитьУдалить
  22. Спасибо Владимир огромное! только что ядро заработало! и в программе radeon-profile активировалась функция fan control! теперь осталось обновить gallium nine драйвера поставить вайн и играть в WOT на карте radeon hd7790 с 2 гигами ddr5 на борту c фпс 40-70 на средне высоких настройках!
    Два долгих года матерился на видюху и сидел на винде! в игры то не играю почти, только изредка в танки!
    Удачи и процветания Вам, и вашему проекту!

    ОтветитьУдалить
    Ответы
    1. Теперь будете знать, что после установки нового ядра загрузчик надо обновить в той системе в котороЙ он установлен, если их две и более.
      Признателен за благодарность. :)

      Удалить
  23. не заводится с ядром 3.19. на 3,16 всё работает. полагаю из за видеокарты nvidia geforce 8100. Драйвера novueau. Что делать?

    ОтветитьУдалить
    Ответы
    1. Странный вопрос однако: "Что делать?" Перейти на ядро 3,16 где всё работает. Ну, на "худой конец" купить видюху помощней или железяку сменить. :)

      Удалить
  24. Этот комментарий был удален автором.

    ОтветитьУдалить
    Ответы
    1. можно попробовать колесико мыши крутануть

      Удалить
  25. режим презентации в последних версиях убунту и производных.
    что за функция?
    случайно не типа Caffeine Plus?

    ОтветитьУдалить
  26. Хм, а мне кажется, наоборот. Upstart заменили на Systemd. Или нет?

    ОтветитьУдалить
    Ответы
    1. А что разве в статье не так?
      Другие изменения:

      Systemd заменяет Upstart

      Удалить
    2. Systemd [что делает?] заменяет [кого или что?] Upstart
      Все верно в статье.

      Удалить
  27. А загрузочный экран плимут все ломается от версии к версии при установке проприетарных драйверов nvidia. А старый метод оживить не помогает, задолбало.

    ОтветитьУдалить
  28. Попробую на ноуте. Станцию бомбить стремно. Уж больно противоречивый дист. Тем более он в бета глюков ловил не меряно. У меня на ноуте жил не более дня. То видео, то ви-фи, то просто слетает загрузка (ефи). Завтра на ноут протестю. Потом пару месяцев подожду.

    ОтветитьУдалить
  29. Подскажите, пожалуйста, следующее:
    в 15.04 разделы ntfs других дисков подключаются автоматом. А в 14.04 только после ввода пароля sudo. Как в 14.04 автоматизировать данный процесс? И что-то в mtab и fstab не нашёл информации о дисках ntfs - где же она ?Спасибо.

    ОтветитьУдалить
  30. Здравствуйте! Мать ASUS P5K64 WS, раритет почти. Решил попробовать Ubuntu 15.04. Из Винды на флешку пишу образ с помощью unetbootin - после перезагрузки черный экран и мигающий курсор, дальше не идет. С помощью UltraISO - тоже самое. Убунты 12 и 14 запуск установки нормаль. Заметил, что Boot Sector для 15.04 версии 6, а для 12 и 14 - 4 версия. Подскажите, пожалуйста, можно что то сделать или на эту мать новые версии Убунту уже не поставить? Спасибо!

    ОтветитьУдалить
  31. ==Подскажите, пожалуйста, можно что то сделать или на эту мать новые версии Убунту уже не поставить?== Видать старовато железо для новых дистрибутивов. (

    ОтветитьУдалить
  32. Владимир, благодарю. Все течет и меняется и где то все заканчивается. LnuxMint пока выручает, может кризис и переживем.

    ОтветитьУдалить
  33. MultiSystem. 15.04 установилась на счет раз. И мать не при чем. Даже драйвер на старую видюху NVIDIA 7300GT работает. А с помощью Unetbootin или "создание загрузочного диска", а тем более dd - загрузки нет.

    ОтветитьУдалить