15 декабря 2013

Установить универсальный конвертер файлов - FF Multi Converter в Ubuntu/linux Mint

FF Multi Converter представляет собой полезный инструмент с графическим интерфейсом для преобразования различных форматов файлов: аудио, видео, изображений и документов.
Очень часто исходные информационные материалы (файлы) не соответствуют требованиям для конечной задачи их создания, тогда и возникает необходимость конвертирования — преобразования одного формата файла в другой. Одним из лучших приложений этого плана является FF Multi Converter.



Возможностеи FF Multi Converter:

Аудио и видео: aac; ac3; afc; aiff; amr; asf; au; avi; dvd; flac; flv; mka; mkv; mmf; mov; mp3; mp4; mpg; ogg; ogv; psp; rm; spx; vob; wav; webm; wma; wmv; и другие, поддерживаемые ffmpeg.

Изображения: bmp; cgm; dpx; emf; eps; fpx; gif; jbig; jng; jpeg; mrsid; p7; pdf; picon; png; ppm; psd; rad; tga; tif; webp; xpm.

Документы: doc --> (odt, pdf); html --> (odt); odp --> (pdf, ppt); ods --> (pdf); odt --> (doc, html, pdf, rtf, sxw, txt, xml); ppt --> (odp); rtf --> (odt); sdw --> (odt); sxw --> (odt); txt --> (odt); xls --> (ods); xml --> (doc, odt, pdf).

Язык интерфейса: мультиязычный, включая русский

Установка FF Multi Converter

Установка предназначена для следующих дистрибутивов:

Ubuntu 13.10 и старше
Linux Mint 16 и старше

Откройте терминал (Ctrl+Alt+T), скопируйте и выполните следующие команды:

sudo add-apt-repository ppa:ffmulticonverter/stable
sudo apt-get update
sudo apt-get install ffmulticonverter

После установки вы найдёте FF Multi Converter в программах Аудио и видео или поиском в меню:


Домашняя страница: https://sites.google.com/site/ffmulticonverter/

Удачи.

29 комментариев :

  1. Для работы с документами требует установки пакета unoconv.
    "This package provides a commandline utility which can convert from any document format that LibreOffice can import to any document format
    it can export. It uses LibreOffice's UNO bindings for non-interactive conversion of documents."

    ОтветитьУдалить
    Ответы
    1. Так нет проблем. Установить пакет unoconv:

      sudo apt-get install unoconv

      Удалить
    2. Так и установила) Ещё не пробовала видео и аудио, может ещё чего будет просить?

      Удалить
    3. Нет, больше ничего не просит, только над аудио долго думает.

      Удалить
    4. На то оно и аудио, это же не текст. Видео - еще более ресурсоемкая вещь (за исключением случаев, когда меняется только "контейнер" без перекодирования содержимого).

      Удалить
    5. Отчитываюсь: за 4 минуты - 0%. Это слишком. И, похоже, зависает. Полный фейл с аудио. Не огорчаюсь, это всего лишь тест работы программы.

      Удалить
    6. >>Отчитываюсь: за 4 минуты - 0%.<<
      Ну да, перебор :). Это всего лишь оболочка для ffmpeg. А с тех пор, как в Убунту стали заменять ffmpeg на "инновационный" avconv везде где только можно и где нельзя, иногда возникают проблемы с совместимостью. Но это лишь мое предположение.

      Удалить
    7. З.Ы. Татьяна, позволю себе дать Вам ссылочку по теме avconv/libav vs ffmpeg, если интересует, почему такие программы иногда отказываются работать. Заодно потренируете свой английский :)
      http://blog.pkh.me/p/13-the-ffmpeg-libav-situation.html

      Удалить
    8. Ох, Максим, Вы переоцениваете мои способности к изучению Линукс) Так глубоко только Вы с Владимиром изучаете, но я пройдусь по ссылке обязательно.
      PS: Мне приятно, что Вы помните о моих попытках "быть на уровне" в языке. Систему на русском ни в жисть не поставлю. :)
      Как Вы думаете, стоит установить Майю с обновлениями Petra? У меня для этих целей место на диске оставлено. Любопытно мне... Live же не увижу ничего. Стоит оно того?

      Удалить
    9. В познавательных целях - нужно, если желание есть. А в мае выйдет LTS - долгосрочный релиз.

      Удалить
    10. Я, наверное, не буду устанавливать, просто загляну в 13 c live.
      В статье по ссылке Максима вычитала "huge egos"... Короче, все перессорились из-за большого ума и в результате мы имеем недружелюбные программы.

      Удалить
    11. >>Как Вы думаете, стоит установить Майю с обновлениями Petra?<<
      Ой, сложно сказать... Я довольно далек от Mint последнее время, и вообще, большой разницы между Xubuntu и Mint XFCE как-то не чувствую. XFCE оно и в Африке XFCE. В плане стабильности переход на LTS может дать определенный выигрыш, но, с другой стороны, и следующий LTS уже не за горами, если разобраться... Всё в Ваших руках. Если на диске есть место и если любопытно, дерзайте :) Женское любопытство - великая сила :), как и всякое любопытство.

      Удалить
    12. Как хорошо находиться среди умных мужчин! Я уже прочла у Володи про май, подожду. Идея LTS не даёт покоя.
      Наберусь терпения. А Майю скачиваю, добавлю в Мультибут и удовлетворю своё любопытство.

      Удалить
    13. Все промежуточные релизы в Ubuntu/Linux Mint служат для отладки и подготовки перед выпуском долгосрочного - LTS, который, как правило, более стабилен и отполирован.

      Удалить
    14. Владимир, для удаления репозитория так нужно писать: sudo add-apt-repository remove ppa:ffmulticonverter/stable ?

      Удалить
    15. не remove, а --remove, с двумя черточками, add-apt-repository - это сама команда, а --remove - это её параметр. Все параметры обычно с черточками, "многобуквенные" с двойными, "однобуквенные" с одинарными.

      Удалить
    16. Да, эта команда правильная для Ubuntu, но в Linux Mint лучше удалять репозитории вручную а Источники приложений. Попробуйте выполнить команду, если терминал ответит, что невозможно удалить репозиторий, то тогда Источники приложений. В Источники приложений клик на строке с репозиторием и внизу кнопка Удалить, вводите пароль, и репозиторий исчезнет.

      Удалить
    17. >>но в Linux Mint лучше удалять репозитории вручную а Источники приложений<<
      Кстати да. Минт он такой.

      Удалить
    18. Я потому спросила, что написала с чёрточками, как показал Максим, терминал выдал, что такой команды не существует. Команду без чёрточек принял, я заглянула для убедительности в менеджер - всё на месте. Значит, вручную, и ключи тоже? Спасибо.

      Удалить
    19. >>Значит, вручную, и ключи тоже?<<
      Я бы ключи не удалял. Есть они не просят, систему не замедляют. Вдруг пригодится :)

      Удалить
  2. Ответы
    1. Впредь не буду удалять ключи (( Буду знать теперь.

      Удалить
  3. Что то не хочет конвертировать, пишет что не установлены ffmpeg и avconv. Может для ксубунты он не подходит? Дайте на всякий случай терминальную команду для удаления со всеми закаченными зависимостями.

    ОтветитьУдалить
    Ответы
    1. Нужно установить пакет FFmpeg и avconv:

      sudo apt-add-repository ppa:jon-severinsson/ffmpeg
      sudo apt-get update
      sudo apt-get install ffmpeg avconv

      И будет конвертировать.

      Удалить
    2. Неа,
      репозиторий подключился, апдейт прошёл, после следующей команды на инсталяцию - терминал выдал: пакет avconv не обнаружен.
      Ну и прога снова выдала:
      Ни ffmpeg, ни avconv не обнаружены.
      Вы не сможете конвертировать аудио/видео файлы пока не установите одну из этих программ.

      В чём затык и как исправить?

      Удалить
  4. в мене працює з mp3 в wav без проблем і швидко

    ОтветитьУдалить
  5. как его в 16.04 установить?

    ОтветитьУдалить
    Ответы
    1. ==как его в 16.04 установить?==Deb-пакетом:
      https://launchpad.net/~ffmulticonverter/+archive/ubuntu/stable/+files/ffmulticonverter_1.6.0-1~ppa2~ubuntu14.10.1_all.deb

      Удалить