05 ноября 2013

Установить последнюю версию проприетарного драйвера ATI в Ubuntu 13.10/linux Mint 16

Для чего нужно устанавливать проприетарный драйвер?

Вопрос не такой простой и наивный, каким кажется на первый взгляд. При эксплуатации новой серии видеокарт (как и при использовании самого драйвера) выявляются определённые ошибки, как у драйверов, так и у самой видеокарты, что производитель и пытается исправить с помощью новых драйверов. В новых драйверах часто решаются проблемы с производительностью в играх, т.е. увеличиивают производительность и значительно сокращают время загрузки игр на компьютерах с операционной системой Linux.

Выввод. Если ваша система работает стабильно и вы не являетесь заядлым геймером, то скорее всего нет необходимости в установке проприетарных версий драйвера.
Но если вы не в восторге от графической производительности вашего компьютера или проблемы с воспроизведением некоторых игр, вы всегда можете установить проприетарные драйверы ATI в Ubuntu/linux Mint .

Ниже приводится два варианта для установки проприетарного драйвера ATI:

1. Для установки более новых видеокарт.
2. Второй вариант для видеокарт, скажем так, не первой свежести.

Установка проприетарного драйвера ATI в Ubuntu/Linux Mint.

1. Для новых видеокарт.

Откройте терминал (Ctrl+Alt+T), скопируйте и выполните следующие команды:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install fglrx-installer


По завершинии установки необходимо перезагрузить компьютер для активации драйвера.

После нового входа в ситему проверьте используемый драйвер: Параметры системы ->Программы и обновления ->Дополнительные драйверы.

2. Если у вас видеокарта довольно старая и установка по первой инструкции не работает, то выполните следующие команды:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy


И также следует перезагрузить компьютер для активации драйвера.

Удачи.

23 комментария :

  1. Вижу, есть как дельные советы так и не очень. не всем подходит этот метод установки.

    ОтветитьУдалить
    Ответы
    1. А какие ещё есть? Может предложите фал .run с сайта скачать?

      Удалить
  2. Установил способом 1
    И сейчас проблема, при старте собщение the system is running in low -graphics mode
    Жму ок и новое окно с возможностью вибора далнейших действий( результату от них ноль
    как откатить систему назад?

    ОтветитьУдалить
    Ответы
    1. Доступа к терминалу нету(

      Удалить
    2. Ctrl+Alt+F2 - должна загрузиться консоль

      Удалить
  3. всегда использовал *.run-файл с сайта амд.
    это что, не кошерно, что ли?!
    проблем нет.

    ОтветитьУдалить
    Ответы
    1. Я тоже и проблем нету. http://4put.ru/pictures/max/770/2367909.jpg

      Удалить
  4. fglrx-legacy не доступен для Ubuntu 13.10 из репозитория, не вводите людей в заблуждение.
    Единственно работающий (пропатченный) проприетарный драйвер для AMD HD2000-4000 пока доступен только для 64-битной Ubuntu 13.10 вот:
    http://ubuntuone.com/1W4B3qa09OB82avCw9kDvP
    http://ubuntuone.com/5fly8Ur8c2PKvUYh2f6V8Z
    http://ubuntuone.com/7HbTMeib9RskH21Qrjv9rl

    И еще, ATI уже давно не существует!

    ОтветитьУдалить
    Ответы
    1. Но, к сожалению, при установке выдаёт ошибку
      Неразрешимая зависимость: fglrx-amdcccle-legacy

      Ну и пакета такого не находит...

      Удалить
  5. $ sudo apt-get install fglrx-installer
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    E: Не удалось найти пакет fglrx-installer

    Нерабочая инструкция какая-то.
    Mint 16 x64.

    ОтветитьУдалить
    Ответы
    1. Всем привет!

      Инструкции выше мне не помогли, возникала ошибка, которая указана постом выше. Через 2 часа копаний в интернете я все-таки догодался посмотреть инструкцию установки дров на оф сайте и смог нормально установить этот ATI драйвер на свою видюшку hd 7870(больше никогда не куплю радион). Я решил установить дрова с оф сайта амд http://support.amd.com/ru-ru/download/desktop?os=Linux+x86, лично я выбрал бету. Итак пошаговая инструкция:
      1. Скачиваем и разархивируем в удобную Вам папку дрова http://support.amd.com/ru-ru/download/desktop?os=Linux+x86 ( я выбрал бету и разархивировал дрова в папку Документы)
      2. Установить через терминал сделующие пакеты - 1. sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms libQtGui4, 2. sudo ln -s /usr/lib/libstdc++.so.6 /usr/lib/libstdc++.so.5.
      3. В терминале прописываем путь до файла с уже разархивированными дровами (у меня cd Документы).
      4. В терминале прописываем команду sudo sh (название .run файла) у меня sudo sh amd-catalyst-13.11-betaV9.95-linux-x86.x86_64.run.
      5. Появляется окно установки каталист, где выбираем первый пункт и нажимаем продолжить(без второго пункта у меня появлялось сообщение о том, что для установки не хватает каких-то пакетов). По окончанию установки делаем ребут.
      6. Находим в установленных программах каталист центр с правами администратора и копаемся в настройках каталиста, после чего все будет работать отлично :) (без копания в настройках каталиста, лично у меня после установки дров особо ничено не поменялось).

      Надеюсь, хоть кому-то сэкономил время.

      Удалить
  6. Всем привет!

    Инструкции выше мне не помогли, возникала ошибка, которая указана постом выше. Через 2 часа копаний в интернете я все-таки догодался посмотреть инструкцию установки дров на оф сайте и смог нормально установить этот ATI драйвер на свою видюшку hd 7870(больше никогда не куплю радион). Я решил установить дрова с оф сайта амд http://support.amd.com/ru-ru/download/desktop?os=Linux+x86, лично я выбрал бету. Итак пошаговая инструкция:
    1. Скачиваем и разархивируем в удобную Вам папку дрова http://support.amd.com/ru-ru/download/desktop?os=Linux+x86 ( я выбрал бету и разархивировал дрова в папку Документы)
    2. Установить через терминал сделующие пакеты - 1. sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms libQtGui4, 2. sudo ln -s /usr/lib/libstdc++.so.6 /usr/lib/libstdc++.so.5.
    3. В терминале прописываем путь до файла с уже разархивированными дровами (у меня cd Документы).
    4. В терминале прописываем команду sudo sh (название .run файла) у меня sudo sh amd-catalyst-13.11-betaV9.95-linux-x86.x86_64.run.
    5. Появляется окно установки каталист, где выбираем первый пункт и нажимаем продолжить(без второго пункта у меня появлялось сообщение о том, что для установки не хватает каких-то пакетов). По окончанию установки делаем ребут.
    6. Находим в установленных программах каталист центр с правами администратора и копаемся в настройках каталиста, после чего все будет работать отлично :) (без копания в настройках каталиста, лично у меня после установки дров особо ничено не поменялось).

    Надеюсь, хоть кому-то сэкономил время.

    ОтветитьУдалить
  7. Кто знает,сейчас есть возможность установить драйвера на ATI radeon x1300? Или смысла нет искать их вообще?

    ОтветитьУдалить
    Ответы
    1. Артём, возможно эта инструкция поможет: https://help.ubuntu.com/community/RadeonDriver

      Удалить
    2. Попробую перевести, c английским не очень хорошо)

      Удалить
    3. Гуглопереводчик Вам в помощь. :)

      Удалить
    4. Ага спасибо) если бы переводчик от гугла, не был таким кривым, ему бы вообще цены не было=)

      Удалить
    5. А вообще есть ли смысл ставить проприетарные драйвера? Дело в том что у меня сечас в списке драйверов, написано дополнительные драйвера отсутствуют. Как это скажется на работе системы в целом. В первый раз сталкиваюсь с таким, имею ввиду с драйверами на ati под linux.

      Удалить
    6. ==А вообще есть ли смысл ставить проприетарные драйвера?== Проприетарные драйверы нужны в системе, если вы играете в игры, для 3D-ускорения, которое выполняет графические операции системы, т.е. улучшает графику в играх. В остальном проприетарные драйверы не нужны.

      Удалить