14 сентября 2013

Установить VMware Player 6.0.0 в Ubuntu/Linux Mint

Вышел бесплатный для некоммерческого использования вариант виртуальной машины VMWare Workstation - VMware Player 6.0. VMware Player - это самый удобный способ одновременно запустить несколько ОС на одном компьютере. Благодаря удобному интерфейсу VMware Player можно с легкостью попробовать Windows 8, Windows 7, Chrome OS, последние выпуски Linux или создать изолированные виртуальные машины для безопасного испытания нового программного обеспечения.




Из новшеств, специфичных для VMware Player 6.0 отмечается режим упрощённого интерфейса, при котором скрывается меню и недоступны для изменения настройки.

Установка VMware Player 6.0 в Ubuntu/Linux Mint 

Прежде всего установите некоторые зависимости следующей командой:

sudo apt-get install build-essential linux-headers-`uname -r`


Далее непосредственная установка VMware Player.


Для 32-bit систем выполните следующие команды:

mkdir ~/VMware && cd ~/VMware

wget -c http://goo.gl/QTHVtv -O VMware-Player-6.0.0-1295980.i386.bundle.tar

tar -xvf VMware-Player-6.0.0-1295980.i386.bundle.tar

chmod +x VMware-Player-6.0.0-1295980.i386.bundle

sudo sh VMware-Player-6.0.0-1295980.i386.bundle


 Для 64-bit систем следующе:

mkdir ~/VMware && cd ~/VMware

wget -c http://goo.gl/JpvULv -O VMware-Player-6.0.0-1295980.x86_64.bundle.tar

tar -xvf VMware-Player-6.0.0-1295980.x86_64.bundle.tar

chmod +x VMware-Player-6.0.0-1295980.x86_64.bundle

sudo sh VMware-Player-6.0.0-1295980.x86_64.bundle


И следуйте инструкциям установки.

По окончании установки вы найдёте VMware Player в программах Системные утилиты или поиском в меню Даш:




Удачного вам тестирования.

28 комментариев :

  1. а как его удалить? Без остатков

    ОтветитьУдалить
    Ответы
    1. Установить из Центра приложений Synaptic, открыть его, ввести в поле поиска VMware-Player-6.0.0 и удалить все пакеты связанные с ним.

      Удалить
    2. Или так же, как при установке,только

      sudo ./VMware-Player-6.0.0-1295980.i386.bundle --uninstall-product vmware-player

      (насчет точности наименования удаляемого продукта "vmware-player" не уверен, сам не пробовал, но недавно удалял VMware Workstation похожим образом. Можно ввести sudo ./VMware-Player-6.0.0-1295980.i386.bundle --uninstall-product , нажать ввод, она выдаст ошибку и сама предложит наименование удаляемого продукта как недостающий аргумент).

      Для 64 по аналогии.

      Удалить
    3. sudo: ./VMware-Player-6.0.0-1295980.x86_64.bundle: команда не найдена

      Удалить
  2. Установил в U13.04. Все на английском, возможно ли русифицировать?

    ОтветитьУдалить
  3. А что за лицензионный ключ? В виндовой версии такого не помню.

    ОтветитьУдалить
  4. Здравствуйте , следую инструкции все сделал, потом как начал устанавливать то выходит такая ошибка

    ERROR
    Unable to start services
    See log file /tmp/vmware-root/vmware-modconfig-2305.log for details

    помогите, что как , благодарен заранее

    ОтветитьУдалить
  5. Ответы
    1. Видимо компилятор gcc не установлен. Попробуйте установить его следующей командой в терминале:

      sudo apt install gcc

      А затем ещё раз повторить установку VMware Player.

      Удалить
  6. Не хватает пакета gcc 5.2.1, вы бы могли подсказать репозитарий из которого можно его установить и заменить на старый, сейчас у меня в системе установлен gcc version 4.8.5 (Ubuntu 4.8.5-2ubuntu1~14.04.1), проверял командой gcc -v. Спасибо.

    ОтветитьУдалить
    Ответы
    1. Здесь можно загрузить пакет с gcc 5.2.1: http://packages.ubuntu.com/wily/gcc-5

      Удалить
    2. Скачал, подскажите а как можно скомпилировать и установить ? ./configure && make && make install не работает... (

      Удалить
    3. Зачем чего-то компилировать, когда там есть ссылки в самом низу страницы http://packages.ubuntu.com/wily/gcc-5 на загрузку deb-пакетов для раных архитектур: amd64 и i386. Выберите нужную, кликните на ней и загрузите с любого зеркала, которые придлагаются. И установите. Вот и всё!

      Удалить
    4. Владимир, благодарю. Вечер, устал...

      Удалить
    5. Веселье продолжаеться...
      dpkg -i '/home/ahriman/Загрузки/gcc-5_5.2.1-22ubuntu2_amd64.deb'
      dpkg: предупреждение: снижение версии gcc-5 с 5.3.0-3ubuntu1~14.04 до 5.2.1-22ubuntu2
      (Чтение базы данных … на данный момент установлено 205918 файлов и каталогов.)
      Подготовка к распаковке …/gcc-5_5.2.1-22ubuntu2_amd64.deb …
      Распаковывается gcc-5 (5.2.1-22ubuntu2) на замену (5.3.0-3ubuntu1~14.04) …
      dpkg: зависимости пакетов не позволяют настроить пакет gcc-5:
      gcc-5 зависит от cpp-5 (= 5.2.1-22ubuntu2), однако:
      Версия cpp-5 в системе 5.3.0-3ubuntu1~14.04.
      gcc-5 зависит от gcc-5-base (= 5.2.1-22ubuntu2), однако:
      Версия gcc-5-base:amd64 в системе 5.3.0-3ubuntu1~14.04.
      gcc-5 зависит от binutils (>= 2.25.1), однако:
      Версия binutils в системе 2.24-5ubuntu14.
      gcc-5 зависит от libgcc-5-dev (= 5.2.1-22ubuntu2), однако:
      Версия libgcc-5-dev:amd64 в системе 5.3.0-3ubuntu1~14.04.
      gcc-5 зависит от libisl13 (>= 0.13), однако:
      Пакет libisl13 не установлен.

      dpkg: ошибка при обработке пакета gcc-5 (--install):
      проблемы зависимостей — оставляем не настроенным
      Обрабатываются триггеры для man-db (2.6.7.1-1ubuntu1) …
      При обработке следующих пакетов произошли ошибки:
      gcc-5

      Удалить
    6. Ну так терминал же сообщил, что пакет libisl13 не установлен, поэтому его нужно установить:
      sudo apt install libisl13
      И повторить установку.
      Либо выполнить команду на удовлетворение зависимостей:
      sudo apt-get install -f
      Удачи.

      Удалить
    7. Эх да если бы )
      sudo apt install libisl13
      Чтение списков пакетов… Готово
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      Пакет libisl13 недоступен, но упомянут в списке зависимостей другого пакета.
      Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

      E: Для пакета «libisl13» не найден кандидат на установку
      Ну тут как бы понятно скачал тут http://packages.ubuntu.com/wily/amd64/libisl13/download, установил проверил:
      dpkg -l | grep libisl13
      ii libisl13:amd64 0.14-2 amd64 manipulating sets and relations of integer points bounded by linear constraints


      dpkg -i '/home/ahriman/Загрузки/gcc-5_5.2.1-22ubuntu2_amd64.deb'
      dpkg: предупреждение: снижение версии gcc-5 с 5.3.0-3ubuntu1~14.04 до 5.2.1-22ubuntu2
      (Чтение базы данных … на данный момент установлено 205923 файла и каталога.)
      Подготовка к распаковке …/gcc-5_5.2.1-22ubuntu2_amd64.deb …
      Распаковывается gcc-5 (5.2.1-22ubuntu2) на замену (5.3.0-3ubuntu1~14.04) …
      dpkg: зависимости пакетов не позволяют настроить пакет gcc-5:
      gcc-5 зависит от cpp-5 (= 5.2.1-22ubuntu2), однако:
      Версия cpp-5 в системе 5.3.0-3ubuntu1~14.04.
      gcc-5 зависит от gcc-5-base (= 5.2.1-22ubuntu2), однако:
      Версия gcc-5-base:amd64 в системе 5.3.0-3ubuntu1~14.04.
      gcc-5 зависит от binutils (>= 2.25.1), однако:
      Версия binutils в системе 2.24-5ubuntu14.
      gcc-5 зависит от libgcc-5-dev (= 5.2.1-22ubuntu2), однако:
      Версия libgcc-5-dev:amd64 в системе 5.3.0-3ubuntu1~14.04.

      dpkg: ошибка при обработке пакета gcc-5 (--install):
      проблемы зависимостей — оставляем не настроенным
      Обрабатываются триггеры для man-db (2.6.7.1-1ubuntu1) …
      При обработке следующих пакетов произошли ошибки:
      gcc-5



      Удалить
    8. sudo apt-get install -fЧтение списков пакетов… Готово
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      Исправление зависимостей… Готово
      Будут установлены следующие дополнительные пакеты:
      gcc-5
      Предлагаемые пакеты:
      gcc-5-multilib gcc-5-doc gcc-5-locales libgcc1-dbg libgomp1-dbg libitm1-dbg
      libatomic1-dbg libasan2-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg
      libcilkrts5-dbg libmpx0-dbg libquadmath0-dbg
      Пакеты, которые будут обновлены:
      gcc-5
      обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
      не установлено до конца или удалено 1 пакетов.
      Необходимо скачать 0 B/25,7 MB архивов.
      После данной операции, объём занятого дискового пространства возрастёт на 98,9 MB.
      Хотите продолжить? [Д/н] Д
      (Чтение базы данных … на данный момент установлено 205924 файла и каталога.)
      Подготовка к распаковке …/gcc-5_5.3.0-3ubuntu1~14.04_amd64.deb …
      Распаковывается gcc-5 (5.3.0-3ubuntu1~14.04) на замену (5.2.1-22ubuntu2) …
      Обрабатываются триггеры для man-db (2.6.7.1-1ubuntu1) …
      Настраивается пакет gcc-5 (5.3.0-3ubuntu1~14.04) …

      Удалить
    9. Ну так что, установилось или нет? Непонятно.
      Одно замечание (к сведению) по выполнению команд в терминале. Когда терминал задаёт вопрос: Хотите продолжить? [Д/н]. Не обязательно вводить Д-заглавную. Т.к. в вопросе [Д/н] Д уже заглавная, можно сразу надать клавишу Ввод.

      Удалить
    10. Не как нет товарищ комрад... Сижу бороду подпираю...

      Удалить
    11. Ну вот и ладненько. :)
      Только у нас говорят не"товарищ комрад", а amigo mio :)))

      Удалить
  7. Этот комментарий был удален автором.

    ОтветитьУдалить