27 сентября 2013

Установить/обновить ядро Linux Kernel 3.11.2 (Stable) в Ubuntu/Linux Mint


Linux Kernel 3.11.2 является вторым корректировочным выпуском ядра серии 3.11. Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu.  Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале:



Установить это ядро версии 3.11.2 командами ниже, можно ​​в следующих дистрибутивах Linux:

    Ubuntu 13.04/12.10/12.04 и старше
    Linux Mint 15/14/13 и старше


Установка ядра Linux Kernel 3.11.2

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера, на свой страх и риск:

Для 32-bit (одной командой):

cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.2-saucy/linux-headers-3.11.2-031102-generic_3.11.2-031102.201309262136_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.2-saucy/linux-headers-3.11.2-031102_3.11.2-031102.201309262136_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.2-saucy/linux-image-3.11.2-031102-generic_3.11.2-031102.201309262136_i386.deb && sudo dpkg -i *.deb

Для 64-bit (одной командой):

cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.2-saucy/linux-headers-3.11.2-031102-generic_3.11.2-031102.201309262136_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.2-saucy/linux-headers-3.11.2-031102_3.11.2-031102.201309262136_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.2-saucy/linux-image-3.11.2-031102-generic_3.11.2-031102.201309262136_amd64.deb && sudo dpkg -i *.deb

2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной)

sudo update-grub

Примечание 1. Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой:


uname -r



Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 3.11.2, выполните эту команду:

sudo apt-get purge linux-image-3.11.2*



Источник: https://www.kernel.org/

Удачи.

 Если у вас появились вопросы, обращайтесь на наш форум:  http://compizomania.54672.x6.nabble.com/

36 комментариев :

  1. Ээээммммм.......Вопрос конечно не по теме,но всё ж рискну:Ubuntu видит беспроводную сеть и подключается к ней,но вот в интернет не ходит.Могут ли быть проблемы со стороны ядра?Стоит 12.04.3 с ядром 3.2.51-generic-pae

    ОтветитьУдалить
    Ответы
    1. Cо стороны ядра, не думаю, т.к.ядро родное. Тут надо смотреть в настройках сети.

      Удалить
    2. А что именно копать то?Винда с андроидом на ура подключились.Эта же заартачилась.

      Удалить
    3. Попробуй следующее:
      1. Подключись к сети "верёвкой"
      2. Открой терминал и выполни следующие команды:

      sudo apt-get install bcmwl-kernel-source
      sudo modprobe wl

      3. Отсоедини "верёвку" и проверь WiFi.

      Удалить
    4. На всякий случай проверьте в настройках беспроводной сети пункт защита, должен совпадать с настройками роутера и еще посмотреть в настройках WiFi роутера какой канал установлен если 12, смените. Не все WiFi под Linux работаю на 12 канале

      Удалить
    5. Просто вспоминается 10.04 с ядром 2.х.х.После установки там как минимум 3.6 никакие драйвера под wi-fi уже не приходилось устанавливать.

      Удалить
    6. Так получилось или тет?

      Удалить
    7. На старом ядре заработало.Сейчас ещё на новом проверю.

      Удалить
  2. Какие то проблемы с интерфейсом начались. Грузится очень долго,даже на старом ядре.

    ОтветитьУдалить
    Ответы
    1. Сделай очистку системы с Ubuntu Tweak. Помогает.

      Удалить
  3. У меня даже не появляется ни боковая панель,ни верхняя.Через Alt-F2 тоже не запускается ни одна программа(Dash попросту не появляется).Слава богу через Guake вроде как запускается.Блин,хоть заново всё переустанавливай.

    ОтветитьУдалить
  4. можно попробывать sudo apt-get install --reinstall linux-generic &&sudo apt-get install --reinstall ubuntu-desktop переустановить ядро и unity

    ОтветитьУдалить
    Ответы
    1. после && пробел пропустил

      Удалить
    2. Не помогло.Проще переустановить с нуля.Та,которая сейчас стоит-результат обновления с 10.04.4

      Удалить
  5. все это конечно интересно, но вот виртуалка с ними не дружит, пока не обновят

    ОтветитьУдалить
    Ответы
    1. Если о виртуалке - то пишет нет необходимых модулей для работы с данной версией ядра

      Удалить
  6. Если home стоит в отдельном разделе перед установкой удали все скрытые файлы и папки и при установке откажись от форматирования home сэкономишь время на перенос и сохранение личных данных, а вообще то новую версию ставить с нуля

    ОтветитьУдалить
    Ответы
    1. Про home знаю(не впервой уже).Всё.Всем спасибо за советы.Пойду скачивать и переустанавливать с нуля.

      Удалить
  7. у меня ядро обновилось всё супер

    ОтветитьУдалить
  8. Интересное замечание:обновлялся с 10.04.4 до 12.04.3-ядро установилось 3.2.51-generic-pae.Установил сейчас с нуля-ядро 3.8.29,после актуализации установилось 3.8.31,оба generic.

    ОтветитьУдалить
    Ответы
    1. Вообще обновление релиза с одной версии на другую проходит не всегда гладко. На это влияет много факторов. И дополнительные репозитории подключённые ранее, и программы, и ядра. Лично я предпочитаю чистую установку. Наверняка знаешь, если пошло что-то не так, значит либо загрузил, либо записал криво образ.

      Удалить
    2. В моём случае криво загрузилось и также обновилось.Пойду спать.Завтра со свежей головой снова в бой.

      Удалить
  9. Здравствуйте.
    Пытаюсь обновиться,вылезает ошибка Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.8.0-30-generic.postrm line 328.
    Что может быть?

    ОтветитьУдалить
    Ответы
    1. Видимо ядро 3.8.0-30-generic не установлено до конца или "висит" в обновлении. Прежде попробуй установить его:
      sudo apt-get update
      sudo apt-get upgrade
      И посмотри, что пишет терминал в после выполнения upgrade.

      Удалить
    2. Сделал,вот,что пишет:
      даляется пакет linux-image-extra-3.8.0-30-generic …
      Examining /etc/kernel/postrm.d .
      run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.8.0-30-generic /boot/vmlinuz-3.8.0-30-generic
      update-initramfs: Deleting /boot/initrd.img-3.8.0-30-generic
      run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.8.0-30-generic /boot/vmlinuz-3.8.0-30-generic
      P: Checking for EXTLINUX directory... found.
      P: Writing config for /boot/vmlinuz-3.8.0-31-generic.efi.signed...
      P: Writing config for /boot/vmlinuz-3.8.0-31-generic...
      P: Writing config for /boot/vmlinuz-3.11.2-031102-generic...
      P: Writing config for Windows 8 (loader) on /dev/sda2...
      P: Writing config for Windows Recovery Environment (loader) on /dev/sda6...
      P: Installing debian theme... done.
      run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.8.0-30-generic /boot/vmlinuz-3.8.0-30-generic
      /usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in backquote substitution
      run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 2
      Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-extra-3.8.0-30-generic.postrm line 328.
      dpkg: ошибка при обработке параметра linux-image-extra-3.8.0-30-generic (--remove):
      подпроцесс установлен сценарий post-removal возвратил код ошибки 1
      Удаляется пакет linux-image-3.8.0-30-generic …
      Examining /etc/kernel/postrm.d .
      run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.8.0-30-generic /boot/vmlinuz-3.8.0-30-generic
      update-initramfs: Deleting /boot/initrd.img-3.8.0-30-generic
      run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.8.0-30-generic /boot/vmlinuz-3.8.0-30-generic
      P: Checking for EXTLINUX directory... found.
      P: Writing config for /boot/vmlinuz-3.8.0-31-generic.efi.signed...
      P: Writing config for /boot/vmlinuz-3.8.0-31-generic...
      P: Writing config for /boot/vmlinuz-3.11.2-031102-generic...
      P: Writing config for Windows 8 (loader) on /dev/sda2...
      P: Writing config for Windows Recovery Environment (loader) on /dev/sda6...
      P: Installing debian theme... done.
      run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.8.0-30-generic /boot/vmlinuz-3.8.0-30-generic
      /usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in backquote substitution
      run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 2
      Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.8.0-30-generic.postrm line 328.
      dpkg: ошибка при обработке параметра linux-image-3.8.0-30-generic (--remove):
      подпроцесс установлен сценарий post-removal возвратил код ошибки 1
      При обработке следующих пакетов произошли ошибки:
      linux-image-extra-3.8.0-30-generic
      linux-image-3.8.0-30-generic
      E: Sub-process /usr/bin/dpkg returned an error code (1)

      Удалить
    3. Это ядро 3.8.0-30-generic не надо было удалять, а наоборот до конца установить. Теперь открой Synaptic, введи в Поиск linux-image и удали всё, что выдаст Synaptic с linux-image-3.8.0-30.

      Удалить
    4. Сделал,вот,что написал synaptic :E: linux-image-extra-3.8.0-30-generic: подпроцесс установлен сценарий post-removal возвратил код ошибки 1
      E: linux-image-3.8.0-30-generic: подпроцесс установлен сценарий post-removal возвратил код ошибки 1

      Удалить
    5. Значит не судьба, устанавливать новые ядра. Если всё-таки хочешь дальнейших экспериментов, переустанови систему.

      Удалить
  10. Совсем,заново?Или можно как то восстановить?

    ОтветитьУдалить
    Ответы
    1. Нет, ну пользоваться системой можно, но ошибка будет постоянно преследовать. Я же пишу, что "Если всё-таки хочешь дальнейших экспериментов, переустанови систему".

      Удалить
    2. Да,экспериментов хочется,просто,я так долго настраивал,жалко все переустанавливать.:((у меня samsung 9 series,там не все просто настраивать,да и не все работает и сейчас) Собственно по этому и ставил ядро,в надежде,что что то исправиться. А,точно,ничем это не исправить без переустановки?

      Удалить
    3. Вот еще,после вода sudo apt-get install -f:
      run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.8.0-30-generic /boot/vmlinuz-3.8.0-30-generic
      /usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in backquote substitution
      run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 2
      Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.8.0-30-generic.postrm line 328.
      dpkg: ошибка при обработке параметра linux-image-3.8.0-30-generic (--remove):
      подпроцесс установлен сценарий post-removal возвратил код ошибки 1
      При обработке следующих пакетов произошли ошибки:
      linux-image-3.11.2-031102-generic
      linux-image-extra-3.8.0-30-generic
      linux-image-3.8.0-30-generic
      E: Sub-process /usr/bin/dpkg returned an error code (1)

      Удалить
    4. Я же писал, ЧТО БУДЕТ ВЫДАВАТЬ ОШИБКУ постоянно.

      Удалить
    5. Да,я понял,просто,надеялся,что можно обойтись без переустановки системы,извините.
      Огромное спасибо,что откликнулись!

      Удалить
  11. Все обновления ядра устанавливаются, работают (Linux Mint mate 32bit)... кроме принтера Canon 1120... он работает только когда обновления ядра официально через центр обновлений приходят.... Можно как то с этим побороться?

    ОтветитьУдалить