10 мая 2013

LibreOffice обновился до версии 4.0.3



Document Foundation (TDF) 9 мая объявила о выпуске третьей корректирующей версии LibreOffice 4.0 для Windows, Mac OS X и Linux операционных систем, включая Ubuntu.

Этот релиз исправляет более ста ошибок во всём её наборе продуктов: Impress, Writer и Calc. Подробнее о исправлениях Вы можете найти на странице: https://wiki.documentfoundation.org/Releases/4.0.3/RC1

А также было объявлено, что "правительство автономной области Испании Эстремадура начало переход на свободное программное обеспечение настольных ПК и ожидает, что большинство из 40 000 ПК мигрируют к концу 2013 года" Это поможет сэкономить около $ 30 млн., через год после перехода.

Пользователи Ubuntu 13.04/12.10/12.04 и Linux Mint 14/13 могут прямо сейчас обновить LibreOffice до версии 4.0.3, выполнив следующие команды в терминале:

sudo add-apt-repository ppa:libreoffice/libreoffice-4-0
sudo apt-get update
sudo apt-get dist-upgrade

После обновления вы можете открыть одно из приложений LibreOffice чтобы убедиться в новой версии продукта:



Удачи.

36 комментариев :

  1. Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Расчёт обновлений…Готово
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено. - и все!

    ОтветитьУдалить
    Ответы
    1. Подтверждаю, не обновляется...

      Удалить
  2. Cannot access PPA (https://launchpad.net/api/1.0/~libreoffice/+archive/libreoffice-4-0) to get PPA information, please check your internet connection.

    Такие дела.

    ОтветитьУдалить
    Ответы
    1. Не знаю. что не получается у вас, вот вывод команды: sudo apt-get dist-upgrade в Ubuntu 13.04

      [im]http://i022.radikal.ru/1305/57/7e485187d820.jpg[/im]

      Удалить
    2. Спасибо.
      Обновился.

      У меня Ubuntu 13.04 - ядра менять боюсь, сейчас у меня 3.8.0-19-generic

      А вот LibreOffice всегда хочу самый новый.

      Удалить
  3. Анонимный10 мая 2013 г., 11:06

    У меня всё встало, как по-маслу
    Спасибо.

    ОтветитьУдалить
  4. Ubuntu 13.04 (ядро 3.9)
    все отлично обновило, спасибо.

    ОтветитьУдалить
  5. C Б-жей помощью обновился.
    У меня показывает версию 4.0.3.3, а не 4.0.3.2 как на скриншоте.
    Спасибо за оперативное и доходчивое освещение дел с LibreOffice, это нужное мне приложение.

    ОтветитьУдалить
  6. http://ppa.launchpad.net/libreoffice/libreoffice-4-0/ubuntu
    для precise нет пакетов, но при желании можно зайти на http://ru.libreoffice.org/download/, скачать архив, распаковать в одну папку и установить командой sudo dpkg -i ru/DEBS/*.deb ru/DEBS/desktop-integration/*.deb

    ОтветитьУдалить
  7. Анонимный10 мая 2013 г., 14:08

    12.04 не обновляется. Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Расчёт обновлений…Готово
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

    ОтветитьУдалить
  8. 12.10 не обновляется. Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Расчёт обновлений…Готово
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

    ОтветитьУдалить
  9. 13.04. Обновился до 4.0.3.3. Всё работает.

    ОтветитьУдалить
  10. 12.04LTS С версии 4.0.2.2 (ID сборки: 400m0(Build:2)) дважды пытался обновиться, два раза пакетов для обновления 0...

    ОтветитьУдалить
  11. Анонимный10 мая 2013 г., 16:38

    На Ubuntu 12.04LTS LibreOffice обновился нормально. Только версию показывает 4.0.2.2

    ОтветитьУдалить
  12. Анонимный10 мая 2013 г., 19:49

    Может смешно, но как вернуться назад, на 3.6, т.к. эта версия с тёмными темами не показыват линейки :).
    Линейка, то есть, только она чёрная на чёрном фоне, а не белая как в 3.6 :(...

    ОтветитьУдалить
    Ответы
    1. Может это не LibreOffice виноват, а тему оформления нужно сменить и всё будет OK?

      Удалить
    2. Анонимный10 мая 2013 г., 19:55

      Ну как бы было всё настроено уже, а тут обновился и сё опять по новой, чобы и Либр работал и глазу приятно, а там др. приложения потянут за собой настройки тем и так до безконечности, вот бы назад вернуться и дождаться пока в оффициальных репах появится, тогда и обновиться...

      Удалить
    3. Назад можно, но сложно. Установи Synaptic, удали всё что связано с LibreOffice 4.0.2 и установи что связано с LibreOffice 3.6.

      Удалить
    4. или через sudo ppa-purge ppa:libreoffice/libreoffice-4-0 а потом sudo apt-get install libreoffice

      Удалить
    5. Можно и так. Но в любом случае нужно ещё удалить или отключить репозиторий:

      sudo add-apt-repository --remove ppa:libreoffice/libreoffice-4-0

      Иначе вновь придёт обновление.

      Удалить
    6. Анонимный10 мая 2013 г., 20:34

      Не помогло, всё удалил, установил заново - тот же стал 4.0.2 :)
      Удалял Синаптиком, Устанавливал:sudo apt-get install libreoffice...

      Удалить
    7. A репозиторий удалял? Надо перед этим удалить, как я писал выше.

      Удалить
  13. Анонимный11 мая 2013 г., 4:54

    Установить новый LibreOffice данными командами можно только на ubuntu 13.04! Может это временно...

    ОтветитьУдалить
  14. 12.04 LTS (386) обновился до 4.0.2.2

    ОтветитьУдалить
  15. Короче - этот способ пока только для ubuntu 13.04...

    ОтветитьУдалить
  16. Анонимный11 мая 2013 г., 15:05

    У меня тоже 12.04 обновляется до версии 4.0.2.2

    ОтветитьУдалить
  17. админ, дайте инструкцию или сделайте статью по установке libreoffice при скачивании пакетов c оф. сайта

    ОтветитьУдалить
    Ответы
    1. А зачем тебе это? Чем эта инструкция не устраивает? Или ты думаешь, что с оф.сайта другой LibreOffice будет?

      Удалить
    2. просто новые версии не для всех дистрибутивов обновляют репы. Я инструкцию знаю, но думаю, что остальным читателям будет интересно и познавательно)

      Удалить
  18. Обновилось с пол пинка! 12.04 LTS

    ОтветитьУдалить
  19. Утром обновился, после чего LibreOffice вылетает при нажатии любого пункта меню. ( сами пункты стали без надписей ). Ubuntu 12.10.
    Apport.log:
    ERROR: apport (pid 5325) Mon May 20 13:22:52 2013: apport: report /var/crash/_usr_lib_libreoffice_program_soffice.bin.1000.crash already exists and unseen, doing nothing to avoid disk usage DoS
    ERROR: apport (pid 7417) Mon May 20 13:37:03 2013: called for pid 7404, signal 11, core limit 0
    ERROR: apport (pid 7417) Mon May 20 13:37:03 2013: executable: /usr/lib/libreoffice/program/soffice.bin (command line "/usr/lib/libreoffice/program/soffice.bin --writer --splash-pipe=6")
    ERROR: apport (pid 7417) Mon May 20 13:37:03 2013: debug: session gdbus call: (true,)
    Помогите пожалуйста

    ОтветитьУдалить
    Ответы
    1. Попробуй вернуться к старой версии следующим образом:

      1. Удали репозиторий и новую версию:

      sudo ppa-purge ppa:libreoffice/libreoffice-4-0

      2. А затем установи дефолтную:

      sudo apt-get install libreoffice

      Удалить
    2. Удалил LibreOffice, репозиторий, почистил убунту-твиком, но:
      serg@eME732G:~$ sudo apt-get install libreoffice
      Чтение списков пакетов… Готово
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
      или же используете нестабильную версию дистрибутива, где запрошенные вами
      пакеты ещё не созданы или были удалены из Incoming.
      Следующая информация, возможно, поможет вам:

      Пакеты, имеющие неудовлетворённые зависимости:
      libreoffice : Зависит: libreoffice-core (= 1:3.6.2~rc2-0ubuntu4) но он не будет установлен
      Зависит: libreoffice-writer но он не будет установлен
      Зависит: libreoffice-calc но он не будет установлен
      Зависит: libreoffice-impress но он не будет установлен
      Зависит: libreoffice-draw но он не будет установлен
      Зависит: libreoffice-math но он не будет установлен
      Зависит: libreoffice-base но он не будет установлен
      Рекомендует: libreoffice-gnome но он не будет установлен или
      libreoffice-kde но он не будет установлен
      E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

      Удалить
    3. Заново установил
      sudo add-apt-repository ppa:libreoffice/ppa
      sudo apt-get update
      sudo apt-get install libreoffice libreoffice-l10n-ru
      ! Удалил глобальное меню:
      sudo apt-get remove indicator-appmenu

      LibreOffice 4.3.3 не вылетает.

      Удалить