04 апреля 2013

Установить рабочее окружение Mate 1.6 в Ubuntu 12.10/12.04 /11.10


После восьми месяцев разработки вышел релиз рабочего окружения MATE 1.6, в рамках которого продолжено развитие кодовой базы GNOME 2.32 с сохранением классической концепции формирования рабочего стола. В состав новой версии включено около 800 изменений и исправлений.
В отличие от GNOME 2.32, MATE полностью избавлен от конфликтов пакетов с GNOME 3, что позволяет использовать традиционный рабочий стол GNOME 2 параллельно с рабочим столом GNOME 3 в одном дистрибутиве, что раньше было невозможно из-за пересечения некоторых имён файлов.

Из используемых в MATE 1.6 приложений можно отметить:

    файловый менеджер Caja (форк Nautilus),
    оконный менеджер Marco (форк Metacity),
    текстовый редактор Pluma (форк Gedit),
    просмотрщик изображений Eye of MATE (форк Eye of GNOME),
    программа для просмотра документов Atril (форк Evince),
    менеджер для работы с архивами Engrampa (форк File-roller),
    калькулятор MateCalc (форк gcalctool),
    эмулятор терминалов MATE Terminal (форк GNOME Terminal).

MATE 1.6 является огромным шагом вперед по сравнению с релизом MATE 1.4  Многие устаревшие пакеты и библиотеки были заменены на новые, доступные в GLib.

В MATE 1.6 добавлены новые темы GTK2/3: Menta, BlackMATE, GreenLaguna, а также новая тема значков: Menta. Кроме того, была добавлена ​​поддержка некоторых из существующих тем GTK3: TraditionalOk, TraditionalOkTest и ContrastHigh.

Начиная с версии 1.6, MATE перешло на новые пакеты: GSettings заменил MateConf, DBus заменил MateCorba/MateComponent, GIO/GVFS заменил MateVFS и libnotify заменил libmatenotify.

Установка  рабочего стола MATE в Ubuntu 12.10/12.04 /11.10

Чтобы добавить репозитории и установить рабочий стол MATE, скопируйте и выполните эту последовательность команд в терминале:

sudo add-apt-repository "deb http://packages.mate-desktop.org/repo/ubuntu $(lsb_release -cs) main"
sudo add-apt-repository "deb http://repo.mate-desktop.org/ubuntu $(lsb_release -cs) main"
sudo add-apt-repository "deb http://mirror1.mate-desktop.org/ubuntu $(lsb_release -cs) main"
sudo apt-get update
sudo apt-get install mate-archive-keyring
sudo apt-get update
sudo apt-get install mate-core mate-desktop-environment

А также нужно установить демон всплывающих извещений, т.к. он не установлен по умолчанию:

sudo apt-get install mate-notification-daemon

По окончании установки, необходимо выйти из текущего сеанса и в окне входа в систему выбрать оболочку MATE:


Страница установки: http://wiki.mate-desktop.org/download

Удаление MATE

Если вы установили MATE в Ubuntu, а теперь хотите удалить его, выполните следующую команду в терминале (одной командой):

sudo apt-get remove mate-archive-keyring mate-notification-daemon atril atril-common caja caja-common engrampa engrampa-common eom eom-common gir1.2-mate-panel libatril libcaja-extension libmarco libmatedesktop libmatekbd libmatekeyring libmatemenu libmatepanelapplet libmatepolkit libmateweather libmateweather-common libmatewnck libmatewnck-common marco marco-common mate-applets mate-applets-common mate-backgrounds mate-calc mate-control-center mate-core mate-desktop mate-desktop-common mate-desktop-environment mate-dialogs mate-icon-theme mate-media mate-media-common mate-media-gstreamer mate-menus mate-panel mate-panel-common mate-polkit mate-power-manager mate-power-manager-common mate-screensaver mate-screensaver-common mate-session-manager mate-settings-daemon mate-settings-daemon-common mate-settings-daemon-gstreamer mate-system-monitor mate-terminal mate-terminal-common mate-themes mate-utils mate-utils-common pluma pluma-common

И удалите репозитории MATE:

sudo add-apt-repository -r "deb http://packages.mate-desktop.org/repo/ubuntu $(lsb_release -cs) main"
sudo add-apt-repository -r "deb http://repo.mate-desktop.org/ubuntu $(lsb_release -cs) main"
sudo add-apt-repository -r "deb http://mirror1.mate-desktop.org/ubuntu $(lsb_release -cs) main"
sudo apt-get update


Удачи.

32 комментария :

  1. При установке выподает ошибка "ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
    mate-archive-keyring"

    ОтветитьУдалить
    Ответы
    1. Всё правильно. Затем идёт команда с добавлением ключа. Выполни её и всё нормализуется.

      Удалить
  2. что-то нехотит W: Ошибка GPG: http://packages.mate-desktop.org quantal Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 68980A0EA10B4DE8

    ОтветитьУдалить
    Ответы
    1. Добавь ключ сам следующей командой:sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 68980A0EA10B4DE8

      Удалить
  3. ...в Linux Mint 14,1 поставить получится?

    ОтветитьУдалить
    Ответы
    1. Нет. Это только для Ubuntu.

      Удалить
    2. На форуме Минта пишут надо подождать......все будет....

      Удалить
    3. http://www.opennet.ru/opennews/art.shtml?num=36567

      Удалить
  4. скажите, а аплет глобального меню теперь есть в этой новой версии?

    ОтветитьУдалить
  5. Попробовал.. "Этот" Минт точно не Минт..Уж лучше сразу пользоваться оригиналом.Или Ubuntu или Mint.А два или три в одном это глупости.

    ОтветитьУдалить
  6. Нормально.Но не работает терминал.Не запускается ни родной Mate ни Ubuntu.Что делать?

    ОтветитьУдалить
    Ответы
    1. Терминал и у меня не запускается. Но там в системе: Приложения ->Стандартные, есть xterminal, я им обходился для работы.
      С mate-terminal, видимо системный баг. Будем надеяться, что в скором времени исправят.

      Удалить
    2. не знаю как вчера- не пробовал терминал, а сегодня обновился- пришли какие то кусочки мате, терминал запускается.

      Удалить
    3. у меня терминал сразу запустился. Но у меня стоял mate 1.4 и я обновился.правда некоторые настройки послетали, но ничего, - разберусь)))

      Удалить
  7. Установил Guake terminal все нормально

    ОтветитьУдалить
  8. Не только терминал. Формат даты-времени не устанавливается, иконки приложений на панели кравые. 1.4 пока лучше.

    ОтветитьУдалить
  9. кучу DE перепробовал- хорош мате, что и говорить- но каждый раз возвращался на юнити- самый мне удобный- всё что надо, и ничего лишнего. а мате держу вторым, на всякий случай, как дань классике. остальные не прижились

    ОтветитьУдалить
  10. Вчера обновился на 12.04. Большинство настроек слетело. Mate-terminal при попытке запуска выдавал ошибку плавающей запятой; после сегодняшних обновлений запускается без проблем.

    ОтветитьУдалить
  11. ==А также нужно установить демон всплывающих извещений, т.к. он не установлен по умолчанию:
    sudo apt-get install mate-notification-daemon==

    Я установил и снёс. Индикатор изменения громкости появляется прямо в центре экрана. Очень неудобно если смотришь фильм. Зачем такое счастье надо. Посмотрел MATE, ничего особенного не заметил. Типа Gnome ничего особенно хорошего или плохого сказать не могу, как пишут в интернетах - "Шрифты-гавно". Т.е. неудобочитаемые шрифты. Плюс - чуть полегче среда. Но на скорости это не сказалось. На моём компьютере как бы нет разницы.

    Вернулся на Unity как домой. Всё удобно и привычно, шрифты удобочитаемы.

    ОтветитьУдалить
  12. mate-conf-editor остался 1.4, будет ли обновляться и станет ли доступным для загрузки - неизвестно, описанное на этом сайте отображение флагов раскладки клавиатуры пока возможно только через установку dconf-editor и правку настроек в нём.

    ОтветитьУдалить
    Ответы
    1. Так, а в чём проблема-то? Флаги в раскладку устанавливаются. Посмотри на верхнем снимке.

      Удалить
    2. Не, с флагами всё нормально, со всем остальным - хуже: компиз полетел, т.к. под 1.4 был заточен, вспомнил об этом поздно, как и о том, что мате у меня в 12.04 - единственное рабочее окружение(((

      Удалить
  13. обновил мате до 1.4 а потом до 1.6 в минт 13 по этим инструкциям http://www.mintlinux.ru/forum/thread1740.html и http://linuxg.net/how-to-install-mate-1-6-on-ubuntu-linux-mint-debian-and-fedora/ с первого захода получил неработющий нетворкменджер,в принципе исправляется изменением значения false на true в строке NetworkingEnabled в файле /var/lib/NetworkManager/NetworkManager.state но сиcтема упорно хотела ещё кучу обновлений с помощью sudo apt-get dist-upgrade -обновил-получил чёрный экран,поставил минт мате с ноля повторил всё с начала -в итоге обновился таки до 1.6-вылитый гном 2.32,что радует, но пришлось вручную обновить движки гтк aurora,equinox и nodoka -,работает норм,но виснет каиро-док при попытке что-либо удалить из него,и наглухо зависает компиз прямо при включении-окна изменяются ,но не перемещаются,благо стоит compiz-fusion-icon -можно обратно в марко переключиться

    ОтветитьУдалить
  14. Анонимный1 мая 2013 г., 19:36

    А в 13.4 можно использовать?

    ОтветитьУдалить
  15. Анонимный6 мая 2013 г., 21:14

    Пакунки, що мають незадоволені залежності:
    mate-core : Залежності (Depends): mate-control-center (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): caja (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): marco (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-session-manager (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-panel (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-settings-daemon (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-terminal (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-desktop (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): libmatekbd (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): libmatedesktop (>= 1.6.0) але він не буде встановлений
    mate-desktop-environment : Залежності (Depends): atril (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): engrampa (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): pluma (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): eom (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-screensaver (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-utils (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-applets (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-media (>= 1.6.0) але він не буде встановлений
    Залежності (Depends): mate-system-monitor (>= 1.6.0) але він не буде встановлений
    E: Неможливо усунути проблеми, Ви маєте поламані зафіксовані пакунки.

    ОтветитьУдалить
    Ответы
    1. Анонимный6 мая 2013 г., 22:57

      Это я выложил вывод терминала, не могу поставить уже в который раз в Ubuntu 12.04.2

      Удалить
    2. Что-то ты накрутил в своей системе, что она имеет сломанные пакеты. Установи систему Linux Mint Mate на жёсткий диск и всё будет ОК.

      Удалить
    3. Анонимный7 мая 2013 г., 17:22

      Не крутил я ничего с новой установки такое, уже несколько раз пробовал, никак не могу накатить Мате на Убунту,
      А с Минтом свои проблемы: после одного из обновлений если в системе языки стоят в локализации: Укр.; Рус;,Англ, то все программы из центра программ ставятся только с английским интерфейсом, если основным языком системы поставить Рус., то все программы сами русифицируются, как только возвращаю на системный Укр, всё заново... Систему вылизал всё под себя сделал и тут такая засада, попробовал заново Минт поставить - всё в порядке, ну уж ладно, думаю поставлю ещё раз, ещё раз "вылижу", так после мультиупдейт, тоже самое, а в 14 Минте сразу такой баг...
      Поставил Убунту, после обновлений такого нету, дай думаю Мате накачу и всё будет, а не тут-то было, думал систему с ошибкой записал, несколько раз пробовал, проверял - всегда один ответ не хватает каких-то зависимостей...
      Извиняюсь за длинный ответ, но вроде всё по порядку изложил, может кто какой выход придложит или для Убунту или Минта.
      Заранее спасибо!

      Удалить
    4. Анонимный9 мая 2013 г., 9:16

      Спасибо добрым людям проблема решена!!!! :) :D !

      Удалить