13 апреля 2016

Установить/обновить ядро Linux Kernel 4.5.1 в Ubuntu и производные

Предупреждение. Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости.  Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему.  Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

Ядро Linux Kernel 4.5.1 является первым корректировочным выпуском ядра версии 4.5.
Для установки вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.

Установить ядро версии 4.5.1 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 16.04/15.10/14.04/12.04
Linux Mint 17.3/17.2/17.1/17/13
elementary OS 0.2/0.3/0.3.1
Deepin 15.1

Установка ядра Linux Kernel 4.5.1

Напоминание пользователям компьютеров с видеокартами Nvidia/AMD. Перед установкой ядра, желательно переключиться на свободный драйвер.

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы: 32 или 64-bit.

Для 32-bit (одной командой):

cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.1-wily/linux-headers-4.5.1-040501-generic_4.5.1-040501.201604121331_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.1-wily/linux-headers-4.5.1-040501_4.5.1-040501.201604121331_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.1-wily/linux-image-4.5.1-040501-generic_4.5.1-040501.201604121331_i386.deb; sudo dpkg -i *.deb

Для 64-bit (одной командой): 

cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.1-wily/linux-headers-4.5.1-040501-generic_4.5.1-040501.201604121331_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.1-wily/linux-headers-4.5.1-040501_4.5.1-040501.201604121331_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.1-wily/linux-image-4.5.1-040501-generic_4.5.1-040501.201604121331_amd64.deb; sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
.
Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой в терминале:

uname -r


Примечание 2. Ядро версии версии 4.5.1 установилось с проприетарным драйвером Nvidia и система работает стабильно только в дистрибутивах Ubuntu 16.04/15.10.


В дистрибутивах Ubuntu 14.04 и Linux Mint 17.3 с новым ядром система работает стабильно только с свободным драйвером.

Примечание 3. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 4.5.1, выполните эту команду:

sudo apt-get purge linux-image-4.5.1-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

7 комментариев :

  1. Обновился, пока все нормально, только появился белый крест на красном фоне в трее - Active graphic card - unknown.
    При нажатии - открывается Nvidia X Server settings. Активной стоит вроде Интел ХД (так и было), на Нвидию переключить не дает - выскакивает махонькое окошко без надписей, но опять так с крестом.
    Ну а в остальном, прекрасная маркиза - все хорошо :)
    PS
    Линукс Минт KDE 17.3

    ОтветитьУдалить
    Ответы
    1. Белый крест не к добру,а тем более на красном фоне.

      Удалить
    2. не, не к добру , особенно в трее ... ждать беды.

      Удалить
  2. Да с этими видеокартами всегда гемор... У меня встроенное графическое ядро (Intel HD graphics) - и проблем никаких. Тьфу, тьфу...))

    ОтветитьУдалить
    Ответы
    1. С играми тоже никаких проблем на встроенных? У меня щас убунту 14.04 и ядро 4.4 из реп и всё ок, не вижу смысла спешить ставить ядро сраду после выпуска.

      Удалить
  3. Обновился, ubuntu 16.04, amd HD7600m, заработал ждущий режим

    ОтветитьУдалить