27 февраля 2016

Установить/обновить ядро Linux Kernel 4.4.3 в Ubuntu и производные

Предупреждение. Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости.  Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему.  Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

Ядро Linux Kernel 4.4.3 является третьим корректировочным выпуском ядра версии 4.4. Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.

Установить ядро версии 4.4.3 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 15.10/14.04/12.04
Linux Mint 17.3/17.2/17.1/17/13
elementary OS 0.2/0.3/0.3.1
Deepin 15.1

Установка ядра Linux Kernel 4.4.3

Напоминание пользователям компьютеров с видеокартами Nvidia/AMD. Перед установкой ядра, желательно переключиться на свободный драйвер.

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера:

Для 32-bit (одной командой):

cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.3-wily/linux-headers-4.4.3-040403-generic_4.4.3-040403.201602251634_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.3-wily/linux-headers-4.4.3-040403_4.4.3-040403.201602251634_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.3-wily/linux-image-4.4.3-040403-generic_4.4.3-040403.201602251634_i386.deb; sudo dpkg -i *.deb

Для 64-bit (одной командой): 

cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.3-wily/linux-headers-4.4.3-040403-generic_4.4.3-040403.201602251634_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.3-wily/linux-headers-4.4.3-040403_4.4.3-040403.201602251634_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.3-wily/linux-image-4.4.3-040403-generic_4.4.3-040403.201602251634_amd64.deb; sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
.
Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой в терминале:

uname -r


Дистрибутив Deepin 15.1


Примечание 2. Ядро 4.4.3 поверх установленного ранее проприетарного драйвера (Nvidia 352) получилось установить только в Ubuntu/Kubuntu 15.10/Deepin 15.1, но в Ubuntu 14.04 и основанных на нём дистрибутивах (Linux Mint 17 и т.п.), устанавливается и работает только с свободным драйвером Nouveau.


Примечание 3. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 4.4.3, выполните эту команду:

sudo apt-get purge linux-image-4.4.3-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

7 комментариев :

  1. "переделал" "Рафаэллу" под "Росинку". Один в один. И всё стало хорошо и приятно. И совершенно не имеет смысла какое "ядро" Хоть три девятое..И Вам советую.Ведь всем известно что девятка лучшее что есть. Теперь уже "было"..)))

    ОтветитьУдалить
  2. А почему так происходит, что в Deepen работает с дровами NVIDIA, а в Минте нет?

    ОтветитьУдалить
  3. Владимир, извините за вопрос не по теме. Как установить тему OS X El Capitan как у вас на скрине? Я её скачал, закинул в папку /usr/share/themes/ а в системе как применить не нашёл. Напишите пожалуйста как это сделать)

    ОтветитьУдалить
    Ответы
    1. ==Я её скачал, закинул в папку /usr/share/themes/ а в системе как применить не нашёл.==
      Настройки системы - Темы и клик на теме OS X El Capitan.

      Удалить
    2. Ну я не настолько глупый. Оказалось, что у этой папки и её подпапках не было прав не чтение.

      Удалить