01 февраля 2016

Установить/обновить ядро Linux Kernel 4.4.1 в Ubuntu и производные

Предупреждение. Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости.  Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему.  Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

Ядро Linux Kernel 4.4.1 является первым корректировочным выпуском ядра версии 4.4. Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.
Установить ядро версии 4.4.1 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 15.10/15.04/14.04/12.04
Linux Mint 17.3/17.2/17.1/17/13
elementary OS 0.2/0.3

Установка ядра Linux Kernel 4.4.1

Напоминание пользователям компьютеров с видеокартами Nvidia/AMD. Перед установкой ядра, желательно переключиться на свободный драйвер.

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера:

Для 32-bit (одной командой):

cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.1-wily/linux-headers-4.4.1-040401-generic_4.4.1-040401.201601311534_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.1-wily/linux-headers-4.4.1-040401_4.4.1-040401.201601311534_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.1-wily/linux-image-4.4.1-040401-generic_4.4.1-040401.201601311534_i386.deb ; sudo dpkg -i *.deb

Для 64-bit (одной командой):
 
cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.1-wily/linux-headers-4.4.1-040401-generic_4.4.1-040401.201601311534_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.1-wily/linux-headers-4.4.1-040401_4.4.1-040401.201601311534_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.1-wily/linux-image-4.4.1-040401-generic_4.4.1-040401.201601311534_amd64.deb; sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
.
Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой в терминале:

uname -r


Дистрибутив Kubuntu 15.10


Примечание 2. Ядро 4.4.1 поверх установленного ранее проприетарного драйвера Nvidia 352 получилось установить только в Kubuntu 15.10, но в Ubuntu 14.04 и основанных на нём дистрибутивах (Linux Mint 17 и т.п.), устанавливается и работает только с свободным драйвером Nouveau.

Примечание 3. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 4.4.1, выполните эту команду:

sudo apt-get purge linux-image-4.4.1-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

9 комментариев :

  1. Смысл менять ядро , если всё работает. Видимо если захотелось оставить надо на "потом". Но правило номер один звучит так.. Если всё работает, ничего не трогай

    ОтветитьУдалить
    Ответы
    1. Честное слово.Хотелось сказать одно.Получилось другое мат не хочется употблять...

      Удалить
    2. Александр - земляк, сдерживай эмоции в комментариях ==мат не хочется употблять...==. И выражай мысли более конкретно.

      Удалить
    3. mint 13 Совершив бег по кругу всегда можно вернуться откуда начал бежать.Сколько ни крути вариантов один . Минт, вопрос какой.?

      Удалить
    4. Вам Debian надо с такой философией

      Удалить
  2. постояно меняю и каждою ядро работает лучше , но до версии 4,2,25 . если выше то nvidia304 не ставит мое разрешение 11440х900 , в линукс минт 17,3.

    ОтветитьУдалить
  3. Мое почтение! При установке двух крайних выпусков ядер у меня не выключается ноутбук и при загрузке Системы автоматически монтируются все логические диски на моем харде в т.ч и файловой системы NTFS чего раньше не было и что явно лишенее. Сейчас ядро 4.3.4-040304-lowlatency x86_64
    Всем добра!

    ОтветитьУдалить
  4. Владимир, спасибо за новые статьи, уже больше года читаю вас регулярно и с интересом. Пользуясь поводом хотел спросить, стоит ли уходить с c LTS ядра на более новое, если всё оборудование работает хорошо, linux mint 17.3, kernel 4.4.0 LTS ?

    ОтветитьУдалить
    Ответы
    1. В самом начале каждой статьи по обновлению ядра я делаю предупреждение:

      Предупреждение. Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости. Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему. Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

      Ну, а если в двух словах: "Работает - не трогай".

      Удалить