22 сентября 2015

Установить/обновить ядро Linux Kernel 4.2.1 в Ubuntu и производные

Предупреждение. Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости.  Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему.  Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

Ядро Linux Kernel 4.2.1 является первым корректировочным выпуском ядра версии 4.2. Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.
Установить ядро версии 4.2.1 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 15.04/14.04/12.04
Linux Mint 17.2/17.1/17/13
elementary OS 0.2/0.3

Установка ядра Linux Kernel 4.2.1

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера:

Для 32-bit (одной командой):

cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.1-unstable/linux-headers-4.2.1-040201-generic_4.2.1-040201.201509211431_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.1-unstable/linux-headers-4.2.1-040201_4.2.1-040201.201509211431_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.1-unstable/linux-image-4.2.1-040201-generic_4.2.1-040201.201509211431_i386.deb; sudo dpkg -i *.deb

Для 64-bit (одной командой):
 
cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.1-unstable/linux-headers-4.2.1-040201-generic_4.2.1-040201.201509211431_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.1-unstable/linux-headers-4.2.1-040201_4.2.1-040201.201509211431_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2.1-unstable/linux-image-4.2.1-040201-generic_4.2.1-040201.201509211431_amd64.deb; sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
.
Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой в терминале:

uname -r


Дистрибутив Linux Mint 17.2 XFCE 


Примечание 2
. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 4.2.1, выполните эту команду:

sudo apt-get purge linux-image-4.2.1-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

26 комментариев :

  1. bug с проприетарными драйверами nvidia успешно перекочевал из 4.2.0.

    ОтветитьУдалить
  2. Удалить старое ядро ))) sudo apt-get purge $(dpkg -l 'linux-*' | sed '/^ii/!d;/'"$(uname -r | sed "s/\(.*\)-\([^0-9]\+\)/\1/")"'/d;s/^[^ ]* [^ ]* \([^ ]*\).*/\1/;/[0-9]/!d' | head -n -1) --assume-yes

    ОтветитьУдалить
  3. Ответы
    1. Ubuntu 15.10 по умолчанию работает на 4.2 и постоянно обновляется.

      Удалить
    2. Обновилось без проблем, к стати 15.10 уже работает нормально, 24 числа ждем бета 2.

      Удалить
  4. Владимир вопрос по поводу электропотребление, что Убунту быстрее разрежает батарею чем винда?

    ОтветитьУдалить
    Ответы
    1. Да, с дистрибутивами Linux батареи портативных компьютеров работают с меньшим запасом, чем с Windows, это известный факт и над ним работают разработчики ядра.
      Я ведь тебе, Ираклий, раньше уже отвечал на эту тему.

      Удалить
    2. На эту тему нет, была тема по поводу сенсорных экранов на нетбуках.

      Удалить
    3. Ну тут все от конкретных версий зависит. Я на свой Aspire E11 накатил Xubuntu 15 вместо штатной 8.1. В сежиме серфинга через wifi живет 6 с половиной часов против 5 в Windows. Ноут для экспериментов. Пробовал и то и другое, делал замеры.
      Под Xfce при серфинге нагрузка на ЦП 12-17%, оперативной памяти задействовано от 630 до 950 мегабайт. Swap разумеется пустой. В серднем в Firefox открыто 5-12 вкладок.

      Удалить
  5. Сначала начал " дёргаться", захотелось как у всех. Но правила менять нельзя. Если всё работает, не трожь.. Смысла просто нет. Ведь всё работает..)))

    ОтветитьУдалить
    Ответы
    1. Абсолютно верно. Ядро менять в случае когда новая железяка отказывается работать или нет дров под нее (возможно в ядро впилены будут).

      Удалить
    2. Верно подмечено! Комп-это, как жена! Изменил - разгребай новое фамильное дерево! А это тебе надо? Ну, так узнавай что имеешь! Это огромный мир! Обоснуй, коль я не прав стал.

      Удалить
    3. Главное старое ядро сразу не сносить)

      Удалить
  6. Извините за офф-топ. В Мозилле на ютубе в полноэкранном режиме тормозит видео. Вне зависимости от разрешения. В Хроме всё хорошо. Кто знает, что делать? ОС Ubuntu 14.04

    ОтветитьУдалить
  7. Есть ли смысл обновлять ядро если и так все работает нормально?

    ОтветитьУдалить
    Ответы
    1. Сразу видно, что Вы не читали анонс к статье, задавая этот вопрос:
      "Предупреждение. Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости. Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему. Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск."

      Удалить
  8. Проприетарные драйвера на nvidia встают нормально?

    ОтветитьУдалить
  9. обновил ядро , рухнул груб , не могу запустить даже на старом (((

    ОтветитьУдалить
    Ответы
    1. Восстановил ГРУБ , запустился на данном ядре , полет нормальный .

      На счет реплики про чукч , то мне она напомнила другой анекдот про чукчу " однако трактор надо " ....

      Удалить
  10. Как дети...Ну не знаещь, не лезь..
    Два "чукчи" едут в автобусе и спрашивают кондуктора
    - А я доеду на этом автобусе до Гума?
    - Нет
    -Другой, А Я???

    ОтветитьУдалить
  11. Поставил, работает, но менеджер предлагает "обновиться" до 3.19. Почему он не видит более новой версии пакетов, и как сделать так, чтобы не предлагал "обновить" ядро на старое?

    ОтветитьУдалить
    Ответы
    1. Здесь немного не так, как Вы поняли. Ядро 3.19 установлено в дистрибутиве по умолчанию и для него приходят обновления, но это не значит, что если Вы обновите это ядро и оно вновь будет использоваться. Использовать то или иное ядро зависит от администратора (пользователя) системы, которое переключается в загрузчике GRUB. Так что обновляйте ядро 3.19 без боязни.

      Удалить
    2. Ясно. Спасибо за пояснения.

      Удалить
  12. А можно ли это как-то в качестве репозитория добавить?

    ОтветитьУдалить
    Ответы
    1. Официальных репозиториев по обновлению того или иного ядра - нет. Но когда на каком-то ядре стороится дистрибутив, тогда для ядра прихотят обновления. Например, Ubuntu 15.10 основан на ядре 4.2. и для данного ядра постоянно приходят обновления.
      vladimir@compizomania ~> cat /etc/lsb-release; uname -r
      DISTRIB_ID=Ubuntu
      DISTRIB_RELEASE=15.10
      DISTRIB_CODENAME=wily
      DISTRIB_DESCRIPTION="Ubuntu Wily Werewolf (development branch)"
      4.2.0-11-generic

      Удалить