07 июня 2015

Установить/обновить ядро Linux Kernel 4.0.5 (Stable) в Ubuntu и производные

Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости.  Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему.  Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

Linux Kernel 4.0.5 является пятым корректировочным выпуском ядра версии 4.0. Список изменений в ядре 4.0.5 можно посмотреть ЗДЕСЬ.
Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.

Установить ядро версии 4.0.5 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 15.04/14.10/14.04/12.04
Linux Mint 17.1/17/13
elementary OS 0.2/0.3

Установка ядра Linux Kernel 4.0.5

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера:

Для 32-bit (одной командой):

cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-headers-4.0.5-040005-generic_4.0.5-040005.201506061639_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-headers-4.0.5-040005_4.0.5-040005.201506061639_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-image-4.0.5-040005-generic_4.0.5-040005.201506061639_i386.deb && sudo dpkg -i *.deb

Для 64-bit (одной командой):
 
cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-headers-4.0.5-040005-generic_4.0.5-040005.201506061639_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-headers-4.0.5-040005_4.0.5-040005.201506061639_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-image-4.0.5-040005-generic_4.0.5-040005.201506061639_amd64.deb && sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
. Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой:

uname -r 


Видеодрайвер Nvidia 352.09


Примечание 2. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ. Если вы решили удалить ядро 4.0.5, выполните эту команду:

sudo apt-get purge linux-image-4.0.5-* linux-headers-4.0.5-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

13 комментариев :

  1. Приветствую. Подскажите 4.0.5 с драйвером Nvidia: 340.76 поедет?

    ОтветитьУдалить
    Ответы
    1. С этим даже не знаю) У меня 352.09) С этим подойдет)

      Удалить
    2. http://forum.ubuntu.ru/index.php?topic=261478.0
      По дефолту не поедет, но по ссылке есть варианты чтоб ехало

      Удалить
    3. Максим, спасибо! Пропатчил, все отлично работает.

      Удалить
    4. Кстати в репозиториях тестовой 15.10 скоро появится ядро 4.0 и разработчики ubuntu добавили патч к драйверу. У них более правильный вариант работающий со всеми ядрами по умолчанию. Короче я просто скачал пакет nvidia-340 из тестовых реп и поставил его в 15.04

      Удалить
  2. Устанавливаю данное ядро , надеюсь вай фай поченили

    сделайте пожалуйся мануал по настройке точки достиупа в минт 17
    что то не получается у меня раздача

    ОтветитьУдалить
  3. первый запуск не удачный , сорвалось при запуске , в рекавери не заходит то же .
    попробую переустановить

    ОтветитьУдалить
    Ответы
    1. Переустановил , запуск прошел удачно но вай фай НЕ РАБОТАЕТ !!!
      на старом ядре все работает на 4.5 нет
      в настройках сети высвечивается сети вай фай а в панеле на рабочем столе нет даже кнопки включения или отключения вай фай присутствует только проводное соединение
      как это победить кто знает ?

      Удалить
    2. Снес ядро , причина ,вай фай не работает .

      Удалить
  4. Хотел добавить что я тестировал данное ядро на своем нетбуке Lenovo s10e atom N270 , 2GB ram

    ОтветитьУдалить
  5. у кого raid0, срочно ставьте! наконец устранили trim-баг (был с версии 3.14)
    https://www.archlinux.org/news/data-corruption-on-software-raid-0-when-discard-is-used/

    ОтветитьУдалить
  6. Снес ядро , причина ,вай фай не работает
    Драйвер через NDISwrapper установлен? Если да то это баг NDISwrapper (о нем известно, версия 1.59-2 не работает с ядром 4) нужно просто обновить сам NDISwrapper и все что с ним связано, мне помогла версия 1.59-5 от Дебиана. https://packages.debian.org/search?searchon=names&keywords=NDISwrapper
    PS Если у вас открывалось окно об ошибке при обновлении ядра, то отправив отечет отрылось бы окно браузера с данным багом, и там черным по белому написано об данной ошибке, и ниже в комментариях написано как ее решить (то что я ниписал выше). Будьте внимательны!

    ОтветитьУдалить