13 февраля 2015

Мажорная версия VLC 3.0 принесет много изменений

VLC — бесплатный и свободный кросс-платформенный медиаплеер и медиаплатформа с открытым исходным кодом. VLC воспроизводит множество мультимедийных форматов файлов: MPEG, DivX/Xvid, OGG и мн. др., а также DVD, Audio CD, VCD и сетевые трансляции. VLC работает на всех популярных платформах (Linux, Windows, MacOS).
Следующий мажорный (Мажорные версии затрагивают серьезные и порой кардинальные изменения приложения) релиз VLC 3.0 принесет такие изменения:
  1. Автоматический аппаратный поворот видео в необходимую ориентацию
  2. Улучшена поддержка и работа расширений
  3. Поддержка воспроизведения файла на прерванном моменте
  4. Поддержка новых форматов и кодеков. Переработана поддержка некоторых существующих.
  5. Появится VDPAU GPU zero-copy. Технология zero-copy позволяет процессору не участвовать
А также визуализация спектра 3D OpenGL, исправления безопасности, поддержка протокола HTTP Dynamic Streaming (HDS) от Adobe, плагин для скриншотов Wayland, поддержка видеокодека Daala, улучшения в libVLC и поддержка журналирования в systemd.
Полный список изменений можно посмотреть на git.videolan.org.


 Установить разрабатываемую версию VLC 3.0 можно в следующих дистрибутивах: Ubuntu 15.04/14.10/14.04.
Откройте терминал (Ctrl+Alt+T), скопируйте и выполните последовательно следующие команды:

sudo add-apt-repository ppa:videolan/master-daily
sudo apt-get update
sudo apt-get install vlc browser-plugin-vlc

После установки вы найдёте  VLC 3.0 в программах Аудио и видео или поиском в меню:


Примечание. Если у вас  была установлена предыдущая версия VLC, то она будет перезаписана на VLC 3.0.

Источник: VLC Daily Build of master branch

Удачи.

53 комментария :

  1. Xubuntu-14.04.
    При установке терминал не выдал никаких ошибок - однако, версия VLC осталась прежняя..

    ОтветитьУдалить
    Ответы
    1. Валерий, у меня в Linux Mint 17.1 XFCE тоже выдавало ошибку. Я в VLC Daily Build of master branch (в ссылке на источник в статье) загрузил отдельно все пакеты архитектуры моей системы (32 или 46) и версия теперь 3.0.

      Удалить
    2. Я не понял - в статье речь идёт о плеере, а команда на установку браузерного плагина. Плагин установился, а плеер не обновился.

      Удалить
    3. Владимир!
      Не стоит перепечатывать новости не проверив работоспособность проги.
      С Вашим опытом и большой аудиторией Вам должно прийти чувство ответственности.
      3.0 - сырая, неофициальная версия, которая может "повесить" систему именно из-за несогласованности пакетов/библиотек и т.п.

      Разрабы её "пилят" ещё.

      Будьте внимательны!

      Удалить
    4. http://git.videolan.org/?p=vlc.git;a=blob;f=NEWS;h=815cb5e60e3e6a8adbb8ae413fed59de5c2b8764;hb=815cb5e60e3e6a8adbb8ae413fed59de5c2b8764

      Сами разрабы пишут: если работает - не стоит ничего менять

      https://fosdem.org/2015/schedule/event/vlc/attachments/slides/751/export/events/attachments/vlc/slides/751/vlc202.pdf

      Удалить
    5. =Не стоит перепечатывать новости не проверив работоспособность проги. Разрабы её "пилят" ещё=
      1. Совершенно верно. В статье указывается, что программа разрабатываемая и даже подчёркнуто это перед командами установки.
      2. =С Вашим опытом и большой аудиторией Вам должно прийти чувство ответственности.= Я ни кого не уговаривал устанавливать программу, а лишь выложил возможность установки для тестирования, так что ВЫ =Будьте внимательны!=
      3. Какие статьи публиковать на сайте, а какие - нет, позвольте мне решать, как админу сайта. Или Вы, Евгений, позиционируете себя здесь куратором?

      Удалить
    6. Владимир, большое спасибо Вам за этот сайт!

      Позиционирую себя как читателя ;) Правильный ответ?

      Удалить
    7. =Позиционирую себя как читателя ;) Правильный ответ?= Не надо ёрничать и передёргивать. Так было бы правильней. Вы здесь не первый, кто приходит в чужой дом с своими указаниями. Создайте "правильный" блог (дом) и выкладывайте в нём "правильные" статьи, а я и другие пользователи будем их с удовольствием читать.

      Удалить
    8. Спокойно! В мои планы не входит ссориться с Вами.

      Были некие критические замечания, которые явно не относятся к политике ведения вашего блога.

      Удалить
  2. В Mint 13 без вопросов и проблем.Сразу.

    ОтветитьУдалить
  3. Я так понял, что это толи альфа, толи бета версия и от ее установки, пока стоит воздержаться)

    ОтветитьУдалить
  4. Пакеты, имеющие неудовлетворённые зависимости:
    vlc : Зависит: vlc-nox (= 3.0.0~~git20150213+r59451+33~ubuntu14.04.1) но 2.1.4+git20150212+r54593+19+11~ubuntu14.04.1 будет установлен
    Зависит: libavcodec55 (>= 6:9.1-1) но он не может быть установлен или
    libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) но он не может быть установлен
    Зависит: libavutil53 (>= 6:9.1-1) но он не может быть установлен
    Зависит: libgles1-mesa (>= 7.8.1) или
    libgles1
    Зависит: libvlccore8 но он не будет установлен
    Ломает: vlc-nox (< 2.2.0~pre2-2~) но 2.1.4+git20150212+r54593+19+11~ubuntu14.04.1 будет установлен
    Ломает: vlc-plugin-pulse (< 2.2.0~pre2-2~) но 2.1.4+git20150212+r54593+19+11~ubuntu14.04.1 будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    Linux mint 17.1 xfce

    Спасибо, но пока попользуем стандартную ppa:videolan/stable-daily

    ОтветитьУдалить
  5. На 14.04 все так же, как и у Вас, Антон.Может быть сначала надо обновить его до 2.2 (сейчас стоит 2.1.6)?

    ОтветитьУдалить
    Ответы
    1. Если не ошибаюсь для libavcodec55 нужно сначала поставить ffmpeg

      Удалить
  6. Уважаемый Админ, я вот например, трудностей не страшусь, но ума мне это не добавляет :) Можно по подробней, или ссылку на ВСЕ пакеты (интересует х64) или то как их там найти? Обычно справа есть "мастер" которым все пакеты скачиваются а тут нету... Возможно чем то помочь? (у меня тоже минт 17)

    ОтветитьУдалить
    Ответы
    1. Как установить ВСЕ пакеты программы?
      1. В конце статьи есть ссылка - Источники: https://launchpad.net/~videolan/+archive/ubuntu/master-daily
      2. Когда откроется эта страница, кликните справа на ссылке: View package details
      3. Открываете пакет для ubuntu14.04.1: vlc - 3.0.0~~git20150213+r59451+33~ubuntu14.04.1
      4. Выбираете и устанавливаете Package files (deb) для своей системы:
      Package files

      libvlc-dev_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (26.4 KiB)
      libvlc-dev_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (26.4 KiB)
      libvlc5_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (45.2 KiB)
      libvlc5_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (47.6 KiB)
      libvlccore-dev_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (115.4 KiB)
      libvlccore-dev_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (115.5 KiB)
      libvlccore8_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (383.8 KiB)
      libvlccore8_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (380.9 KiB)
      vlc-data_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_all.deb (4.8 MiB)
      vlc-dbg_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (25.2 MiB)
      vlc-dbg_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (24.5 MiB)
      vlc-nox_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (2.4 MiB)
      vlc-nox_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (2.3 MiB)
      vlc-plugin-fluidsynth_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (5.6 KiB)
      vlc-plugin-fluidsynth_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (6.1 KiB)
      vlc-plugin-jack_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (11.0 KiB)
      vlc-plugin-jack_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (11.1 KiB)
      vlc-plugin-notify_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (5.1 KiB)
      vlc-plugin-notify_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (5.4 KiB)
      vlc-plugin-pulse_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_all.deb (888 bytes)
      vlc-plugin-samba_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (4.8 KiB)
      vlc-plugin-samba_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (4.9 KiB)
      vlc-plugin-sdl_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (7.8 KiB)
      vlc-plugin-sdl_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (7.6 KiB)
      vlc-plugin-svg_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (6.0 KiB)
      vlc-plugin-svg_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (6.0 KiB)
      vlc-plugin-zvbi_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (10.6 KiB)
      vlc-plugin-zvbi_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (10.5 KiB)
      vlc_3.0.0~~git20150213+r59451+33~ubuntu14.04.1.dsc (4.2 KiB)
      vlc_3.0.0~~git20150213+r59451+33~ubuntu14.04.1.tar.gz (29.8 MiB)
      vlc_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_amd64.deb (1.4 MiB)
      vlc_3.0.0~~git20150213+r59451+33~ubuntu14.04.1_i386.deb (1.4 MiB)

      Вот и вся премудрость установки программы вручную.

      Удалить
    2. Ну так то... Вполне реально :) Спасибо.

      Удалить
  7. вообщем тоже повёлся на обновление,и зря,сам плеер не обновился,и незапускается,кроме этого он ещё и убил другую программу paromplayertv что тоже перестал запускаться,решил удалить,а при удалении предлагает удалить и сам paromplayertv,отказался от удаления,вообщем у меня такая беда была и раньше,помогло только переустановка системы, у меня LinuxMint17.1-kde32

    ОтветитьУдалить
    Ответы
    1. Дмитрий, я в предыдущем комментарии пояснил, как установить VLC 3.0 вручную. А ParomplayerTV нужно просто преустановить и он вновь будет работать: sudo apt-get install --reinstall paromplayer

      Удалить
  8. я это уже попробовал,поскачивать пакеты ,больше половины почти все не хотят устанавливаться, вылетало куча всяких разных ошибок,и пишет чтоб в терминале запустили sudo apt-get install -f и после этого предлагает удалить тотже самый пакет который я пытался установить,вообщем понял что бесполезно всё это и попробовал реанимировать паромплеер как вы написали sudo apt-get install --reinstall paromplayer ,и вот что пишет терминал Переустановка paromplayer невозможна, он не скачивается , решил переустановить пакетом скачанным,вроде установило но незапускается,вообщем понял что надо уже переустанавливать систему,ведь так старался всё настроил,установил,и тут такое убийство других программ,ну вообщем ещё чтото может и убило ,но проверять не буду,а ведь в статье не написано что это бета и устанавливать на свой страх и риск,очень жаль,придётся переустанавливать систему !

    ОтветитьУдалить
    Ответы
    1. =понял что надо уже переустанавливать систему,ведь так старался всё настроил,установил,и тут такое убийство других программ,ну вообщем ещё чтото может и убило ,но проверять не буду,а ведь в статье не написано что это бета и устанавливать на свой страх и риск,очень жаль,придётся переустанавливать систему !=
      Очень жаль. На этот случай все эксперименты нужно делать в тестируемой системе, а не рабочей: http://compizomania.blogspot.com/2014/08/10-ubuntulinux-mint.html#more. И всегда нужно делать бекап системы на непредвиденный случай: http://compizomania.blogspot.com/2014/07/systemback-linux.html

      Удалить
    2. Судя по отзывам я бы назвал ее альфа версией
      А я как увидел в статье подчернутое слово "разрабатываемую версию VLC 3.0" сразу подумал что део не чисто зашел на сайт VLC увидел что новой версии нет и решил не рисковать)
      Компизомания конечно уважаемый сайт, но и свою голову никто не отменял)))

      Удалить
    3. Кстати, у меня в Linux Mint 17.1 XFCE обе программы: VLC 3.0 и ParomplayerTV работают исправно.

      [im]http://s019.radikal.ru/i614/1502/1e/145b794ddf0a.png[/im]

      Удалить
    4. А как бы удалить старую версию и поставить заново, но уже стандартную ?
      sudo apt-get remove --purge vlc*

      sudo apt-get install vlc

      Удалить
  9. http://my-files.ru/lt2ven ссылка на разбитый по папкам набор файлов для установки. Отдельно папка для х64 и х32. Распаковываем и адрес папки в команду (вместо просто "./": sudo dpkg –i ./*.deb

    ОтветитьУдалить
    Ответы
    1. Да как хотите... Если для Вас этот вариант приемлем, устанавливайте так. Главное ведь, чтобы программа установилась и работала, а не способ её установки.

      Удалить
    2. Ну просто подумал что пришлось сортировать, скачивать по одному... Может кому "влом" а я уже сделал :) Не жалко ведь...

      Удалить
    3. Анатолий, а VLC 3.0 работает после установки вручную? И система не упала?

      Удалить
    4. Нет. Не работает :(
      При обработке следующих пакетов произошли ошибки:
      vlc
      vlc-nox
      vlc-plugin-fluidsynth
      vlc-plugin-jack
      vlc-plugin-notify
      vlc-plugin-pulse
      vlc-plugin-samba
      vlc-plugin-sdl
      vlc-plugin-svg
      vlc-plugin-zvbi
      vlc-dbg

      Удалить
    5. Тогда устанавливайте deb пакеты из перечня сверху вниз по одному, а не командой sudo dpkg –i ./*.deb, тогда зависимости программы будут поочерёдно удовлетворены.

      Удалить
  10. 14.10 с vlc 2.2 обновился до 3.0 нормально. Вроде все работает. Получается, что 2.2 до 3.0 можно обновить без танцев, а 2.1_ уже придется устанавливать пакеты вручную.
    P.S. Кстати, 2.2 ведь тоже еще бета - не все "карточки" закрыты.

    ОтветитьУдалить
  11. так вот у меня и было обновление с версии 2.2 до 3й,вот и не прокатило,может с кде какие-то несовместимости,а может и с trusty не очень дружит,а темболее trusty да ещё и с кде,но уже переустановил.

    ОтветитьУдалить
    Ответы
    1. Дмитрий Налисниченко: я вот вас спрошу. А вы разработчик программных продуктов, имеете опыт по отладке софта, знаете, как сообщать об ошибках, и т.д. Если нет, то зачем ставили альфа версию данной проги, да и на рабочей машине ? И стабильная версия VLC бывает создает проблемы, а тут альфа....

      Удалить
  12. Я непонимаю зачем ОС переустановить удалил VLC подчистил хвосты и установил прежнюю

    ОтветитьУдалить
  13. Столько #рача
    Из принципа потратил 30 мин времени и после выполнения следующих трёх команд тройка встала без проблем linux mint 17.1 xfce

    sudo add-apt-repository ppa:motumedia/libav10-trusty
    sudo apt-get update
    sudo apt-get install libavcodec-extra-55

    Людям котрые ставят нестабильные версии программ желаю терпения и учите матчасть!

    ОтветитьУдалить
    Ответы
    1. Если работает не трогай но это же не интересно люди даже ОС из за етого переустанавливает и по этому приходит опыт

      Удалить
    2. Опыт это когда понимаешь что делаешь, а бездушная переустановка системы это не гуд... так что учимся читать вывод терминала если пользуемся apt-get или изучаем работу synaptic...

      Удалить
    3. ну если непонимаеш это тоже опыт а synaptic ну надо разбиратся http://compizomania.blogspot.com/p/10-ubuntulinux-mint.html

      Удалить
    4. Антон Казанцев! Блестяще ! Огромное спасибо . Благодаря Вам всё установилось и всё работает. Молодчина !!!!

      Удалить
    5. Ну хоть кому-то помогло! А спасибо как всегда Владимиру! Можно и материально)))

      Удалить
  14. http://i64.fastpic.ru/big/2015/0215/2f/01d9147b11ff274f82fc9b1cc520322f.png

    ОтветитьУдалить
  15. Загружался сейчас с liveusb mint 17.1 xfce что бы проверить свой совет
    добавляем
    sudo add-apt-repository ppa:motumedia/libav10-trusty
    перед sudo apt-get update
    в инструкции в статье и далее никаких хлопот.
    это для всех 14.04 если я правильно понимаю trusty в имени ppa

    ОтветитьУдалить
  16. Сырая еще эта тройка (на каких-то роликах вдруг "вывести звук не удалось", ну итп) - ставить ее смысла нет особого. Ну если только разработчикам помогать с багрепортами.
    А вот как 2.2 (почти готовую бету) прикрутить на 14.04 вместо 2.1.6? Тем более, что в 14.10 vlc 2.2 идет из коробки.

    ОтветитьУдалить
    Ответы
    1. Ну если так хотите 2.2 то попробуйте https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media/+build/6590780

      Удалить
  17. сырой плеер паром плаеер не запустился и тано тоже так что старая версия юзается на убунту 14.04

    ОтветитьУдалить
    Ответы
    1. Виктор, пусть плеер будет сырой. Но объясните как вы умудрились поломать паром?
      следуя этой инструкции поставил vlc и паром сверху оба вместе работают... Может вы как то неправильно устанавливали и побили пакеты от которых зависит работа парома?

      Удалить
    2. Может вы как то неправильно устанавливали и побили пакеты от которых зависит работа парома?

      У меня паромплеер тоже убился,ставил по инструкции.Не понятно от чего это происходит,ведь не у всех так.Я удалил vlc и его репозиторий,после этого установил vlc 2.1 и паромплеер заработал.

      Удалить
  18. у меня тоже не получилось установить VLC на lubuntu 14.04.1

    ОтветитьУдалить
    Ответы
    1. http://fastpic.ru/view/64/2015/0216/5dc8ff0ca15ed9226fb273a6b93d2cf5.png.html

      Удалить
  19. привет всем
    помогите не могу установить VLC выдает ошибку
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    vlc : Зависит: vlc-nox (= 3.0.0~~git20150221+r59518+33~ubuntu14.04.1) но он не будет установлен
    Зависит: libavcodec55 (>= 6:9.1-1) но он не может быть установлен или
    libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) но он не может быть установлен
    Зависит: libavutil53 (>= 6:9.1-1) но он не может быть установлен
    Рекомендует: vlc-plugin-notify (= 3.0.0~~git20150221+r59518+33~ubuntu14.04.1) но он не будет установлен
    Рекомендует: vlc-plugin-samba (= 3.0.0~~git20150221+r59518+33~ubuntu14.04.1) но он не будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    ОтветитьУдалить
    Ответы
    1. В комментарии Антона Казанцева на этой странице объясняется, как это исправить и установить VLC 3: http://compizomania.blogspot.com/2015/02/vlc-30.html?showComment=1423979952722#c514613850371360897

      Удалить