06 февраля 2015

Установить/обновить ядро Linux Kernel 3.18.6 (Stable) в Ubuntu и производные

Linux Kernel 3.18.6 является шестым корректировочным выпуском ядра версии 3.18. Список изменений в ядре 3.18.6 можно посмотреть ЗДЕСЬ.
Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.

Установить ядро версии 3.18.6 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 15.04/14.10/14.04/12.04
Linux Mint 17/13
elementary OS 0.2/0.3

Установка ядра Linux Kernel 3.18.6 в терминале

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера, на свой страх и риск:

Для 32-bit (одной командой):

cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.6-vivid/linux-headers-3.18.6-031806-generic_3.18.6-031806.201502061036_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.6-vivid/linux-headers-3.18.6-031806_3.18.6-031806.201502061036_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.6-vivid/linux-image-3.18.6-031806-generic_3.18.6-031806.201502061036_i386.deb && sudo dpkg -i *.deb

Для 64-bit (одной командой):
 
cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.6-vivid/linux-headers-3.18.6-031806-generic_3.18.6-031806.201502061036_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.6-vivid/linux-headers-3.18.6-031806_3.18.6-031806.201502061036_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.6-vivid/linux-image-3.18.6-031806-generic_3.18.6-031806.201502061036_amd64.deb  && sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
. Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой:

uname -r

Примечание 2
. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 3.18.6, выполните эту команду:

sudo apt-get purge linux-image-3.18.6-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

 Если у вас появились вопросы, обращайтесь на наш форум:  http://compizomania.54672.x6.nabble.com/

16 комментариев :

  1. Ответы
    1. ==Нвидиа починили?==
      А кто его ломал, чтобы чинить?

      Удалить
  2. "Нахлобучил" на Nvidia-331 в Минт13.Сижу тащусь.Это даже не ракета, молния правильней. И "старый" сомпиз и Super Boot, всё работает как часы, ну может даже немного лучше :))

    ОтветитьУдалить
  3. Что это такое?- "Error! Bad return status for module build on kernel: 3.18.6-031806-generic (x86_64)
    Consult /var/lib/dkms/broadcom-sta/6.30.223.141/build/make.log for more information."
    Что в make.log не так? - http://www.fayloobmennik.net/4586364

    ОтветитьУдалить
    Ответы
    1. https://launchpad.net/ubuntu/+archive/primary/+files/bcmwl-kernel-source_6.30.223.248%2Bbdcom-0ubuntu2_i386.deb

      Удалить
  4. И как его удалить? http://imgur.com/uhOkHRL

    ОтветитьУдалить
    Ответы
    1. В Linux есть очень хороший инструмент по имени Synaptic. Установи, если не установлен: sudo apt-get install synaptic, открой его, введи в поле поиска linux-image-3.18.6 и удали.

      Удалить
    2. Владимир, у Санька проблемы с драйвером Broadcom. Ссылку я ему дал на обновление (правда архитектура 386), но думаю он разберется! А так, проблем нет - полет нормальный...

      Удалить
    3. Synaptic тоже самое выдаёт http://i.imgur.com/5ctfasL.png ... А для проприориетарных драйверов какой репозиторий надо?

      Удалить
    4. В Linux есть очень хороший инструмент по имени Synaptic. Установи, если не установлен: sudo apt-get install synaptic, открой его, введи в поле поиска linux-image-3.18.6 и удали
      Владимир хорошо написал

      Удалить
    5. Я думал,по картинке заметно будет,что последовать указаниям Владимира не удаётся...

      Удалить
  5. "Старое" не обязательно хуже Нового. При использовании FireFox нового созыва постоянно горела лампочка ЖД ,возник вопрос,что кто-то использует систему..Если пройти по пути user/lib/gvfsd/...metadata и удалить его то и проблем нет.И последствий тоже.Просто система меньше грузиться и никто ни куда ничего не отправляет.Странно. И лампочка больше не "горит".

    ОтветитьУдалить
  6. как вот это лечить
    [ 1.646859] [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
    [ 1.646860] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun

    ОтветитьУдалить
    Ответы
    1. ==как вот это лечить == Не устанавливать это ядро.

      Удалить