06 января 2015

Установить последнюю версию Java 8 в Ubuntu 14.10/Linux Mint 17.1 и старше

Что такое Java?

Программное обеспечение Java позволяет играть в сетевые игры, общаться с людьми по всему миру, подсчитывать проценты по ипотечным кредитам и просматривать трехмерные изображения. Приложения, которые написаны на языке программирования Java и доступ к которым можно получить из браузера, называются "апплетами". Крупные компании также используют апплеты Java для интранет-приложений и для систем электронной коммерции.
Программное обеспечение Java для компьютера или среду исполнения Java называют также средой Java Runtime, средой выполнения, JRE, виртуальной машиной Java, виртуальной машиной, Java VM, JVM, VM или загружаемыми файлами Java.

Поскольку Java не устанавливается по умолчанию в Ubuntu или других дистрибутивах основанных на Debian, то пользователи должны загрузить исполняемые файлы Java c сайта Oracle и установить их вручную, что не всегда просто для некоторых пользователей.
В этой статье я покажу вам, как установить Java 8 в Ubuntu 14.10/Linux Mint 17.1 или старше с помощью репозитория созданного голландской командой Duinsoft.

Устанока Java 8 в Ubuntu 14.10/Linux Mint 17.1 и старше

Примечание. Прежде чем установить Java 8, разработчики Oracle рекомендуют удалить старую версию, если она установлена в вашей системе следующими командами в терминале:

sudo apt-get purge openjdk*
sudo apt-get autoremove


Установка Java 8

Выполните эти команды а терминале для установки Java 8:

sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 5CB26B26
echo "deb http://www.duinsoft.nl/pkg debs all" | sudo tee -a /etc/apt/sources.list.d/duinsoft.list
sudo apt-get update
sudo apt-get install update-sun-jre


По окончании установки вы можете проверить установленную версию Java на сайте http://www.java.com/ru/download/installed.jsp, нажав кнопку Проверьте версию Java.



А также в браузере Firefox: Меню - Инструменты - Дополнеия - Плагины:


Домашняя страница Duinsoft

Удвчи.

11 комментариев :

  1. В Мозилле сработало, а Опера пишет, что плагин не поддерживается.

    ОтветитьУдалить
  2. проверка показала что Java актуальна после установки по этой инструкции:
    http://compizomania.blogspot.com/2014/03/oracle-java-8-ubuntulinux-mint.html

    а есть какие то отличия?

    ОтветитьУдалить
    Ответы
    1. Отличий нет. Просто другой репозиторий.

      Удалить
  3. А почему в хроме не поддерживается Java, а в Firefox все ок?

    ОтветитьУдалить
    Ответы
    1. =А почему в хроме не поддерживается Java, а в Firefox все ок?= Chrome начиная с версии 34 выпилил NPAPI плагины, поэтому остается пользоваться только Firefox.

      Удалить
  4. Ответы
    1. Спасибо!!!!!!
      Просто в заглавии статьи написано "Минт - 17.1"

      Удалить
    2. В заголовке написано: Ubuntu 14.10/Linux Mint 17.1 и старше. И старше означает предыдущие дистрибутивы. ;)

      Удалить
  5. Сделал себе на Mint 17.1 MATE. все супер. теперь 8 версия)

    ОтветитьУдалить