27 июня 2014

Установить/обновить ядро Linux Kernel 3.15.2 (Stable) в Ubuntu/Linux Mint

Linux Kernel 3.15.2 является вторым корректировочным выпуском ядра версии 3.15. Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.

Установить ядро версии 3.15.2 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 14.04/13.10/12.04
Linux Mint 17/16/13

Установка ядра Linux Kernel 3.15.2

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера, на свой страх и риск:

Для 32-bit (одной командой):

cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15.2-utopic/linux-headers-3.15.2-031502-generic_3.15.2-031502.201406261639_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15.2-utopic/linux-headers-3.15.2-031502_3.15.2-031502.201406261639_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15.2-utopic/linux-image-3.15.2-031502-generic_3.15.2-031502.201406261639_i386.deb && sudo dpkg -i *.deb


Для 64-bit (одной командой):

cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15.2-utopic/linux-headers-3.15.2-031502-generic_3.15.2-031502.201406261639_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15.2-utopic/linux-headers-3.15.2-031502_3.15.2-031502.201406261639_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15.2-utopic/linux-image-3.15.2-031502-generic_3.15.2-031502.201406261639_amd64.deb && sudo dpkg -i *.deb


2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
. Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой:

uname -r


Примечание 2. Если вы раньше устанавливали программу KernelUpdate, откройте её из Меню - Системные утилиты или перезагрузите свой компьютер и при новом входе в систему вы должны увидеть открытое окно xterm с извещением о новом ядре 3.15.2, при условии если вы прописывали KernelUpdate в Автоматически запускаемые приложения.
Нажмите клавишу Enter и следуйте инструкциям по установке ядра 3.15.2.

Примечание 3
. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 3.15.2, выполните эту команду:

sudo apt-get purge linux-image-3.15.2-*

Источник: https://www.kernel.org/

Удачи.

21 комментарий :

  1. Очень хороший сайт,спасибо создателю! 10 бал

    ОтветитьУдалить
  2. Вот по ссылке ОТСЮДА есть соответствующие deb пакеты, там на странице куча ссылок, как определить что конкретно скачивать что бы обновить ядро?

    ОтветитьУдалить
    Ответы
    1. Прочитать названия пакетов в команде установки, которая дана в статье, их и скачивать, чего же тут непонятного. И так по аналогии с любым ядром. А если короче - все файлы на странице под свою архитектуру, кроме "...lowlatency...", ядра lowlatency - для особых нужд.

      Удалить
    2. То есть я правильно понял, если например у меня установлена Убунта 64 битная, то я должен для обновления ядра установить пакеты три штуки:
      linux-headers-3.15.2-031502-generic_3.15.2-031502.201406261639_amd64.deb
      linux-headers-3.15.2-031502_3.15.2-031502.201406261639_all.deb
      linux-image-3.15.2-031502-generic_3.15.2-031502.201406261639_amd64.deb
      Я правильно понял?
      Кстати, устанавливать их в любой последовательности?

      А не понятно мне просто потому, что на линуксе сижу совсем не долго и еще не обновлял ядро)))

      Удалить
    3. >>Я правильно понял?<<

      Да, правильно.

      >>Кстати, устанавливать их в любой последовательности?<<

      Я точно не помню, важна ли в данном случае последовательность. Вообще, для установки скачанных пакетов удобно использовать утилиту gdebi (есть в стандартных репозиториях). В Nautiluse ПКМ на файле - открыть в gdebi. Если другой пакет должен быть установлен "вперед", gbebi укажет на неудовлетворенную зависимость, таким образом последовательность установки невозможно будет перепутать.

      Удалить
    4. Спасибо за gdebi
      И еще один вопрос, что можете сказать о KernelUpdate не проще ли обновлять ядро через нее?

      Удалить
    5. Теоретически проще, но вручную надежнее. Такие написанные умельцами скрипты, вроде KernelUpdate, конечно, хороши, но имеют свойство устаревать, когда умельцы перестают их поддерживать. Рано или поздно, скрипт в лучшем случае перестанет работать, в худшем - установит какие-нибудь левые пакеты... Ну его нафиг, ИМХО. Вручную три файла скачать и поставить, ей-Богу, совсем несложно.

      Удалить
    6. Прирост производительности 30%. Только ручками, всё становится, но и гуглить тоже, есть много рекмендов, собрал коллекцию, классифицирую, потом обязательно поделюсь, кстати Спасибо за советы Всем.

      Удалить
    7. "Прирост производительности 30%"
      Замеряли наверное Phoronix Test Suite-очень мощная утилита -если можно ссылочку на ваши результаты-любопытно посмотреть-до и после

      Удалить
    8. На глаз заметно, я не меряю утилами, по Ване меряю, как виндасофт идет, экспереминтатор я, основной момент, ...в ване авто кад пашет быстрей чем в винде, проюзивал ваню сам, почему в винде с ним не работаю? комп на работе не тянет, вот и приходится извращатся,

      Удалить
  3. у меня две системы, тестовая и основная, на тестовой обновил ядро до Linux Kernel 3.15.2, на основной стандартное ядро Убунты Kernel 3.13.0 разницы не ощутил)))

    ОтветитьУдалить
  4. после обновления до 3.15.2 не видит интерфейс wlan0, соответственно, не работает wifi. подскажите, пжст, дальнейший ход действий.

    ОтветитьУдалить
    Ответы
    1. Загрузиться на старом ядре, выбрав соотв.пункт в Grub, и удалить новое ядро, как указано в статье
      sudo apt-get purge linux-image-3.15.2-*

      Подробнее здесь:
      http://compizomania.blogspot.com/2012/09/ubuntu-121012041110linux-mint-13.html
      (эта ссылка тоже взята из статьи). Вся информация перед глазами, зачем задавать вопросы? Или Вы желаете непременно поднять wifi на новом ядре? :) Боюсь, вслепую таких инструкций Вам здесь никто не даст. Мало ли отчего он может не работать.

      Удалить
    2. У меня получилось установкой deb-пакета под свою версию Убунты по этой ссылке https://launchpad.net/ubuntu/+source/bcmwl

      Удалить
    3. Вопрос к Максиму Пузыреву? С ядром понятно, пашет, почему компиз в новых версиях не работает вообще, даже жидкие окна не включаются?

      Удалить
    4. >>почему компиз в новых версиях не работает вообще<<

      В новых версиях чего? Вы имеете в виду новую версию Ubuntu? Но если бы компиз в ней не работал, Вы имели бы пустой экран без панелей. Рабочее окружение Unity основано на compiz, это его плагин. Почему не включаются жидкие окна, не знаю. Возможно, нет прав на перезапись соотв.файла настроек в дом.папке, либо в Ubuntu разработчики специально каким-то образом защитили настройки компиз от перезаписи. Мне сложно сказать, я обычно пользуюсь Xfce без компиза, а в данный момент вообще осваиваю KDE. Возможно, подскажет кто-нибудь другой. Можете создать топик на форуме с описанием симптомов. http://compizomania.blogspot.com/p/blog-page_2482.html

      Удалить
    5. В новых версиях чего?


      юнити, минт мате, другие оболочки не признаю, не нравятся просто, ноут вроде резвый, 3 винта переставляю, на каждом своя, винда голимая для игрушек внуку на третьем, виртуал бокс не признаю, ну да ладно буду юзать далее, спасибо.

      Удалить
    6. В Mate по умолчанию нет compiz, там marco. Compiz нужно прикручивать отдельно через dconf. http://compizomania.blogspot.com/2013/12/compiz-linux-mint-16-mate.html
      По поводу не включающихся/редактирующихся эффектов я описывал что-то подобное применительно к xfce+compiz, можете почитать, может, натолкнет на какую мысль:
      http://compizomania.blogspot.com/2013/08/compiz-xubuntu-1304.html

      Удалить
  5. Error! Bad return status for module build on kernel: 3.15.2-031502-generic (x86_64)
    Consult /var/lib/dkms/fglrx/14.200/build/make.log for more information.

    Как побороть эту ошибку?

    ОтветитьУдалить
  6. 3.15 не дружит с моим PCH чипом, да ну и фиг с ним! Откат на 3.14.8

    ОтветитьУдалить
  7. Этот комментарий был удален автором.

    ОтветитьУдалить