13 мая 2014

Установить гоночную игру Stunt Rally 2.3 в Ubuntu 14.04 и производные

Stunt Rally, это гоночная игра для Linux и Windows c доступными треками, сценариями, гоночными машинами и редактором треков. В игре предстоит ездить на закрытых ралли треках с элементами трюков: бездорожье, петли, прыжки, трубы и пр.
В качестве движка для симуляции машин используется Vdrift, а весь рендеринг выполняет Ogre3D. Среди других используемых технологий PagedGeometry для отрисовки декораций (деревья, трава) и MyGUI. http://compizomania.blogspot.com/


Основной список изменений в версии Stunt Rally 2.3:
    153 трека (7 новых, 27 переименовано).
    Все треки визуально улучшены.
    Новые текстуры местности.
    Динамическая камера подпрыгивает вместе с машиной, добавлены ползунки углов обзора камеры.
    Добавлена функция выбора количества топлива в зависимости от длины трека.
    Добавлены различные визуальные настройки для травы, например плотность травы, цвет, направление цвета.
    Добавлена опция ограничения fps.
    Различные улучшения редактора игры: окно для выбора текстуры местности, растительности, травы и моделей; вкладка настройки трэка с выбором таких функций, как гравитация, ветер и т.д.

Рекомендуемые системные требования

Двухядерный процессор; видеокарты: GeForce 9600 GT или Radeon HD 3870. Запуск возможен и на более старых моделях видеокарт с поддержкой 3-их шейдеров.

Посмотрите этот видео-ролик, чтобы иметь представление об игре:


Установка Stunt Rally 2.3 в Ubuntu 14.04 и производные

Выполните следующие команды в терминале:

sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu trusty-getdeb games" >/etc/apt/sources.list.d/playdeb.list'

wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

sudo apt-get update && sudo apt-get install stuntrally


Источник:  Stunt Rally game with Track Editor http://compizomania.blogspot.com/

Удачных гонок.

13 комментариев :

  1. Здравствуйте! При установке появляется ошибка:

    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    stuntrally : Зависит: libogre-1.9.0 но он не может быть установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    Linux MInt 16 Cinnamon

    ОтветитьУдалить
    Ответы
    1. К сожалению данный репозиторий для Ubuntu 14.04, а Linux MInt 16, это Ubuntu 13.10. Подожди до выпуска Linux MInt 17 и установи игру.

      Удалить
    2. Скачал deb с офсайта, установил, работает, но тормозит :'-(

      Удалить
    3. Как правило, игры на компьютере "тормозят" из-за параметров железа, в основном от количества ядер процесса, ОЗУ (памяти) и видеокарты. Чем новее компьютер и видюха, тем лучше работают игры. Но лучше всего иметь приставку с играми, подключённую к монитору/телевизору.

      Удалить
  2. Ответы
    1. sudo apt-get remove --purge stuntrally
      sudo apt-get autoremove

      Удалить
  3. Народ, а не знайте какие нибудь шутеры для Linux? Главное что бы русифицированы были.

    ОтветитьУдалить
  4. Владимир, игра не запускается, ошибок нет, запуска нет. Я подумал что проблема в видео карте Radeon HD 3870 и решил установить проприетарные драйвера, инструкции читал в сети. Корректно я не установил драйвер в Ubuntu 14.04, 64 bit. Сейчас разрешение не 1400*900 а только 1152*864. Без Вашей помощи никак! Как же установить проприетарный драйвер для ATI Radeon HD 3870 ? Помогите пожалуйста.

    ОтветитьУдалить
    Ответы
    1. Igor K, мне сложно правильно ответить на Ваш вопрос о драйвере AMD, т.к. у меня на компьютерах только Nvidia и Intel. Посмотрите эту инструкцию по правильной установке драйвера AMD: https://help.ubuntu.com/community/BinaryDriverHowto/AMD

      Удалить