24 декабря 2013

Как установить драйверы для принтеров Canon PIXMA MP Series в Ubuntu/Linux Mint и производные

Хотя после установки Ubuntu  и подключения принтера в компьютеру большинство из них определяются автоматически, всё-таки некоторые драйверы для принтеров приходится устанавливать дополнительно.

В этой статье я покажу вам, как установить драйверы для принтеров Canon PIXMA MP Series в Ubuntu 14.04 и старше, а также производные дистрибутивы от Ubuntu.



Прежде всего вы должны добавить репозиторий и обновить систему следующими командами в терминале:

sudo add-apt-repository ppa:michael-gruz/canon-trunk
sudo apt-get update


Данный перечень содержит драйверы для принтеров Canon, которые можно установить:

    Canon MP140 Ubuntu Driver – cnijfilter-mp140series
    Canon MP160 Ubuntu Driver – cnijfilter-mp160series
    Canon MP190 Ubuntu Driver – cnijfilter-mp190series
    Canon MP210 Ubuntu Driver – cnijfilter-mp210series
    Canon MP240 Ubuntu Driver – cnijfilter-mp240series
    Canon MP490 Ubuntu Driver – cnijfilter-mp490series
    Canon MP500 Ubuntu Driver – cnijfilter-mp500series
    Canon MP510 Ubuntu Driver – cnijfilter-mp510series
    Canon MP520 Ubuntu Driver – cnijfilter-mp520series
    Canon MP540 Ubuntu Driver – cnijfilter-mp540series
    Canon MP550 Ubuntu Driver – cnijfilter-mp550series
    Canon MP560 Ubuntu Driver – cnijfilter-mp560series
    Canon MP600 Ubuntu Driver – cnijfilter-mp600series
    Canon MP610 Ubuntu Driver – cnijfilter-mp610series
    Canon MP630 Ubuntu Driver – cnijfilter-mp630series

После того как вы добавили репозиторий и обновили систему командами выше, выберите драйвер для своего принтера и установите одной из команд, соответственно вашему принтеру:

Canon MP140:

sudo apt-get install cnijfilter-mp140series

Canon MP160:

sudo apt-get install cnijfilter-mp160series
Canon MP190:

sudo apt-get install cnijfilter-mp190series

Canon MP210:

sudo apt-get install cnijfilter-mp210series

Canon MP240:

sudo apt-get install cnijfilter-mp240series

Canon MP490:

sudo apt-get install cnijfilter-mp490series

Canon MP500:

sudo apt-get install cnijfilter-mp500series

Canon MP510:

sudo apt-get install cnijfilter-mp510series

Canon MP520:

sudo apt-get install cnijfilter-mp520series

Canon MP540:

sudo apt-get install cnijfilter-mp540series

Canon MP550:

sudo apt-get install cnijfilter-mp550series

Canon MP560:

sudo apt-get install cnijfilter-mp560series

Canon MP600:

sudo apt-get install cnijfilter-mp600series

Canon MP610:

sudo apt-get install cnijfilter-mp610series

Canon MP630:

sudo apt-get install cnijfilter-mp630series

Удачи.

13 комментариев :

  1. Ubuntu 12.04 (не знаю, как для другіх, но может кому понадобиться)
    Canon MP280:
    sudo add-apt-repository ppa:michael-gruz/canon-trunk
    sudo apt-get update
    sudo apt-get install cnijfilter-common cnijfilter-mp280series scangearmp-common scangearmp-mp280series

    ОтветитьУдалить
  2. Забыл, простите, это драйвер что бы заработал СКАНЕР - основная проблема, а принтр определился автоматом.

    ОтветитьУдалить
  3. Спасибо!!!У меня МП-540,правда работает.

    ОтветитьУдалить
  4. Спасибо большое за статью!
    Где же Вы были неделю назад когда я мучался с установкой принтера?..))

    Подскажите, есть ли возможность заставить работать МФУ от того же Canon (PIXMA MG2240)?
    Принтер завёлся нормально, а вот сканер никак не определяется Xsane-ом.
    Смог его заставить хоть как-то работать только с помощью Vuescan, но он платный, это не Linux-way))

    ОтветитьУдалить
  5. Спасибо! Но моего принтера MP230 в списке нету, а с ним проблема со сканером в Mint16. Если кто решил проблемку поделитесь решением.

    ОтветитьУдалить
  6. http://support-in.canon-asia.com/contents/IN/EN/0100466201.html Может с этим заработает.

    ОтветитьУдалить
  7. Разобрался со сканером из МФУ.
    Оказывается, с ним можно работать только через фирменный scangearmp

    ОтветитьУдалить
  8. Mint 17 x86_64
    sudo apt-get install cnijfilter-ip2700series
    Пакеты, имеющие неудовлетворённые зависимости:
    cnijfilter-ip2700series:i386 : Зависит: libtiff4:i386 (> 3.9.5-3~) но он не может быть установлен
    Устанавливаем libtiff4_3.9.7-2ubuntu1_i386.deb
    sudo apt-get install cnijfilter-ip2700series
    Все установилось!! но не работает
    $ /usr/bin/canon-maintenance
    /usr/bin/canon-maintenance: строка 32: [: =: ожидается использование унарного оператора
    /usr/bin/canon-maintenance: строка 34: [: =: ожидается использование унарного оператора
    Unknown switch, -P

    ОтветитьУдалить
    Ответы
    1. Так а что в этих строках?

      Удалить
    2. 32 if [ ${ver[1]} = "3.80" ]; then
      cngpijmnt ${printer[1]}
      34 elif [ ${ver[1]} = "3.90" ]; then
      cngpijmnt ${printer[1]}

      Удалить
  9. Приветствую всех! Кто подскажет как в настройках этой мфу выставить черновую печать? Много жрет краски если все оставить как есть.
    Во вкладке качество печати есть только как обычно и ручной режим :idiot2:
    http://storage7.static.itmages.ru/i/14/1229/h_1419878249_3577299_2971cbda4f.png
    http://storage9.static.itmages.ru/i/14/1229/h_1419878301_2137665_2ef1fbbae7.png

    ОтветитьУдалить