01 октября 2012

Установить ядро Linux kernel 3.6 в Ubuntu 12.10/12.04/Linux Mint 13


Ядро Linux kernel 3.6 было выпущено недавно с большим количеством новых функций и усовершенствований по сравнению с предыдущими версиями ядра. Среди примечательных особенностей в этой последней версии, является введение hybrid sleep (гибридный спящий режим), это новая функция, которая позволит компьютерам и ноутбукам выходить из режима ожидания в случае перерыва (отключения) в электроснабжении .
Это ядро ​​также предлагает улучшенное управление питанием и улучшенная поддержка устройств Android. Другие функции и изменения в ядре 3.6 можно посмотреть ЗДЕСЬ.

Вы можете установить Linux Kernel 3.6 в следующих дистрибутивах:

    Ubuntu 12.10/12.04/11.10 и старше
    Linux Mint 13/12 и старше


Установка ядра 3.6.0

Откройте терминал и выполните следующие команды для 32-bit и 64-bit систем:

cd /tmp

wget http://dl.dropbox.com/u/47950494/upubuntu.com/linux-kernel-3.6 -O linux-kernel-3.6

chmod +x linux-kernel-3.6

sudo sh linux-kernel-3.6

По окончании установки, перезагрузите систему, чтобы перейти на новое ядро.

После очередного входа в систему вы можете проверить версию ядра с помощью команды в терминале:

uname -r

Вы должны увидеть следующее:



Если вы столкнётесь с проблемой загрузки или не в состоянии запустить систему после обновления до нового ядра, то посетите ЭТУ страницу, которая поможет вам удалить Linux Kernel 3.6.0 и перейти на старое ядро.

Удачи.

19 комментариев :

  1. Не получается русифицировать AriOS4/ubuntu 12.04/.Через языковый селектор-пишит что нужно выполнить команду в терминале sudo apt-get install -f.Или выполнить установку через Synaptic.Но это не помогает.При вводе команды sudo apt-get install language-pack-ru-base в терминале пишет что выполнить невозможно так-как у вас отложились битые пакеты(held).Synaptic не показывает битых пакетов.

    ОтветитьУдалить
    Ответы
    1. Перезагрузи компьютер, когда появится загрузчик GRUB для выбора систем, клавишей со стрелкой Вниз опустись на вторую строчку Recovery mode и нажми Enter. Должен открыться перечень возможностей восстановления, опять же стрелкой вниз опустись до строки, где написано broken packets и нажми Enter, дождись окончания восстановления поломанных пакетов, после чего тебе будет предложено загрузится нормально. загрузи компьютер, как обычно и войди в систему.

      Удалить
  2. Спасибо!Сейчас попробую.

    ОтветитьУдалить
  3. Всё осталось без изменений.

    ОтветитьУдалить
  4. The following packages have unmet dependencies:

    language-pack-gnome-ru: Depends: language-pack-gnome-ru-base (>= 1:12.04+20120417) but 1:12.04+20120801 is to be installed
    language-pack-kde-ru: Depends: language-pack-kde-ru-base (>= 1:12.04+20120417) but 1:12.04+20120801 is to be installed
    language-pack-ru: Depends: language-pack-ru-base (>= 1:12.04+20120417) but 1:12.04+20120801 is to be installed
    Это с установки языков.

    ОтветитьУдалить
  5. niko@SATELLITE-L750:~$ sudo apt-get install language-pack-ru-base
    [sudo] password for niko:
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    language-pack-ru-base : Зависит: language-pack-ru (>= 1:12.04+20120801) но он не будет установлен
    Рекомендует: firefox-locale-ru но он не будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
    А это с терминалаю

    ОтветитьУдалить
    Ответы
    1. Зашёл я на этот персидский (иранский) сайт AriOS4, это бета версия где присутствует только два языка в настоящий момент: английский и персидский. Думаю, что твои старания с русификацией дистрибутива-напрасны.

      Удалить
    2. админу респект за публикации ядро обновлено http://rlu.ru/aAT

      Удалить
  6. Ядро встало, система запустилась без проблем, к сожалению не поднимает драйвер WiFi (лептоп Lenovo G570)

    ОтветитьУдалить
    Ответы
    1. И стоила игра свеч?

      Удалить
  7. Спасибо за содействие!Частично ОС русифицировалась.Пользоваться можно.

    ОтветитьУдалить
  8. Автору спасибо. Ubuntu 12.04 всё стало, всё работает.

    ОтветитьУдалить
  9. улучшенная поддержка устройств Android

    Поясните..

    ОтветитьУдалить
    Ответы
    1. Android, как известно, тоже базируется на ядре Linux.

      Удалить
    2. Это давно известно.Что подразумевается под поддержкой устройств Android?

      Удалить
    3. В статье ссылка есть специально для пытливых, открой и почитай.

      Удалить
    4. Зачем выделять что-то здесь,а потом посылать читать на сторонние ссылки???Не знаешь-так и напиши.

      Удалить
    5. Я что Всевышний, знать всё? Для того и ссылки даю, чтобы интересующиеся могли найти нужное именно для них.

      Удалить
  10. обновил на десктопе (12.04), на стадии загрузки ОС , как говорится, очень много букоф, и в конце описал мою USB-Keyboard и на этом все остановилось, мигающий курсор внизу экрана.
    пришлось при слежующей перезагрузке выбрать Previous Linux Version

    ОтветитьУдалить