17 июля 2012

Установить ядро Linux 3.4.5 в Ubuntu 12.04/Linux Mint 13


Ядро Linux 3.4.5 вышло с новыми возможностями и поддержкой большего количества драйверов. Вы можете найти полный список изменений для Linux Kernel 3.4.5 ЗДЕСЬ.
Прежде чем устанавливать это ядро, имейте ввиду, что переход на новое ядро ​​может сделать вашу систему нестабильной, а также могут не работать некоторые драйверы  видеокарт для NVIDIA или AMD, карты беспроводных устройств и т.д. Таким образом, устанавливайте ядро ​​на свой страх и риск.

Если вы всё-таки решились на установку, то откройте терминал, скопируйте и выполните следующие команды:

cd /tmp && wget -O linux-kernel-3.4.5 http://dl.dropbox.com/u/47950494/upubuntu.com/linux-kernel-3.4.5

chmod +x linux-kernel-3.4.5 && sudo sh linux-kernel-3.4.5

По окончании установки перезагрузите компьютер, стобы задействовать новое ядро.

После удачного входа в систему, проверьте используемое ядро следующей командой:

uname -r

Выход в терминале должен быть следующим:

3.4.5-030405-generic

Если вы хотите вернуться к предыдущему ядру и удалить новую версию, то выполните следующую команду:

sudo apt-get purge linux-image-3.4.5-030405-generic 

Удачи.

26 комментариев :

  1. Анонимный17 июля 2012 г., 14:55

    При обновлении ядра слетел драйвер видеокарты ATI, переустановка драйвера не помогла. Откатился на старое ядро.

    ОтветитьУдалить
    Ответы
    1. Я об этом предупреждал в статье. Удали новое ядро нижней командой.

      Удалить
    2. Анонимный17 июля 2012 г., 17:52

      Сначала удаляется драйвер,а потом обновляется ядро и снова устанавливается драйвер видеокарты!Кто же обнавляет ядро с установленным драйверов!?

      Удалить
    3. Анонимный17 июля 2012 г., 17:55

      Если не секрет для чего вы устанавливаете драйвер видеокарты? По моему в ubuntu он вообще не нужен.

      Удалить
    4. Анонимный17 июля 2012 г., 19:00

      А так же не нужны драйверы принтера, микрофона, веб-камеры, сканера и другие, без которых эта суперсистема - просто WEB браузер, который чуть меньше подвержен вирусам.
      Одно плохо - если хочется что-то распечатать, отредактировать в нормальных полнофункциональных приложениях, пообщаться - приходится перезагружаться в Windows.
      Установка драйверов в этой "суперсистеме" превращается в настоящие танцы с бубном.
      Но для мазохистов, которые решили попробовать это чудо - в самый раз.
      Даже для того, чтобы оставить здесь комментарий, приходится изрядно поломать глаза, хотя уже давно есть другие проверенные методы против спама.

      Удалить
    5. В компьютерах со встроенными графическими картами Nvidia/ATI, желательно устанавливать драйверы видеокарт, иначе придётся работать без ускорения 3D, а значит c Unity 2D. Если у тебя есть встроенная видеокарта, открой её окно и почитай для чего она служит.

      Удалить
    6. Анонимный17 июля 2012 г., 19:20

      давно ли ты порно баннер убирал со своего windows? Сидишь харакеришся!Что для тебя означает полнофункциональное приложение? И зачем ты вообще перезагружаешся на windows-сиди на нём постоянно в своей "СУПЕРСИСТЕМЕ"!

      Удалить
    7. Анонимный17 июля 2012 г., 19:33

      Видеокарта у меня не встроенная.
      Порнобанеров я вообще не ловил.
      А проблемы с установкой драйверов действительно существуют. И если даже делать всё по инструкции от canon, драйвер принтера Canon LBP2900 не устанавливается.
      И в самом деле, зачем мне это надо? Видимо для того, чтобы "гуру" в очередной раз ощутили себя "богами", когда "криворукие" что-то не могут.

      Удалить
    8. Ты если хочешь чего-то спросить, так спрашивай, только вот тролить не надо.
      А то развёл здесь супер-пупер...

      Удалить
    9. Анонимный17 июля 2012 г., 19:43

      Справедливое замечание. Просто немного поднадоело возиться установкой этих не самых сложных драйверов.
      Лучше убрать мои негативные сообщения.

      Удалить
    10. Анонимный18 июля 2012 г., 15:18

      перейди по этой ссылке и попробуй установить драйвер для своего принтера canon LPB2900 (http://itshaman.ru/articles/98/kak-ustanovit-printer-canon-lbp-2900-v-linux-ubuntu) надеюсь поможет!

      Удалить
    11. Анонимный18 июля 2012 г., 18:56

      Спасибо, кучу статей перерыл, но ... проблема остаётся и, похоже, не только у меня одного. Закрываем тему.

      Удалить
    12. Посмотри страницу по установке и отладке дайвера Canon LPB2900 ЗДЕСЬ.

      Удалить
    13. Анонимный20 июля 2012 г., 20:17

      Спасибо, посмотрел. Хрен вместо пирожка.
      И ответы http://forum.ubuntu.ru/index.php?topic=197502.msg1489674#new

      Удалить
    14. Какой заколдованный у тебя Canon. Не знаю, что и посоветовать.

      Удалить
  2. Анонимный17 июля 2012 г., 19:11

    Я всё прекрасно печатаю,обрабатываю фотографии,общаюсь в скайпе и всё это в ubuntu...извини конечно,но если у тебя кривые руки,то для тебя windows в самый раз.

    ОтветитьУдалить
    Ответы
    1. Анонимный17 июля 2012 г., 19:25

      Очень рад за тебя, что руки прямые. Поверь, я ни сколько не удивляюсь таким отношением от "гуру" поклонников Линукса к начинающим переходить на эту "суперсистему" "криворуких поклонников Windows".
      Действительно, что-то не очень у меня получается драйвер для своего принтера Canon LBP2900 нормально установить. Да и видеодрайвер ATI не хочет устанавливаться. Ну это видимо,только боги могут. спасибо за наставничество, очень помогло.

      Удалить
    2. Никто Вас использовать Ubuntu не заставляет. Нравится Windows пользуйте его. Не стоит начинать троллинг. По поводу принтера Вы бы хоть воспользовались поиском Google - http://t.co/wzsZPlJS. Куча мануалов на эту тему. Все уже придумано до Вас. По поводу видеокарт ATI, обращайтесь к тому же Google.

      Удалить
    3. Анонимный17 июля 2012 г., 19:53

      Я уже ответил выше админу:
      Анонимный17 июля 2012 г., 19:43
      Справедливое замечание. Просто немного поднадоело возиться установкой этих не самых сложных драйверов.
      Лучше убрать мои негативные сообщения.

      И погуглил по поводу драйверов, старые статьи не очень помогли. Но всё равно, спасибо за помощь.

      Удалить
    4. Проблема возникла аналогичная! Linux Mint 14 Mate. Принтер стоит, на печать отправляется исправно! Только не печатает! Варианты решения появились?

      Удалить
    5. Попробуй установить более новое ядро по инструкции ЗДЕСЬ. Возможно твой принтер будет печатать с новым ядром.

      Удалить
  3. Очень нужна помощь. Владимир, мне нужно установить jre-7u под оперу и файерфокс. Где это взять и как установить? Заранее благодарю.

    ОтветитьУдалить
    Ответы
    1. Почитай ЗДЕСЬ. Хотя и на английском, но думаю разберёшься.

      Удалить
  4. Я тоже хотел было попользоваться этой халявой Минт13 Мате; однако, не получилось: в упор не видит смартфон Нокия, блютус не работает, даже после установки Блюман. Также нет печати на Эпсон SX130. Все эти удовольствия есть в убунту10.10 без шаманизма; с теми же девайсами. Удивительно, релизы делают хуже предыдущих...

    ОтветитьУдалить
  5. конечно новые выпуски линукс хуже предыдущих. Идет на дно. ДНИЩЕ

    ОтветитьУдалить