22 ноября 2016

Как установить окружение Cinnamon 3.2 в Ubuntu 16.04/16.10

Cinnamon — свободная оболочка для среды рабочего стола GNOME, являющаяся ответвлением от кодовой базы GNOME Shell. Основное направление разработки — предоставление пользователю более привычной, традиционной среды в стиле GNOME 2, удобной пользователям настольных ПК и ноутбуков.

 Рабочий стол или окружение (кому как нравится) Cinnamon версии 3.2 выйдет в официальном релизе Linux Mint 18.1 в конце ноября/декабре, но уже сегодня можно установить Cinnamon 3.2 в Ubuntu 16.10/16.04, как дополнительное окружение.


Установка окружения Cinnamon 3.2 в Ubuntu 16.04/16.10

Примечание. Прежде чем устанавливать любое дополнительное окружение рабочего стола в дистрибутив Ubuntu, нужно всегда иметь ввиду тот факт, что в основной системе могут дублироваться какие-то программы, возникать непредвиденные регрессии и даже нестабильность работы системы.
Поэтому я всегда рекомендую перед установкой доп. окружения, установить программу Systemback и создать в ней точку возврата, чтобы без проблем удалить установленное окружение вместе с зависимостями пакетов приложений и вернуться к работе системы до установки окружения. Здесь вы найдёте Systemback с инструкцией по созданию точки возврата.

Установка Cinnamon 3.2

Откройте терминал, скопируйте и выполните следующие команды:

sudo add-apt-repository ppa:embrosyn/cinnamon
sudo apt-get update
sudo apt-get install cinnamon cinnamon-core


 Для входа в окружение Cinnamon по окончании установки, закройте все приложения, выйдите из системы и в окне нового входа выберите Cinnamon:

1. 


2. 


3. И ввести свой пароль для входа в окружение.


Удачи.

Почитать о новшествах  Cinnamon 3.2 можно ЗДЕСЬ.

12 комментариев :

  1. А если циннамон уже стоит? Система -минт 18

    ОтветитьУдалить
    Ответы
    1. ==А если циннамон уже стоит? Система -минт 18== Система -минт 18 можно обновить самостоятельно до 18.1 по этой инструкции:
      http://compizomania.blogspot.com/2016/11/linux-mint-18-sarah-linux-mint-181.html

      Удалить
  2. Владимир, вижу у вас и Plasma есть в окружении. Напишите, пожалуйста, как установить, а то у меня при попытке поставить в Ubuntu 16.04 была ошибка с несовместимостью google чего-то там с какой то библиотекой кед. (

    ОтветитьУдалить
    Ответы
    1. Пожалуйста:
      sudo add-apt-repository ppa:kubuntu-ppa/backports
      sudo apt-get update
      sudo apt-get install kubuntu-desktop

      Удалить
  3. Если основной установлена Linux Mint 18.0 то корица с ней не подружится при паралельной установке?

    ОтветитьУдалить
  4. А Linux Mint 18.0 у вас с каким окружением стоит?

    ОтветитьУдалить
  5. Спасибо, Владимир. Я тоже пытался так установить, но у меня:"...При обработке следующих пакетов произошли ошибки:
    /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb
    /var/cache/apt/archives/kaccounts-providers_4%3a15.12.3-0ubuntu1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)..." и дальше никак((( Synaptic выдал:"E: /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb: попытка перезаписать «/usr/share/accounts/services/google-im.service», который уже имеется в пакете account-plugin-google 0.12+16.04.20160126-0ubuntu1" Не знаю, как это победить...)

    ОтветитьУдалить
    Ответы
    1. Попробуйте эту команду: sudo apt install -f

      Удалить
    2. Пробовал... Выдало:"...Распаковывается kde-config-telepathy-accounts (4:15.12.3-0ubuntu1) …
      dpkg: ошибка при обработке архива /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb (--unpack):
      попытка перезаписать «/usr/share/accounts/services/google-im.service», который уже имеется в пакете account-plugin-google 0.12+16.04.20160126-0ubuntu1
      Обрабатываются триггеры для libc-bin (2.23-0ubuntu4) …
      При обработке следующих пакетов произошли ошибки:
      /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)..."
      Видимо придётся снести КДЕ, а жаль... Очень хотелось пощупать кеды.

      Удалить
  6. а на Linux Mint 17.3 то-то пробовал обновлять синамон?
    я, когда вышел версии 3.0, смог обновить, а вот с 3.0 до 3.2 - не выходит,
    пишет E: Не удалось найти пакет cinnamon-core.
    репозиторий добавил, т.е. выполнил команды выше. Как поступают в таких ситуациях?)

    ОтветитьУдалить
    Ответы
    1. ==пишет E: Не удалось найти пакет cinnamon-core.
      репозиторий добавил, т.е. выполнил команды выше. Как поступают в таких ситуациях?)==
      Попробуйте переустановить пакет cinnamon-core:
      sudo apt install --reinstall cinnamon-core
      И обновить систему:
      sudo apt update
      sudo apt upgrade

      Удалить