11 января 2016

Релиз ядра Linux 4.4 LTS

Предупреждение. Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости.  Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему.  Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

Ядро Linux Kernel 4.4 LTS (Long-Term Support) является ядром с длительным сроком поддержки, до февраля 2018 года и будет ядром по умолчанию в Ubuntu 16.04 LTS.
Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.
Установить ядро версии 4.4 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 15.10/15.04/14.04/12.04
Linux Mint 17.3/17.2/17.1/17/13
elementary OS 0.2/0.3
Deepin 15

Установка ядра Linux Kernel 4.4

Напоминание пользователям компьютеров с видеокартами Nvidia/AMD. Перед установкой ядра, желательно переключиться на свободный драйвер.

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера:

Для 32-bit (одной командой):

cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-generic_4.4.0-040400.201601101930_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-generic_4.4.0-040400.201601101930_i386.deb; sudo dpkg -i *.deb

Для 64-bit (одной командой):
 
cd /tmp; wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb; sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
.
Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой в терминале:

uname -r

Linux Mint 17.3


Deepin 15


Примечание 2
. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

Если вы решили удалить ядро 4.4, выполните эту команду:

sudo apt-get purge linux-image-4.4-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

48 комментариев :

  1. вроде встало без проблем.. посмотрим, спасибо =)

    ОтветитьУдалить
    Ответы
    1. К сожалению пришлось откатиться, не уходит в сон.

      3.19.0-42-generic работает на ура =)

      Удалить
    2. Этот комментарий был удален автором.

      Удалить
  2. Что-то эти ядра посыпались... Прям, одно за другим! :))

    ОтветитьУдалить
    Ответы
    1. Вообще-то компиляторщики ядер не всегда поспевают за изготовителями оборудования. Так что...

      Удалить
    2. 4.4 два месяца разрабатывали.Вполне нормально.

      Удалить
  3. После установки ядра не устанавливаются драйвера nvidia, вот что пишет
    ERROR (dkms apport): kernel package linux-headers-4.4.0-040400-generic is not supported
    Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
    Не знает ли кто что можно сделать?

    ОтветитьУдалить
    Ответы
    1. Одно из двух решений.
      1. Откатится на ядро системы по умолчанию и установить проприетарный драйвер.
      2. Оставаться на ядре 4.4 и свободном драйвере NOUVEAU.
      "устанавливайте новое ядро на свой страх и риск"

      Удалить
    2. Как восстановиться я знал, думал что-нибуть можно сделать с ядром или драйверами что бы заставить их работать.

      Удалить
    3. У меня была похожая проблема с DKMS модулями VirtualBox, помог совет отсюда http://askubuntu.com/questions/719775/latest-stable-kernel-4-4-virtualbox-5-kernel-modules-failed
      Кратко нужно установить g++ и gcc 5 версии, и сделать, чтобы они использовались по умолчанию

      sudo add-apt-repository ppa:ubuntu-toolchain-r/test
      sudo apt-get update
      sudo apt-get install gcc-5 g++-5

      Потом для каждой версии из
      ls -lh /usr/bin/gcc*
      добавить альтернативу
      sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.8 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.8
      sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.9 40 --slave /usr/bin/g++ g++ /usr/bin/g++-4.9
      sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-5 20 --slave /usr/bin/g++ g++ /usr/bin/g++-5

      и в конце выбрать 5 версию
      sudo update-alternatives --config gcc

      Потом попробуйте запустить установку драйвера

      Удалить
  4. Поставила это ядро, начались зависания.
    Решилось так: apt-get install intel-microcode

    ОтветитьУдалить
  5. Последние драйвера от интел постановляться?

    ОтветитьУдалить
  6. Нашлось 200 с мелочью мегабайт при удалении и Compiz рухнул..Ничто не вечно под луной..)))

    ОтветитьУдалить
  7. Написано ведь красными буквами.. Кстати, как это делается..??

    ОтветитьУдалить
  8. Решил обновить ядро на Xubuntu 14.04.03 LTS x64. Успешно обновилось, за исключением пары проблем. Не смог установить драйвер для wifi-донгла mt7601, т.к. при компилляции он "лезет" в ядро. В этом 4.4 выдало сообщение о защите (что более порадовало). И возникли проблемы с загрузкой модуля ядра VirtualBox 5. Переустановка и переконфиг не помогли. С оф.ядром системы 3.19 все работало. Надеюсь будущие обновления исправят эти моменты.

    ОтветитьУдалить
  9. У меня все стало работать стабильнее и плавнее. Даже непривычно как-то до этого стояло 3.3.1, это был тихий ужас, тормозило постоянно. Ноутбук слабый и только Линукс смог его оживить, еще бы исправили проблему батареи и всё вообще шикарно стало.

    ОтветитьУдалить
  10. Огорчает одно, драва на Intel убогие до безобразия. Поддержка OpenGL 3.0 только и все. И до сих пор не сдвинулись с места. Кароче печальная компания, вроде бы и крутая а дрова дрянь.

    ОтветитьУдалить
    Ответы
    1. Просто под Linux писать их не хотят... Мало кто им пользуется. :)

      Удалить
    2. Всё Интел под Линукс пишет. Мало кто ждет от встроенных видюх чуда и все сидят на нвидии и амд.

      Удалить
    3. Ну, сейчас встроенные видюхи - ого-го... У меня, например Intel Pentium G3220 с встроенным видеоядром. На Windows спокойно в Metro играл в разрешении 1366x768 Видюхи - это для геймеров. А простому человеку она на фиг не нужна.

      Удалить
    4. Под виндой у них дрова поддерживают OpenGL 4.5 а вот под линуксом 3.0, так что они где то делают а где то лажают по страшному и годами не могут исправить ничего.

      Удалить
    5. А что Вы, Сергей Серегин, здесь тогда вопросы по Linux задаёте? Или потерялись в пространвстве?

      Удалить
    6. ==Под виндой у них дрова поддерживают OpenGL 4.5 а вот под линуксом 3.0==
      Нужно учесть, что ЛЮБЫЕ ОТКРЫТЫЕ драйвера (не только intel) не могут поддерживать версию OpenGL новее, чем поддерживает Mesa, а в Mesa поддержка Opengl 4.1 только-только проклюнулась, месяца 3 назад. Драйвера с поддержкой нововведений пока не готовы "для продакшена", надо полагать.

      Удалить
  11. 4.4 + NVidia 358 (Optimus), Intel дрова последние с репозитория Все стабильно
    Nv361 не стают

    ОтветитьУдалить
  12. По большому счету зачем линуксу нвидиа и радеон, для танцев только, интеловских вполне хватает для нормальной работы системы, если только под вайном гонять игры.

    ОтветитьУдалить
    Ответы
    1. А зачем гонять под вайном если есть нативные игры? И к вашему сведению, я уже писал но и вам напишу, интеловые дрова отстой полный, они до сих пор только поддерживают OpenGL 3.0 а на дворе уже 4.5 которые у nVidia и AMD давно уже есть. Интел даже 3.3 не может сделать. Я из за этого свой проект на ноуте где только интеловая графика запустить не могу. Это вообще портит все. Попробуйте написал проект строк в 30к и потмо когда окажется что графика говно вам придется все переписывать, вот тогда и поймете зачем лунуксу другие дрова.

      Удалить
    2. Под Wine игры - это, по-моему, моветон. ))

      Удалить
  13. Поставил ядро. Все работает вроде. В спящий, ждущий, перезагрузку уходит без проблем. Ви фи работает.
    Нубук: Lenovo G50-30 (pentium N3540), видео Intel, Mint 17.3 64-bit

    ОтветитьУдалить
  14. в прошлом году рискнул поставил 4.3.... пару дней вроде работало потом начались проблемы. благо перед такими экспериментами привычка делать резервную копию системного раздела. вернул всё в зад ;-) и сидю на 3.19.0-32. всё нормально работает. ноут acer aspire 4820tg (i3 330m, 8 gb ram, intel ssd 60 gb под систему и hitachi 320 gb для home, ati 5470 (драйвер свободный).

    ОтветитьУдалить
    Ответы
    1. == вернул всё в зад== Это куда...?

      Удалить
    2. Вот и я всегда считал, что говорить "вернуть в зад" - неправильно. Надо говорить "вернуть в обратный зад", так гораздо грамотнее, очевидно же :)

      Удалить
    3. Обратный зад-это тот же самый зад, но уже спереди?

      Удалить
    4. Главное, чтоб не наизнанку, я думаю :)

      Удалить
  15. Asus S500CA / Ubuntu 15.10
    Полет нормальный, увеличилось скорость открытия окон и скрол стал помягче
    Все устраивает

    ОтветитьУдалить
  16. Asus K52Dr/Ubuntu 14.04
    Все работает но при перезагрузке не выключается.

    ОтветитьУдалить
  17. поставил...
    перестал работать f.lux
    при загрузке выдаёт ещё пять ошибок
    не стал разбираться снёс. f.lux жалко.

    ОтветитьУдалить
  18. z@z-K53BR:~$ uname -r
    4.4.0-1-generic
    z@z-K53BR:~$

    сегодня обновилось в 16.04

    ОтветитьУдалить
  19. После установки ядра, перестали запускаться виртуальные машины на VirtualBox.
    Вылетает такая ошибка:

    Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

    '/sbin/rcvboxdrv setup'

    as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

    where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

    Ввожу в терминале sudo '/sbin/rcvboxdrv setup' но это не помогает.

    Откатываться на старое ядро или можно как то исправить эту проблему?

    ОтветитьУдалить
    Ответы
    1. ==you should install the DKMS package first==
      Сначала нужно установить DKMS. DKMS необходим, чтобы драйверы virtualbox могли пересобраться под нестандартное ядро. Попробуйте
      sudo apt-get install dkms virtualbox-dkms
      sudo /sbin/rcvboxdrv setup
      и перезагрузитесь.

      Удалить
    2. Странно, но после первой команды удалился virtualbox версии 5 и установился версии 4, а при вводе второй команды терминал мне выдал вот это sudo: /etc/init.d/vboxdrv: command not found

      Удалить
  20. сделать бы как нибудь в хубунту что бы система сама автоматом предлагала устанавливать такого типа ядра по мере их выхода что бы каждый раз не выполнять команды.
    и что то давно не видно Ираклия со своим дежурным постом что всё ок и со своей навязчиво-бредовой идеей о полной самостоятельности убунту от линукс ))))

    ОтветитьУдалить
  21. У меня Linux mint 17.3
    Обновил ядро до 4.4
    И после этого linux Отказался Видеть видеодрайвер nvidia

    Остался на свободном драйвере x

    А с Новым ядром Linux Просто летает!
    Даже скорость загрузки стала быстрее!
    Спасибо За Статью!

    ОтветитьУдалить