15 ноября 2015

Установить VirtualBox 5.0.10 в Ubuntu 15.10/15.04/14.04 и производные

VirtualBox является многофункциональным инструментом для создания изолированных виртуальных машин, предлагает высокую производительность, а также является единственным профессиональным решением, которое находится в свободном доступе с открытым исходным кодом на условиях GNU General Public License (GPL) v.2.
VirtualBox активно развивается с частыми обновлениями и имеет постоянно растущий список функций, поддерживаемых гостевых операционных систем и платформ, с которыми он работает. VirtualBox является результатом коллективной работы при поддержке выделенных компаний: каждому предлагается внести свой вклад, в то время как Oracle обеспечивает соответствие продукта профессиональным критериям качества.

Компания Oracle выпустила корректирующий релиз системы виртуализации VirtualBox 5.0.10, в котором отмечено 26 исправлений, направленных на увеличение стабильности и устранение регрессивных изменений.


Среди наиболее заметных исправлений:

    Дополнения для X11 частично адаптированы под новый ABI X.Org Server 1.18 (не решены проблемы с 3D);
    Улучшена поддержка некоторых моделей процессоров Intel Atom
    Решены проблемы с созданием скриншотов из GUI;
    Устранены проблемы с отображением окон с 3D-контентом при переходе в полноэкранный режим на системах с X11;
    Исправлены недоработки в синхронизации окна менеджера VM и воспроизведении звука после приостановки работы виртуальной машины;
    Обеспечен корректный сброс звуковых потоков AC97 для решением проблемы с отключением звука;
    В гостевых системах с Linux налажена работа звукового кодека AD1980 через устройства HDA;
    Внесены исправления в реализацию USB-контроллера xHCI, улучшено определение устройств USB;
    Улучшен проброс web-камер;
    Исправлены ошибки, приводившие к крахам на системах с ядром Linux младше 3.3.

Установка  VirtualBox 5.0.10 в Ubuntu 15.10 и производные

Откройте терминал, скопируйте и выполните следующие команды:

sudo sh -c 'echo "deb http://download.virtualbox.org/virtualbox/debian wily contrib" >> /etc/apt/sources.list.d/virtualbox.list'
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-5.0


Установка  VirtualBox 5.0.10 в Ubuntu 15.04 и производные

Выполните в терминале следующие команды:

sudo sh -c 'echo "deb http://download.virtualbox.org/virtualbox/debian vivid contrib" >> /etc/apt/sources.list.d/virtualbox.list'
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-5.0


Установка  VirtualBox 5.0.10 в Ubuntu 14.04/12.04 и производные

sudo sh -c 'echo "deb http://download.virtualbox.org/virtualbox/debian precise contrib" >> /etc/apt/sources.list.d/virtualbox.list'
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-5.0


После установки вы найдёте  VirtualBox в программах Администрирование или поиском в меню:


VirtualBox 5.0.10 во время установки ОС Linux Mint 17.2 XFCE  в Ubuntu 15.10:


VirtualBox 5.0.10 в работе с установленной системой Linux Mint 17.2 XFCE  в Ubuntu 15.10:


Домашняя страница  VirtualBox

Удачи.

16 комментариев :

  1. А можно таким образом винду поставить на убунту 14.04? А то я уже заколебался переключаться с системы на систему, только ради того чтобы поработать в фотошопе (работа с ним связана, гимп не подходит, клиенты с ним не работают, вот и парюсь)...

    ОтветитьУдалить
    Ответы
    1. Можно конечно. Здесь подробно: http://compizomania.blogspot.com/2013/07/windows-81-blue-preview-virtualbox.html

      Удалить
    2. Данная тема посвящена тем пользователям которые хотят запустить фотожоп под вайном но у них это не получается!Я устанавливал CS5/ И так поехали:

      Для запуска обязательно нужны, вайн не ниже 1.2 и библиотеки gdiplus.dll и atmlib.dll (качаем Здесь ) некоторые расширения, устанавливаемые через Winetricks.
      Открываем терминал и даем команду wget http://www.kegel.com/wine/winetricks после скачки и установки. Alt+F2 там пишем winetricks и *запустить* в открывшемся окне выбираем *Select the Default wineprefix* и *ок* в открывшемся окне выбираем *Install a Windows Dll or component* и ок. В открывшемся окне выбираем следующие компоненты, msxml6, gecko, vcrun2005, vcrun2005sp1, vcrun2008, gdiplus, ie6, msxml3. и ок. После установки компонентов закидываем gdiplus.dll и atmlib.dll (ссылка вверху) в ~/.wine/drive_c/windows/system32 опять открываем терминал и даем команду (для убунты)sudo apt-get install ttf-mscorefonts-installer потом опять Alt+F2 там winecfg вкладка *библиотеки* компоненты gdiplus.dll и atmlib.dll должны быть *Сторонняя, потом встроенная* потом вкладка *приложения* в версии windows нужно выбрать windows xp! Ну и наконец-то устанавливаем cs5!

      Удалить
  2. На ядре 4.2 почему то не хочет работать. Что только не перепробовал, весь инет уже излазил. Приходится перезагружать комп и заходить под старым ядром. Но это конечно очень напряжно

    ОтветитьУдалить
    Ответы
    1. Попробуйте команду для отладки: sudo /usr/lib/virtualbox/vboxdrv.sh setup У меня на ядре 4.3 заработал.

      Удалить
    2. Не не работает, выдает ошибку:
      Trying to register the VirtualBox kernel modules using DKMSError! Bad return status for module build on kernel: 4.2.5-040205-generic (x86_64)
      Consult /var/lib/dkms/vboxhost/5.0.2/build/make.log for more information.
      ...failed!
      (Failed, trying without DKMS)
      Recompiling VirtualBox kernel modules ...failed!
      (Look at /var/log/vbox-install.log to find out what went wrong)

      Удалить
    3. Блин! Яж написал что ядро 4.3 Обнови ядро

      Удалить
    4. А у меня не пошло ядро 4.3, пришлось откатываться до 4.2

      Удалить
  3. был бы доступ к ресурсам видео, хотя бы %50 - цены не было бы совсем, я бы тогда точно виду снес.

    ОтветитьУдалить
  4. не выходит(

    Пакеты, имеющие неудовлетворённые зависимости:
    virtualbox-5.0 : Зависит: libdevmapper1.02.1 (>= 2:1.02.99) но 2:1.02.77-6ubuntu2 будет установлен
    Зависит: libstdc++6 (>= 5.2) но 4.8.4-2ubuntu1~14.04 будет установлен
    Зависит: libvpx2 (>= 1.4.0) но он не может быть установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    подскажите что сделать можно? при инсталяции с пакета с сайта тоже выдает ошибку libdevmapper1.02.1 (>= 2:1.02.99)

    ОтветитьУдалить
  5. ребят, уже и ОС переустановил, то же самое( помогите плиз..

    ОтветитьУдалить
    Ответы
    1. У меня тоже самое - Пакеты, имеющие неудовлетворённые зависимости:.... ОС LINUX MINT 17.3

      Удалить
  6. По моему на сайте VB всё достаточно подробно расписано. У меня обновляется на автомате. Единственное неудобство это когда обновляется ядро приходится делать reinstall.

    ОтветитьУдалить