05 августа 2015

Как перейти на LibreOffice 5.0 в Ubuntu и производные

Некоммерческий фонд The Document Foundation несколько часов назад объявил о выпуске LibreOffice 5.0 и обновил свой репозиторий для Ubuntu 15.10/15.04/14.04/12.04, и производных.
LibreOffice 5.0 выходит с внушительны количеством новых возможностей для Calc, Новые значки, значительные улучшения в меню и боковой панели. Кроме того, стиль управления в настоящее время интуитивно  более  понятен благодаря визуализации стилей прямо в интерфейсе. Подробнее можно посмотреть в "Примечания к выпуску LibreOffice 5.0" на русском и др. языках.


Для обновления LibreOffice, установленного в вашем дистрибутиве до LibreOffice версии 5.0 необходимо подключить его собственный репозиторий и сделать обновление системы.

Откройте терминал, скопируйте и выполните следующую команду:

sudo add-apt-repository ppa:libreoffice/ppa

Затем откройте Менеджер обновлений, где среди прочих обновлений вы найдёте обновление LibreOffice до версии 5.0:


Либо выполните следующие команды в терминале:

sudo apt-get update; sudo apt-get dist-upgrade

Источник: https://launchpad.net/~libreoffice/+archive/ubuntu/ppa

Удачи.

65 комментариев :

  1. Здравствуй Владимир в минте 17.2 не получается обновить

    ОтветитьУдалить
    Ответы
    1. Хм. Странно. Действительно. Тогда попробуйте так:

      LibreOffice для 32 bit

      cd /tmp; wget http://download.documentfoundation.org/libreoffice/stable/5.0.0/deb/x86/LibreOffice_5.0.0_Linux_x86_deb.tar.gz

      tar -xzvf LibreOffice_5.0.0_Linux_x86_deb.tar.gz

      cd LibreOffice_5.0.0.5_Linux_x86_deb/DEBS

      sudo dpkg -i *.deb


      LibreOffice зля 64 bit

      cd /tmp; wget http://download.documentfoundation.org/libreoffice/stable/5.0.0/deb/x86_64/LibreOffice_5.0.0_Linux_x86-64_deb.tar.gz

      tar -xzvf LibreOffice_5.0.0_Linux_x86-64_deb.tar.gz

      cd LibreOffice_5.0.0.5_Linux_x86-64_deb/DEBS

      sudo dpkg -i *.deb

      Удалить
    2. Такое бывает в Минт, там какая-то более хитрая система приоритета репозиториев. Попробуйте обновиться через Synaptic, предварительно выставив в нем Настройки - Параметры - Вкладка "Дистрибутив" - Предпочитать новейшую версию. Может помочь.

      Удалить
    3. ==Попробуйте обновиться через Synaptic== Нет, Максим, не получается и через Synaptic. Только тарболом. (

      Удалить
    4. ==Нет, Максим, не получается и через Synaptic. Только тарболом. ( ==
      Жаль. Минт, похоже, очень трепетно относится к обновлению поставляемых по умолчанию программ :). Это поведение можно поменять, поковырявшись в конфигах, но сейчас не помню, как именно, давненько не сталкивался.

      Удалить
    5. P.S. Надо гуглить по поводу Pin-Priority in linux mint

      Удалить
    6. копаемся в этой теме - http://www.mintlinux.ru/forum/thread9478.html
      ...и находим ответ)).

      Удалить
    7. Если кратко, то надо провернуть такой финт ушами (цитата из http://www.mintlinux.ru/forum/thread9478.html):

      Открываем /etc/apt/preferences.d/official-extra-repositories.pref
      и "до кучи" дописываем туда:
      Package: *
      Pin: origin ppa.launchpad.net
      Pin-Priority: 700

      Вуаля! Офис обновился!

      Удалить
    8. Ага или без правки конфига через синаптик как здесь -http://www.mintlinux.ru/forum/thread9478-2.html
      первое сообщение, под номером #16, там и картинки есть.

      Удалить
    9. ula dutr большое спамибо, обновился нормально!

      Удалить
    10. Минт Корица 17.2 Обновился через репозиторий без проблем. Видимо не сам Минт виноват, а что то в настройках

      Удалить
    11. sudo apt-get update && sudo apt-get dist-upgrade
      Попробуй так. У меня тоже Минт.

      Удалить
    12. Русификация Libreoffice.

      Для 32-бит:

      cd /tmp; wget http://download.documentfoundation.org/libreoffice/stable/5.0.0/deb/x86/LibreOffice_5.0.0_Linux_x86_deb_langpack_ru.tar.gz
      tar -xzvf LibreOffice_5.0.0_Linux_x86_deb_langpack_ru.tar.gz
      cd LibreOffice_5.0.0.5_Linux_x86_deb_langpack_ru/DEBS
      sudo dpkg -i *.deb

      Для 64-ьит

      cd /tmp; wget http://download.documentfoundation.org/libreoffice/stable/5.0.0/deb/x86_64/LibreOffice_5.0.0_Linux_x86-64_deb_langpack_ru.tar.gz
      tar -xzvf LibreOffice_5.0.0_Linux_x86_64_deb_langpack_ru.tar.gz
      cd LibreOffice_5.0.0.5_Linux_x86-64_deb_langpack_ru/DEBS
      sudo dpkg -i *.deb

      Удалить
    13. Не хочет русифицировать для 64-бит. На второй команде выдает ошибку:

      tar -xzvf LibreOffice_5.0.0_Linux_x86_64_deb_langpack_ru.tar.gz
      tar (child): LibreOffice_5.0.0_Linux_x86_64_deb_langpack_ru.tar.gz: Функция open завершилась с ошибкой: Нет такого файла или каталога
      tar (child): Error is not recoverable: exiting now
      tar: Child returned status 2
      tar: Error is not recoverable: exiting now

      Удалить
    14. Попрлбуйте русифицировать командой: sudo apt-get install libreoffice-l10n-ru

      Удалить
    15. aleksas31, все должно работать. Если есть проблемы с командной строкой, скачайте русификатор
      http://download.documentfoundation.org/libreoffice/stable/5.0.0/deb/x86_64/LibreOffice_5.0.0_Linux_x86-64_deb_langpack_ru.tar.gz
      распакуйте любым менеджером архивов и установите deb-файл c помощью gdebi.

      Удалить
    16. Владимир сработал Ваш совет! Максим и тебе (мы знакомы) спасибо! :)

      Удалить
  2. Ответы
    1. Выше в комментариях инструкция для Минт: http://compizomania.blogspot.com/2015/08/libreoffice-50-ubuntu.html?showComment=1438800845073#c307876100103328113

      Удалить
  3. Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.HrpcfteHuE --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 1378B444
    gpg: запрашиваю ключ 1378B444 с hkp сервера keyserver.ubuntu.com
    gpg: ключ 1378B444: "Launchpad PPA for LibreOffice Packaging" не изменен
    gpg: Всего обработано: 1
    gpg: неизмененных: 1

    ОтветитьУдалить
  4. У меня установлен linux mint 17.2 mate 32х разрядная, не получилось обновить.

    ОтветитьУдалить
  5. Владимир, а как сделать, что бы менеджер обновлений сообщал об доступности обновлений, как на Минте?

    ОтветитьУдалить
    Ответы
    1. ==ак сделать, что бы менеджер обновлений сообщал об доступности обновлений, как на Минте?== Имеется ввиду в Ubuntu? Так в Ubuntu на панели Unity появляется подсвеченный значок Менеджера обновлений, который и сообщает о новых обновлениях.

      Удалить
  6. Обновился. Давно хотел спросить как в таблицах настроить копи-паст правой кнопкой мыши, что то никак не получается. Приходится пользоваться ctrl+c и ctrl+v.

    ОтветитьУдалить
    Ответы
    1. Используйте среднюю кнопку мыши - колёсико для копипаста. Выделить текст для копирования, а затем в нужном месте нажать наколёсико мыши для вставки, без использования контекстного меню, как это делается с применением правойкнопки мыши. Подробней здесь: " Копирование и вставка с помощью мыши в Linux" http://compizomania.blogspot.com/2013/05/linux.html

      Удалить
    2. Спасибо. Оказывается все очень просто.

      Удалить
  7. Привет Владимир, вопрос у меня такой, можно ли подключить, или установить центр приложений Убунту в Минте? Я имею в виду как отдельное приложение, ну как Гугле Плей.

    ОтветитьУдалить
    Ответы
    1. ==можно ли подключить, или установить центр приложений Убунту в Минте?== Так он установлен по умолчанию. Просто называется по-другому - Менеджер программ.

      Удалить
    2. Но он в Минте какой то обрезанный, да бог с ним. Вот я хотел еще спросить, Владимир Убунту уже считается как отдельная ОС, со своей экосистемой? Я имею в виду, что бы ее не называть Линукс, а ОС Убунту.

      Удалить
    3. Называйте как хотите. А что касается официального названия, как вопрос не ко мне, а к Canonical или персонально к космонавту Марку Шаттлворту. :)

      Удалить
  8. Мое почтение! Удалось тарболом обновиться в Минт Синамон 17.2 и русифицировать. Но как не странно версия 4.4.3.2 осталась вместе с обновленной версией?! Обе версии работают нормально . Прошу уточнить правильную команду в терминале для удаления версии 4.4.3.2
    Скрин наличия обоих версий: http://hostingkartinok.com/show-image.php?id=7d471ec056e66b11a2a73c46ea7df89b

    ОтветитьУдалить
    Ответы
    1. Для удаления предыдущей версии выполните команду:

      sudo apt remove libreoffice 4.4

      Удалить
  9. Исправьте пожалуйста опечатку в первой строке новости в слове "нескольо"...

    Спасибо

    ОтветитьУдалить
  10. Xubuntu 14.04, обновился нормально.

    ОтветитьУдалить
  11. Владимир, подскажи, пожалуйста, как установить сразу пятый офис? а то на elementary OS Freya офиса из коробки нет.

    ОтветитьУдалить
  12. Тут установка пятого офиса: http://compizomania.blogspot.com/2015/08/libreoffice-50-ubuntu.html?showComment=1438800845073#c307876100103328113

    А тут его русификация: http://compizomania.blogspot.com/2015/08/libreoffice-50-ubuntu.html?showComment=1438802226648#c3503018888038361970

    ОтветитьУдалить
  13. прочитал интересную статейку обновления libreoffiice в linuxmint по ней все получилось обновился до версии 5.0.0.5 но некоторые функции работают некорректно перешел на kubuntu обновил все отлично работает кому нужно для linuxmint пожалуйста:
    открываем файл official-extra-repositories.pref расположенный
    /etc/apt/preferences.d/ дописываем строки

    Package: *
    Pin: origin ppa.launchpad.net
    Pin-Priority: 700

    и обновляемся

    add-apt-repository ppa:libreoffice/ppa
    apt-get update
    apt-get upgrade

    ОтветитьУдалить
    Ответы
    1. ==прочитал интересную статейку обновления libreoffiice в linuxmint==
      А если бы Вы сначала внимательно прочитали комментарии выше, то статейка не понадобилась бы :)

      Удалить
  14. Владимр у вас ошибка
    tar -xzvf LibreOffice_5.0.0_Linux_x86_64_deb_langpack_ru.tar.gz
    cd LibreOffice_5.0.0.5_Linux_x86_64_deb_langpack_ru/DEBS
    sudo dpkg -i *.deb

    не правильно надо так
    tar -xzvf LibreOffice_5.0.0_Linux_x86-64_deb_langpack_ru.tar.gz
    cd LibreOffice_5.0.0.5_Linux_x86-64_deb_langpack_ru/DEBS
    sudo dpkg -i *.deb

    ОтветитьУдалить
  15. У меня Ubuntu-Mate.5-я либра установилась,но осталась и 4.4.3.2 Как ее снести что бы пятерку не задело?

    ОтветитьУдалить
    Ответы
    1. Для удаления предыдущей версии выполните команду:

      sudo apt remove libreoffice 4.4

      Удалить
  16. Пятёрка сырая ппц... Кнопка "Специальные символы" в таблицах сразу приводит к краху программы.
    Поторопился, блин, установить.

    ОтветитьУдалить
    Ответы
    1. Интересно! У меня на работе на 2х компах установлен офис 5й (Ubuntu 14.04, полностью обновлённые) и дома 15.04.
      На всех компах нажатие кнопки спец символы в документе приводит к краху проги. Пришлось везде откатывать офис, т.к. документы очень важные - заявки.
      Могу прислать сам документ, попоробуете у себя. Мне уже действительно интересно!

      Удалить
    2. Выложите документ куда нибудь в облако (Mega, Dropbox, YandexDisk etc) и киньте ссылочку в коммент. Мне тоже интересно, ибо, по правде говоря, мой скриншот сделан в Archlinux. Надо будет перезагрузиться в Убунту и поковыряться там. Пока, исключительно в порядке предположения, предлагаю проверить в Synaptic, все ли "нестрогие зависимости" libreoffic'а установлены (в меню по ПКМ на пакете, пункт "рекомендуемые пакеты" или как-то так).

      Удалить
    3. Пишу из Ubuntu Mate, обновлена до 14.04-3, офис 5.0.0.5 - глюк пока не воспроизводится, все работает нормально: http://i.imgur.com/v3Hg6iE.png
      Советую запустить libreoffice --calc в терминале, и посмотреть его ругань на момент падения.

      Удалить
    4. Gluk41, документ скачал, удаляйте коммент. Будем посмотреть.

      Удалить
    5. При открытом документе у меня со спецсимволами тоже все хорошо. Будем считать, что Вам не повезло. Надеюсь, хотя бы в следующих выпусках глюк проявляться не будет.

      Удалить
  17. Народ! Подскажите, плиз - где в Либре в таблицах кнопку найти - обрамление ячейки (нужны тупо внешние границы, остальное - без надобности)? Чтобы можно было на панельку вынести и горячие клавиши задать! В старом микрооффисе ещё в 5 версии можно было один раз мышкой кликнуть - и выделение обрамлялось как выбрано, а вот в Либре - что-то как-то туго с этим, только меню выбора линий появляется. Мож кто ткнёт носом?

    ОтветитьУдалить
    Ответы
    1. https://help.libreoffice.org/Calc/User_Defined_Borders_in_Cells/ru
      Не оно? Горячая клавиша Ctrl+1, вкладка Обрамление.
      Насчет добавить кнопку - затрудняюсь сказать, хотя панели инструментов редактируются в широких пределах, можно и поискать нужную команду.

      Удалить
    2. Не, не то. Вылезает только меню по выбору обрамления, отдельной кнопки нет. В Экселе это называется "Границы" - выбирается тип обрамления и он автоматом выносится на кнопку. Достаточно один раз мышью кликнуть, чтобы выделенный диапазон "обрамился". В либре такого нет, к сожалению.
      http://i.imgur.com/TpH60Tj.png

      Удалить
    3. Да, отдельной кнопки с запоминанием последних параметров обрамления на панели нет. Это не очень удобно, но не смертельно.

      Удалить
    4. Это совсем неудобно, но не смертельно, да.

      Удалить
  18. после выполнение команды: sudo apt-get update; sudo apt-get dist-upgrade
    brasero пропало почему то.

    ОтветитьУдалить
  19. в манжаро идёш в менеждер пакетов и ищеш фреш пакет оффиса и качаеш 5 оффис

    ОтветитьУдалить
  20. Никак не хочет настраиваться на русский язык.
    Как сделать дефолтный русский?

    ОтветитьУдалить