14 июля 2015

В Firefox и Chrome заблокированы все версии Flash

В Adobe Flash нашли очередную критическую уязвимость, использование которой может привести к падению браузера, либо к получению контроля над компьютером под управлением Windows, Mac OS X или Linux.

Поскольку патч пока не готов, в Firefox заблокировали как последнюю, так и все предыдущие версии Flash, чтобы обезопасить пользователя. С такими темпами в ближайшем будущем будет легче просто отказаться от Flash, однако пока в Firefox он блокируется не окончательно, и все Flash элементы можно активировать на странице простым кликом. Как только Adobe выпустит обновление, Mozilla уберет блокировку плагина.



На аналогичный шаг пошли и в Google, также заблокировав Flash в браузере по той же самой причине. Плагин тоже блокируется по умолчанию, но его можно использовать каждый раз подтверждая запуск на странице. Несмотря на наличие кнопки Update plugin, Flash обновить пока невозможно, и вместо этого пользователя перенаправляют на страницу поддержки.

Как алтернативу для просмотра видео программ на компьютере я использую, например, браузер Pale Moon, где Flash работает исправно:


P.S. Будем надеяться, что Flash в Firefox и Chrome скоро исправят.

46 комментариев :

  1. Если кому будет от этого легче, то пострадали не только пользователи СПО но и форточники тоже...

    ОтветитьУдалить
    Ответы
    1. не только форточники, это касается всех кто использует афп вне зависимости от ос.

      Удалить
  2. На Linux пока не заблокирован 18.0.0.194

    ОтветитьУдалить
    Ответы
    1. Adobe Flash Player 11.2 будет последней версией, поддерживающей Linux в качестве платформы. Adobe будет продолжать обеспечивать ретроподдержку безопасности Flash Player 11.2 для Linux.

      18.0.0.194 Это уже не офф

      Удалить
  3. Зашел на сайт через Хром, вроде Флеш работает.

    ОтветитьУдалить
    Ответы
    1. потому что это дело профиксили, еще дня два назад.

      Удалить
    2. [im]http://storage4.static.itmages.com/i/15/0715/h_1436932621_6117578_1d807fbc78.png[/im]

      Удалить
  4. Вообще Adobe Flash Player всегда являлся большой дыркой.

    ОтветитьУдалить
    Ответы
    1. а кто то разве утверждает об обратном и кто то разве здесь сидящие не в курсе об этом??? )))

      Удалить
  5. Года 2 уже отказываются,блокируют,заменяют,а воз и ныне там.Такое впечатление,что на самом деле "дырки"кому-то нужны.

    ОтветитьУдалить
    Ответы
    1. в дырку можно подсматривать и подслушивать.

      Удалить
    2. Не секрет что они нужны Hacking Team, наверняка они и заказывают у adobe "мультиплатформенные" дыры.

      Удалить
  6. А как на счет HTML 5, это разве не альтернатива Флеш плееру?

    ОтветитьУдалить
    Ответы
    1. На Youtube - да. Но не ютюбом единым... Вот когда все видеохостинги и прочие сайты массово откажутся от флеша, тогда можно будет о чем-то таком говорить. Пока этого не происходит, хотя подвижки есть.

      Удалить
    2. Никаких подвижек не заметил, по моим наблюдениям HTML 5 нигде кроме Youtube не работает))))

      Удалить
  7. Mozilla Thunderbird Гугл тоже заблокировал.

    ОтветитьУдалить
  8. Ответы
    1. ==как прикрутили?==

      sudo add-apt-repository ppa:nilarimogard/webupd8
      sudo apt-get update
      sudo apt-get install freshplayerplugin

      https://github.com/i-rinat/freshplayerplugin

      Удалить
    2. Установил, sudo add-apt-repository ppa:nilarimogard/webupd8
      sudo apt-get update
      sudo apt-get install freshplayerplugin
      но не совсем отлично почему то. Например на сайте
      http://www.piranya.com/ в роликах, где есть плейлисты (Задорнов к примеру) они не отображаются. Так же нет значков регулировки громкости, пауза, "на весь экран". Почему так у меня. Linux Mint 17.2, Firefox последний. Удалил репу и freshplayerplugin. Стало работать как положено. Такое можетбыть или только у меня? В чем загвостка?

      Удалить
    3. Старый плеер удалите. Возможно они конфликтуют.
      Затем установите sudo apt-get instal pepperflashplugin-nonfree

      Удалить
    4. Загвоздка в том, что проект freshplayer неофициальный и экспериментальный. Freshplayer это "самодельный переходник" между Pepper Plugin API и Netscape Plugin API, трудно ожидать от него полного отсутствия глюков.

      Удалить
    5. Alexandr Unit, пример файла конфигурации freshplayer находится в /usr/share/freshplayerplugin/freshwrapper.conf.example, скопируйте в ~/.config, переименуйте в freshwrapper.conf и можно редактировать. При наличии проблем можно, к примеру, попробовать отключить 3d посредством enable_3d = 0

      https://github.com/i-rinat/freshplayerplugin/blob/master/doc/known-issues.md

      Удалить
    6. P.S. Скриншот с http://www.piranya.com/
      http://i.imgur.com/zmsYCuv.png

      Удалить
    7. Не знаю как у вас максим, а у меня работает ppapi на firefox идеально в отличии от npapi древнего и не обновляемого сто лет.

      Удалить
    8. Разве я говорил, что он у меня плохо работает? Я отвечал на вопрос Alexandr Unit, который пожаловался на проблему с некоторыми сайтами. У меня и freshplayer, и обычный 11-й flash в Мозилле работают без особых нареканий.

      Удалить
    9. Спасибо всем! Не было времени, сейчас установил, конфиг подправил. Работает отлично Pepper в Firefox!

      Удалить
  9. Я фляшом не пользуюсь, и мне как то пофиг.

    ОтветитьУдалить
    Ответы
    1. есть масса сайтов что я посещаю где требуется флеш.
      как быть в такой ситуации?
      типа "не посещать эти сайты" не вариант, абсолютно, лично в моем случае.

      Удалить
    2. он просто кроме контакта ни куда не заходит, а там уже html5 есть. таким людям флееш не нужен и они считают себя героями.

      Удалить
  10. Chrome Версия 43.0.2357.134 (64-bit) работает Flash Adobe

    ОтветитьУдалить
  11. "к получению контроля над компьютером под ... или Linux" откуда "дровишки"?
    ведь с 2008г. прекратили полпытки взлома браузеров и прочих .... под Ubuntu в сязи с бесперпективностью !!!

    ОтветитьУдалить
  12. Гы-гы, так вот из-за чего такая фигня с флешем под форточками последнее время. А я понять не могу, почему говорит о необходимости обновления, а обновлять не дает. Теперь ясно. Ну что опять буда смотреть фильму под линухой. Тихо и спокойно. Всем всего доброго.

    ОтветитьУдалить
  13. В том то и дело, что Флеш на Линуксе не блокировали, значит пофиг.

    ОтветитьУдалить
    Ответы
    1. Не знаю у кого не блокировали, но я вот например до сих пор без флеша живу. Ибо фф настоятельно просит его не включать. Конечно как вариант можно зайти в about:config и поставить false в extensions.blocklist.enabled но как то хз

      Удалить
  14. Уже вышло обновление до версии 11.2.202.491-1

    ОтветитьУдалить
  15. здравствуйте Скажите,пожалуйста,как сделать так,чтобы в браузере chromium в одноклассниках играла музыка и показывало видео?Pepperflash установлен Там пишут обновить flash plaeyer от Adobe

    ОтветитьУдалить
  16. Тоже увидел сообщение ну и погуглил, и прикрутил ppapi к firefox как Максим описывал. С флешем теперь всё в порядке, самая последняя версия под Ubuntu. Только браузер при закрытии выдавал сообщение о краше. Запустил из консоли, прочитал об ошибках связанных с отсутствием vaapi и vdpau. Создал конфиг, в самых последних пунктах убрал ускорение vdpau vaapi (по 0 выставил). Теперь всё работает прекрасно!

    ОтветитьУдалить
  17. во ПОШЛО И видео и музыка в одноклассниках После того.как установил freshplayerplugin Спасибо Максиму Пузырёву)))

    ОтветитьУдалить
  18. Я был не прав HTML 5 действительно не мало где есть, но что бы он заработал, нужно физически отключить в браузере флеш плагин, иначе он будет определятся автоматически и HTML 5 запускаться не будет)))

    ОтветитьУдалить
  19. to Костя Дьяченко: Да ладно уже, Костик, я не герой, а вот ты без фляша не сможешь в танчики поиграть. Я повторюсь, мне твой флеш боком не упал, так что новость ДЛЯ МЕНЯ не актуальная, а вот школьники должны страдать....

    ОтветитьУдалить
  20. Ф 12 поиск формта видео , и vlc пока рулят как по мне

    ОтветитьУдалить
  21. Этот комментарий был удален автором.

    ОтветитьУдалить