15 мая 2015

Установить/обновить ядро Linux Kernel 4.0.3 (Stable) в Ubuntu и производные

Ядро Linux является критичным элементом системы. Обновления ядра могут содержать улучшения аппаратной поддержки или устранять уязвимости.  Делать обновление стоит когда одно из аппаратных устройств работает некорректно, а новое ядро может решить данную проблему.  Но в тоже время установка нового ядра без особой необходимости может привести к нежелательным регрессиям, таким как: отсутствие подключения к сети, отсутствие звука или даже невозможность загрузить систему, поэтому устанавливайте новое ядро на свой страх и риск.

Linux Kernel 4.0.3 является третьим корректировочным выпуском ядра версии 4.0. Список изменений в ядре 4.0.3 можно посмотреть ЗДЕСЬ.
Вы можете скачать соответствующие deb пакеты ОТСЮДА и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.

Установить ядро версии 4.0.3 командами ниже, можно ​​в следующих дистрибутивах Linux:

Ubuntu 15.04/14.10/14.04/12.04
Linux Mint 17.1/17/13
elementary OS 0.2/0.3

Установка ядра Linux Kernel 4.0.3

1. Откройте терминал, скопируйте и выполните одну из команд, согласно архитектуры вашей системы/компьютера:

Для 32-bit (одной командой):

cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-headers-4.0.3-040003-generic_4.0.3-040003.201505131441_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-headers-4.0.3-040003_4.0.3-040003.201505131441_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-image-4.0.3-040003-generic_4.0.3-040003.201505131441_i386.deb && sudo dpkg -i *.deb

Для 64-bit (одной командой):
 
cd /tmp && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-headers-4.0.3-040003-generic_4.0.3-040003.201505131441_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-headers-4.0.3-040003_4.0.3-040003.201505131441_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.3-wily/linux-image-4.0.3-040003-generic_4.0.3-040003.201505131441_amd64.deb  && sudo dpkg -i *.deb

 2. Обновите GRUB (GRUB надо обновлять в той системе Linux где он установлен, если у вас их более одной):

sudo update-grub

Примечание 1
. Если у вас установлен загрузчик BURG, то и его нужно обновить:

sudo update-burg

3. По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

После входа в систему, проверьте версию актуального ядра командой:

uname -r


Примечание 2. Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.
Если вы решили удалить ядро 4.0.3, выполните эту команду:

sudo apt-get purge linux-image-4.0.3-* linux-headers-4.0.3-*

И вновь обновите GRUB командой:

sudo update-grub

Источник: https://www.kernel.org/

Удачи.

24 комментария :

  1. Ну вот уже третье 4-е ядро, как с видео драйвекпами?! Кто пробовал, отпишитесь, пожалуйста.

    ОтветитьУдалить
    Ответы
    1. Мне как обладателю 9600GT 340 nvidia драйвер нужно патчить для 4.0/4.1 ядра. И тогда работает.

      Удалить
    2. Что под словом патчить ? Драйвер установлен и ... ? Понимаю патчи (заплатки) на драйвера для игр . Но обьясни ,как патчить драйвер ?

      Удалить
  2. Ответы
    1. А название темы окна в Вашей системе? Чёрный, с отливом, весьма красиво глядится.

      Удалить
    2. http://gnome-look.org/content/show.php/DarkCold+-+3xMetacity?content=148659

      Удалить
    3. Вот еще:
      http://gnome-look.org/content/show.php/DarkCold?content=143165
      и для xfwm:
      http://xfce-look.org/content/show.php/DarkCold?content=148515

      Удалить
    4. А название темы окна в Вашей системе? Чёрный, с отливом, весьма красиво глядится.
      Dark mint, но это только в 13 Минт мате "напрямую, можно.А потом только перетаскивая папку с места на место. Главное "сохранить" в другом месте, остальное по инструкции как менять тему.
      To install Dark-Mint theme on Ubuntu/Linux Mint open Terminal (Press Ctrl+Alt+T) and copy the following commands in the Terminal:
      Terminal Commands:
      sudo add-apt-repository ppa:noobslab/themes
      sudo apt-get update
      sudo apt-get install dark-mint-theme
      That's it
      Нынешняя ш_няга, даже рядом не стоит..)))

      Удалить
    5. Alexandr Maltsev.. АКТИВНОЕ окно выглядит по другому. И кнопки другого цвета, что впрочем не утомляет. А они разные.. Если в Cinnamon поставить, много людей можно чем удивить. Проблема в том, что сейчас это можно делать через "тридцать три п_ ***Ы"

      Удалить
    6. Вдохновили, пойду пробовать :)

      Удалить
  3. на убунту мате никто не пробовал?

    ОтветитьУдалить
    Ответы
    1. "Проверено" Мин, или Минт нет. Вопрос, а в чём проблема??? Какое отношение имеет Холо как другому??? И что они здесь делают.. Дебилы, и , да посто дебилы. " Они "думают"? Чем и как???Голожопольстви, ,

      Удалить
    2. ты на каком языке вещаешь чудило?

      Удалить
  4. http://www.mintlinux.ru/forum/thread9127-1.html#43986
    Это то что есть у меня. Фотошопом пользоваться не умею. Не "доросло понятие? -с". Может попробовать, а потом выносить "суждения".. так проще. Не ФАКТ что у ВАС будет работать.. Свою систему надо лелеять и холить.Впрочем, о чём это я,,

    ОтветитьУдалить
  5. Правило номер один.. Легко и просто..

    ОтветитьУдалить
    Ответы
    1. Плохое правило . Поставил Минт 17.1 xfce , настроил . Все работает . Теперь сижу, как дурак .

      Удалить
  6. Я думаю так работает ну и ладно

    ОтветитьУдалить
  7. Спасибо! Прошло шатано. Всё работает! Конфигурация: Минт 17.1 XFCE, AMD Phenom 2 х6 1100Т, GTX 760 (Nvidia-346).

    ОтветитьУдалить
  8. Встало)) Что 4.0.2 и 4.0.3)))) Mint 17.1 Cinnamont 64-bit, AMD Phenom(tm) II X4 920 Processor x4, GeForce GTS 450 (Nvidia-349.16)

    ОтветитьУдалить