14 сентября 2014

Как правильно установить Google Earth в Linux Mint 17/Ubuntu 14.04 - 64bit

Весь мир открыт перед вами с Google Earth!
Виртуальные путешествия в любую точку мира: 3D-здания, фотоснимки и рельеф. Поиск городов, компаний и других мест.

Многие пользователи  Linux Mint 17/Ubuntu 14.04 архитектуры систем 64-bit заметили определённые "глюки" после установки Google Earth, это потому, что программа зависит от пакета ia32-libs в данной архитектуре.
Представленная ниже пошаговая инструкция поможет вам установить Google Earth в Linux Mint 17/Ubuntu 14.04 - 64bit.


Пошаговая установка Google Earth в Linux Mint 17/Ubuntu 14.04 - 64bit

Все действия по установке будут происходить в терминале (Ctrl+Alt+T).

1. Прежде всего необходимо добавить архитектуру 32-bit:

sudo dpkg --add-architecture i386 && sudo apt-get update

2. Установить библиотеку ia32-libs:

sudo apt-get install ia32-libs

3. Установить пакет Google Earth:

sudo apt-get install googleearth-package

4. И последнее. Установить google-earth-stable:i386 (для архитектуры 32-bit):

sudo apt-get install google-earth-stable:i386

Вот и всё. Откройте системное меню - Интернет и запустите Google Earth.


Удачи.

21 комментарий :

  1. Спасибо!
    Все хорошо.
    Кроме одного - вместо фотографий - белые прямоугольники без изображений.
    Такое только у меня, или это общая проблема?

    ОтветитьУдалить
    Ответы
    1. Это проблема kml-модуля Panoramio. Пройдите по ссылке http://www.panoramio.com/kml , скаченный kml-файл откройте "открыть в GoogleEarth (по умолчанию)", и через минуту фотографии Panoramio заработают!

      Удалить
    2. И каждый раз открывать через этот файл?

      Удалить
    3. У меня почему то после закрытия программы и открытии снова всё возвращается к прежнему состоянию: вместо фото белые квадраты. А вот на черных квадратах фото есть. Приходится закрываться и запускать прогу через файл. Почему не могу понять? Кто знает помогите!!!

      Удалить
    4. Решение проблемы корректного отображения фотографий Panoramio в Google Earth:
      Устанавливаете саму программу Гугл Планета Земля, далее
      - откройте терминал и введите:
      1. sudo apt-get install libfreeimage3
      2. cd /opt/google/earth/free
      3. sudo wget https://googledrive.com/host/0B2F__nkihfiNalQzN0ZmcjBPTGs/ge7.1.1.1580-0.x86_64-new-qt-libs-debian7-ubuntu12.tar.xz
      4. sudo tar xvf ge7.1.1.1580-0.x86_64-new-qt-libs-debian7-ubuntu12.tar.xz
      5. sudo apt-get install gufw
      6. sudo apt-get install flashplugin-installer

      Удалить
  2. Не могу установить. Убунту 14,04 х64. При вводе команды sudo apt-get install ia32-libs получаю

    sudo apt-get install ia32-libs
    Зчитування переліків пакунків... Виконано
    Побудова дерева залежностей
    Зчитування інформації про стан... Виконано
    Пакунок ia32-libs недоступний, але згадується у переліку залежностей іншого пакунка.
    Це може означати, що пакунок відсутній, застарів, або доступний з джерел, не згаданих в sources.list
    Однак наступні пакунки заміняють його:
    lib32z1 lib32ncurses5 lib32bz2-1.0

    E: Для пакунка 'ia32-libs' не знайдено кандидатів на встановлення

    И на последнюю команду

    sudo apt-get install google-earth-stable:i386
    Зчитування переліків пакунків... Виконано
    Побудова дерева залежностей
    Зчитування інформації про стан... Виконано
    E: Не можу знайти пакунок google-earth-stable

    Если скачивать *.deb с оф. сайта, то не хочет устанавливать, так как не стоят либы ia32-libs

    ОтветитьУдалить
  3. После введения
    sudo apt-get install ia32-libs
    выдал
    Пакет ia32-libs недоступен, но упомянут в списке зависимостей другого пакета.
    Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
    Однако следующие пакеты могут его заменить:
    lib32z1 lib32ncurses5 lib32bz2-1.0
    заменил
    sudo apt-get install lib32z1
    все успешно установилось, НО, после введения этого
    sudo apt-get install google-earth-stable:i386
    вот
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    E: Не удалось найти пакет google-earth-stable
    третий пункт не пропускал, что не так, U14.04, 64b.
    С уважением Владимир.

    ОтветитьУдалить
    Ответы
    1. ia32-libs-multiarch вроде она теперь...

      Удалить
    2. Не удалось найти пакет ia32-libs-multiarch. В интернете пишут много советов, можно добавить какие-то репы со старой убунты и поставить так ia32-libs, либо установить другие либы, но как-то не хочется портить систему непроверенными способами.

      Удалить
    3. и есть мнение что ia32-libs недоступен в репах с 13.10
      подсказывают что если дополнительно установить пакеты (libfontconfig1:i386 libx11-6:i386 libxrender1:i386 libxext6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libglib2.0-0:i386 libsm6:i386) то можно поставить GE на 64 битах так:
      cd /tmp && wget http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb
      sudo dpkg -i google-earth-stable_current_i386.deb
      sudo apt-get install -f

      Удалить
    4. Андраей, а вы на этот случай заведите виртуалку, ну или бэкапы при помощи systemback делайте...

      Удалить
    5. Спасибо, установил, всё работает. Никаких косяков пока не обнаружил.

      Удалить
  4. Вот нашел и все установилось
    Установка Google Earth 7.1.2.2041 в Ubuntu 14.04 и старше

    Откройте терминал (Ctrl+Alt+T), скопируйте и выполните следующие команды, согласно вашей системы:

    Для систем 64-bit:
    одной командой
    sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core
    тоже одной командой
    cd /tmp && wget http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb && sudo dpkg -i google-earth-stable_current_i386.deb
    потом это
    sudo apt-get install -f

    ОтветитьУдалить
  5. svtv1 присоединяюсь к этому способу, но надеюсь найдётся более изящный...

    ОтветитьУдалить
    Ответы
    1. Вот другая инструкция по установке Google Earth 7.1.2.2041 в Ubuntu 14.04 и старше: http://compizomania.blogspot.com/2013/09/google-earth-7122019-ubuntu-1310-linux.html

      Удалить
  6. Не по теме, но все же, можно сделать новую инструкцию по установке проги WinUSB, а то старая на новой Убунту 14.04 не работает)

    ОтветитьУдалить
  7. Правила не должны меняться от версии к версии. Если по другому то это идио.. .Иначе настанет дурдом. Каждый будет называть сборку своим именем. Но всего их три ? Юзабельные и долгоживущие. Остальное мусор..

    ОтветитьУдалить
  8. Мне нравится именно Линукс. Винды нет.Но вот установка приложений удивляет. В 13 минте(убунте) так. в другом эдак.. Порядок должен быть, хоть и Свободное ПО.

    ОтветитьУдалить
  9. Проблемы с фотками в Panoramio и установкой 64 битной версии решили с помощью костылей вот в этом посте http://ubuntuforums.org/showthread.php?t=2196304&p=12892342#post12892342 , у меня всё заработало, единственно пришлось подправить ярлык запуска в /usr/share/applications

    ОтветитьУдалить