07 декабря 2013

Установка Pepper Flash Plugin для Chromium


Последняя доступна версия Adobe Flash Player для Linux - 11.2, обновляется она только для браузеров Chrome. Связано это с тем, что Adobe отказались от Linux, а Google взяла разработку на себя, назвав данную разработку Pepper. Для установки Pepper, необходимо установить пакет из специального репозитория, который представляет из себя установщик Pepper.




Установка Pepper в Chromium

sudo add-apt-repository ppa:skunk/pepper-flash
sudo apt-get update 
sudo apt-get install pepflashplugin-installer


После установки вам необходимо указать Chromium, что нужно пользоваться Pepper Flash Player. Для этого отредактируйте файл запуска браузера chromium-browser/default, открыв его на редактирование следующей командой:

sudo gedit /etc/chromium-browser/default

В конце файла скопируйте/вставьте следующую строку:

. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Затем сохраните и закройте редактор.

Или выполните команду в терминале, которая добавляет в файл данную строку, только быстрее:

sudo sh -c 'echo ". /usr/lib/pepflashplugin-installer/pepflashplayer.sh" >>/etc/chromium-browser/default'

Теперь перезапустите Chromium, откройте chrome://plugins и удостоверьтесь в том, что у вас стоит последняя версия Adobe Flash Player.
В моём случае установленная версия - 11.9:


Удачи.

24 комментария :

  1. Ответы
    1. Нет. А зачем собственно? Там что, обычный "старорежимный" флеш плохо работает? Ну да, мажорная версия не меняется, но обновления безопасности-то выходят, и будут выходить еще года 4. За это время еще многое изменится. Мозилла намерена постепенно отказаться от флеш в пользу других технологий.

      Удалить
  2. как я и думал все осталось как и есть. Даже видео с бигмира не производит. Лажа на века.

    ОтветитьУдалить
  3. У меня вопрос возник. А установленный до ранее Adobe Flash Player 11.2 нужно удалить или не трогать?

    ОтветитьУдалить
  4. Мда... я думал он нормально заведется. А все как было так и осталось, белые квадратные пятна в играх, полноэкранный режим как нормально не работал так и не работает. Если честно не совсем понимаю что данная установка конкретно даёт.

    ОтветитьУдалить
  5. сегодня после обновления ядра начал вываливать slackware flash has crashed. пришлось переключиться на 11.2

    ОтветитьУдалить
  6. Владимир, а есть flash для maxthon? Почему-то в 14.04 youtube показывает Квадрат Малевича. Хотя звук есть.

    ОтветитьУдалить
    Ответы
    1. Не знаю. Пока на 14.04 не устанавливал maxthon. Установлю. Напишу сюда. Подожди немного.

      Удалить
    2. Миша, я установил Maxthon в 14.04. Видео воспроизводит. Вот смотри:

      [im]http://i017.radikal.ru/1404/55/ad967fecebb5.png[/im]

      Удалить
    3. А вот видео с youtube:

      [im]http://s003.radikal.ru/i204/1404/f8/79053097bd58.png[/im]

      Удалить
    4. Михаил, возможно, проблема в том, что только pepperflash и установлен (например, в составе Google Chrome), а "обычный" - нет?

      Удалить
    5. У меня воспроизводит почти всё, кроме Youtube. Да, я установил pepperflash. Теперь надо просто flashplayer установить?

      Удалить
    6. Pepperflash сам по себе предназначен только для Google Chrome. Для того, чтоб он работал с Chromium (или с Mahthon), нужно индивидуальное допиливание. С Мозиллой он вообще не работает и не собирается. Так что обычный flashplayer никто не отменял :)

      Удалить
  7. А может Maxthon переустановить. Раньше с ним не было таких проблем.

    ОтветитьУдалить
    Ответы
    1. Попробуй установить кодеки, если раньше не устанавливал:
      sudo apt install ubuntu-restricted-extras
      sudo apt install libavcodec-extra

      Удалить
  8. Не помогло. Все видео на youtube в виде черного экрана со звуком. На других ресурсах нормально. Рядом стоит компьютер с 12.04. Там та же версия Maxthon. На Нем все хорошо. Я уже переустановил Maxthon. Не помогло.

    ОтветитьУдалить
    Ответы
    1. Надо обновить страницу значком на панели или пкм на странице пункт перезагрузить

      Удалить
    2. Миша, посмотри здесь: http://www.youtube.com/html5

      Удалить
  9. Всё! Заработало! Добавил еще кодеков из Центра приложений. Всем спасибо огромное! !4.04 в остальном пока без нареканий!

    ОтветитьУдалить
    Ответы
    1. Вот видишь, оказывается и сам уже можешь. Так часто бывает. Ищешь, ищешь какую-то вещь, а она рядом лежит.

      Удалить
  10. Добрый вечер! Та же проблема с YouTube на Макстоне в 14.04. Кодеки
    sudo apt install ubuntu-restricted-extras
    sudo apt install libavcodec-extra
    установлены. При запуске Макстона выдает уведомление "Не удалось загрузить ShokWave flash". Что посоветуете?

    ОтветитьУдалить
    Ответы
    1. Установить SWF Gnash из Центра приложений и смотреть ролики с YouTube.

      Удалить