23 ноября 2013

Вышел Wine 1.7.7

Вышел очередной экспериментальный выпуск открытой реализации Win32 API - Wine 1.7.7. С момента выпуска версии 1.7.6 было закрыто 49 отчётов об ошибках.

Наиболее важные изменения:



    Поддержка настройки совместного доступа к внешним разделам при помощи NetAPI-библиотеки от проекта Samba;
    В драйвере для OS X добавлена поддержка использования нескольких раскладок клавиатуры;
    Улучшена поддержка XEMBED;
    Добавлена поддержка массивов в VBScript;
Закрыты отчёты об ошибках, связанные с работой игр и приложений:
Blood 2
Tomb Raider
Touhou 9
Word 2003/2007
Monster Jam
PowerPoint 2007
Frontpage 2003
Mouse in Nostale
Resident Evil 2
BioEdit
UltraNitroRacers
CivCity Rome 1.1
Desert Gunner
Caesar IV
Physx 9.12.1031
Mafia 2
Dungeons & Dragons Online
TERA Online
GEOVIA Surpac 6.x
Chessmaster 10th Edition
Freespace.

Установка Wine 1.7.7

Установка WineHQ 1.7.7 в Ubuntu 13.10/13.04/12.10/12.04 и Linux Mint 16/15/14/13.

Откройте терминал (Ctrl+Alt+T), скопируйте и выполните следующие команды:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.7 winetricks


Источник: http://www.winehq.org/announce/1.7.7

Удачи.

11 комментариев :

  1. Использовал wine на ubuntu 10.10. Понял что лучшая wine - это windows.Оно конечно все улучшается с годами,но если программа написана для винды,то лучше ее там и пользовать.

    ОтветитьУдалить
    Ответы
    1. Ага, а еще лучше вообще на Винду перейти, так что ли? :) Если мне от Винды необходимы две или три программы, которые по wine прекрасно бегают, почему бы мне не использовать wine вместо дуалбута? Какие религиозные соображения мне помешают? Ответ на вопрос, нужен ли Wine, ИМХО, вполне очевиден - конечно же, нужен. Тем, кому нужен и тогда, когда нужен. Вот и всё. Холивары по этому поводу считаю смешными и высосанными из пальца.

      Удалить
    2. Да я согласен про 2-3 программы.Просто встречал людей,которые думают,что wine=windows.Я и сам когда-то был такого мнения.А это не так.Вот дома мне винда не нужна,а на работе есть программы только под вин, да с проверкой подлинности,и под wine фиг,а не работа.

      Удалить
  2. Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Уже установлена самая новая версия winetricks.
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    wine1.7 : Зависит: wine1.7-i386 (= 1.7.6-0ubuntu2) но он не будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

    ОтветитьУдалить
  3. у меня так же пишет, система 64 битная

    ОтветитьУдалить
  4. как обновить wine? Делаю все как написано обновление не проходит

    ОтветитьУдалить
    Ответы
    1. Вероятно, это потому, что установлен метапакет "wine", который ссылается в качестве зависимости на стабильную версию wine 1.6. Вы это увидите, если откроете менеджер пакетов synaptic и посмотрите установленные пакеты по фильтру "wine". Чтоб такого не происходило, лучше всегда устанавливать wine c конкретным указанием номера версии, как и указано в статье. То есть, в данном случае, надо предварительно удалить всё, имеющее отношение к версии 1.6, т.е.

      sudo apt-get remove wine wine1.6

      а уж затем устанавливать 1.7, должно помочь.

      P.S. Установленные Windows-приложения не удалятся :).

      Удалить
  5. Максим Пузырев нет, wine 1.6 не установлено вообще, я пытаюсь обновить wine c 1.7.6 на 1.7.7 и оно не проходит

    ОтветитьУдалить
  6. Спасибо, Lnux Mint 16 64 bit Wine 1.7.7 установилось, работает. Wine прежних версий не было.

    ОтветитьУдалить
  7. а какой wine лучше ставить? 1.6.2 или 1.7.22 (23 версию не могу установить из репозитория, а исходники я никогда не любил)?

    ОтветитьУдалить