06 августа 2013

Вышел Wine 1.7.0


С выпуском Wine 1.7.0 начался цикл разработки новой экспериментальной ветки Wine 1.7.x, который завершится выпуском стабильной версии 1.8.0. С момента выхода версии 1.6.0 исправлено 44 различные ошибки.



Основные изменения:

    В драйвере Postscript добавлена поддержка вертикального расположения текста;
    В состав включена библиотека liblcms 2 (ранее поставлялась первая версия);
    Данные Unicode обновлены до версии 6.2.0;
    В инсталлятор добавлена поддержка элементов HyperLink Control для отображения гиперссылок;
    Улучшена поддержка XML-атрибутов.

Если вы хотите установить Wine 1.7.0 в Ubuntu/Linux Mint, следуйте инструкциям ниже.

Установка WineHQ 1.7 из исходных файлов в Ubuntu 13.10/13.04 и Linux Mint 15

Откройте терминал, скопируйте и выпоните данную последовательность команд:

sudo apt-get install flex bison qt4-qmake
wget http://prdownloads.sourceforge.net/wine/wine-1.7.0.tar.bz2
tar -xjvf wine-1.7.*
cd wine-1.7.*
./configure
cd tools; ./wineinstall


Установка WineHQ 1.7 из исходных файлов в Ubuntu 12.10/12.04/11.10 и Linux Mint 14/13/12

sudo apt-get install flex bison qt3-dev-tools qt4-qmake
wget http://prdownloads.sourceforge.net/wine/wine-1.7.0.tar.bz2
tar -xjvf wine-1.7.*
cd wine-1.7.*
./configure
cd tools; ./wineinstall


Источник:  http://www.winehq.org/announce/1.7.0

Удачи.

  Если у вас появились вопросы, обращайтесь на наш форум:  http://compizomania.54672.x6.nabble.com/ 

17 комментариев :

  1. Владимир, у меня вот такая ошибка...:
    configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

    Configure failed, aborting install.
    Плдскажите, как установить, спасибо. Убунту 12.04 64 bit.

    ОтветитьУдалить
    Ответы
    1. ./configure --enable-win64
      некоторые так советуют сделать,
      или так


      sudo apt-get install gcc-multilib g++-multilib

      Then [...] specifyiong a 32-bit host and passing 32-bit compilation flags:

      ./configure --host=i686-linux-gnu "CFLAGS=-m32" "CXXFLAGS=-m32" "LDFLAGS=-m32"

      Удалить
  2. Установил Wine 1.7.0, но почему-то он не отображается в меню Программы. Что делать?

    ОтветитьУдалить
    Ответы
    1. Всё стало на своё место после установки Winetricks.

      Удалить
  3. roman@roman-Lenovo-B580:~$ wine --version
    wine-1.4
    объясните почему показывает 1,4 если установил 1,7

    ОтветитьУдалить
    Ответы
    1. Сделай обновление системы.

      Удалить
    2. В смысле открой Менеджер обновлений и обнови систему. возможно там будет Wine 1.7.0.

      Удалить
    3. менеджер утверждает что нет обновлений

      Удалить
  4. Cкажите как обновится с версии 1.6 на 1.7 на Linux mint 15

    ОтветитьУдалить
    Ответы
    1. Удалить 1.6 и установить 1.7.

      Удалить
    2. А оно того стоит, игры лучше будут играть?

      Удалить
    3. Раз новая версия, значит есть улучшения. В статье есть ссылка на сайт Wine, открой и почитай.

      Удалить
  5. не ставится

    X development files not found. Wine will be built
    without X support, which probably isn't what you want. You will need
    to install development packages of Xlib/Xfree86 at the very least.
    Use the --without-x option if you really want this
    Configure failed, aborting install.

    :(

    ОтветитьУдалить
  6. Установка wine 1.7 на Ubuntu от 12.04 и выше.
    Люди, не мучайтесь с исходниками. Ибо wine team уже все за вас сделал.
    Ссылка на источник:
    http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu
    Установка:
    sudo apt-get update && sudo apt-get upgrade
    sudo add-apt-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get install wine1.7
    Приятного использования.

    ОтветитьУдалить
    Ответы
    1. Пакеты, имеющие неудовлетворённые зависимости:
      wine1.7 : Зависит: wine1.7-i386 (= 1.7.2-0ubuntu1~ppa1)
      E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

      Удалить
    2. Один из возможных путей решения:
      sudo apt-get update && sudo apt-get dist-upgrade
      Так-же, вариант решения проблемы с битыми пакетами приведен на этой странице:
      http://compizomania.blogspot.com/2013/05/ubuntu-13041210.html

      Удалить