14 ноября 2012

Установить обновлённый Skype 4.1 для Linux в Ubuntu 12.10/12.04/Linux Mint 13

Вышел обновлённый Skype версии 4.1 для систем Linux, в котором улчшена совместимость с Unity и Gnome Shell.



Вот некоторые новые возможности и изменения в последней версии:

Общайтесь с  друзьями Skype из Windows Live Messenger

Вход с помощью аккаунта Microsoft без необходимости создания новой учетной записи Skype

Улучшено качество видео для видео-чата и т.д.


Установка Skype 4.1

Прежде чем установить Skype версии 4.1, необходимо удалить старую версию (если установлена) из Центра приложений, либо выполнив следующую команду:

sudo apt-get remove skype

Далее зайдите на сайт: http://www.skype.com/intl/ru/get-skype/on-your-computer/linux/:


Выберите пакет Ubuntu 12.04 (multiarch) для любой архитектуры компьютера, загрузите его и установите в Центре приложений:


Хотя пакет Skype - Ubuntu 12.04 (multiarch), но после установки на компьютеры c архитектурой 64 -bit может не отображаться значок в трее. Если у вас присутствует данный баг, то нужно выполнить следующую команду:

sudo apt-get install sni-qt sni-qt:i386

Теперь вы можете пользоваться обновлённым Skype 4.1.

Удачи.

67 комментариев :

  1. Установил работает, но только нет значка Skype в трее. Объясните пожалуйста как это исправить.

    ОтветитьУдалить
  2. Ответы
    1. Спасибо ввел команду, сейчас все нормально.

      Удалить
    2. Здравствуйте! Пробовал установить по схеме, но выдаёт ошибку Error: Зависимость не может быть удовлетворена: libqt4-network (>=4:4.8.0)

      Удалить
    3. Попробовал тоже самое(

      Удалить
    4. Выполни команду: sudo apt-get install -f, затем установи скайп.

      Удалить
    5. Пробовал! Старая версия устанавливается нова нет, таже ошибка.

      Удалить
    6. Пробовал в терминале выдал следующее:
      lega ~ # dpkg -i skype-install.deb
      Выбор ранее не выбранного пакета skype.
      (Чтение базы данных ... на данный момент установлен 160321 файл и каталог.)
      Распаковывается пакет skype (из файла skype-install.deb)...
      dpkg: зависимости пакетов не позволяют настроить пакет skype:
      skype зависит от libqt4-network (>= 4:4.8.0), однако:
      Версия libqt4-network в системе 4:4.7.4-0ubuntu8.2.
      skype зависит от libqtgui4 (>= 4:4.8.0), однако:
      Версия libqtgui4 в системе 4:4.7.4-0ubuntu8.2.
      dpkg: не удалось обработать параметр skype (--install):
      проблемы зависимостей -- оставляем не настроенным
      При обработке следующих пакетов произошли ошибки:
      skype

      Удалить
    7. Какой-то глюк в системе. Но если старая версия работает нормально, то не переживай, в новой практически нет кардинальных изменений.

      Удалить
    8. У меня версия 2,2!!!)))

      Удалить
    9. Вау! А система какая?

      Удалить
    10. KDE 12, но с ядром 3.6.7)))

      Удалить
    11. KDE 12 не бывает. Есть KDE 12.04,12.10

      Удалить
    12. Проверил через терминал стоит такая:
      ~ $ lsb_release -a
      No LSB modules are available.
      Distributor ID: LinuxMint
      Description: Linux Mint 12 KDE
      Release: 12
      Codename: lisa

      Удалить
    13. Так Linux Mint 12, а не KDE 12. тогда у тебя должен быть установлен Synaptic. Открой его, введи в строку поиска Skype, удали всё что с ним связано и повтори установку нового Skype.

      Удалить
    14. Всё это уже пробовал)

      Удалить
    15. Тогда обнови систему до Linux Mint 13, хотя через пару дней выйдет 14-я, там уже будет новый Skype.

      Удалить
    16. Спасибо за помощь) Сижу жду 14-й Линукс)

      Удалить
  3. "Хорошо улучшена совместимость, что даже значок в трее не появляется"

    ОтветитьУдалить
  4. А чем он лучше 4.0.... у меня например 4.0 отлично работает, правда у меня KDE.

    ОтветитьУдалить
  5. У меня всё нормально и значёк в трее есть.

    ОтветитьУдалить
  6. А я наоборот, бьюсь как убрать иконку в трее:(

    ОтветитьУдалить
  7. Вот так удаляется значёк в трее...

    sudo apt-get remove sni-qt sni-qt:i386

    ОтветитьУдалить
  8. Всем привет, у кого не устанавливается Skype попробуйте так:
    sudo add-apt-repository ppa:skype-wrapper/ppa
    sudo apt-get update && sudo apt-get install skype-wrapper
    у меня после этого установился, U12.10
    С уважением Володя.

    ОтветитьУдалить
  9. Как добавить его в автозагрузку? Ubuntu 12.10

    ОтветитьУдалить
  10. Не могу установить скайп т.к он выдает ошибку Неправильная архитектура 'i386'
    Можете как-то помочь с установкой?

    ОтветитьУдалить
    Ответы
    1. Система какая? Ubuntu, Mint...

      Удалить
    2. Ubuntu 12.10 x64

      Удалить
    3. Открой Центр приложений Ubuntu, введи в окне поиска Skype и установи. Он теперь есть в репозитории и устанавливается без проблем.

      Удалить
    4. Аналогичная проблема при аналогичной системе. В репозитории не находит, серьезно
      http://i52.fastpic.ru/big/2013/0125/2f/c0aa497b06aecb00bcc1404fc83ca92f.png

      Удалить
    5. Возможно не подключен репозиторий. См. снимок:

      [img]http://s55.radikal.ru/i148/1207/1f/21005c4ec430.png[/img]

      Активируй эти два пункта, а затем обнови систему командой: sudo apt-get update
      Затем открой Центр приложений и ещё раз проверь.

      Удалить
    6. Ubuntu 12.10
      сначала полез в центр приложений, но там скайпа не было.
      Репозитории подключены, сделал update, в центре приложений скайп появился, но он не устанавливается.
      Ошибка:

      Зависимости пакета не могут быть разрешены
      Следующие пакеты имеют неудовлетворённые зависимости:

      skype: Depends: skype-bin но он не будет установлен

      Центр приложений при этом "внезапно закрылся и предлагает перезапуститься и отправить отчёт

      Удалить
    7. Попробуй установку Skype следующим образом:

      sudo apt-get install libxss1

      cd /tmp

      wget -c http://goo.gl/XaHpa -O skype-ubuntu-precise_4.1.0.20-1_i386.deb

      sudo dpkg -i skype-ubuntu*.deb

      Удалить
    8. выполняю sudo apt-get install libxss1
      пишет
      Чтение списков пакетов… Готово
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      Пакет libxss1 недоступен, но упомянут в списке зависимостей другого пакета.
      Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

      E: Для пакета «libxss1» не найден кандидат на установку

      Удалить
    9. помогло спс

      Удалить
  11. У меня скайп пишет при авторизации что с этого компьютера мол я уже авторизован. Хотя все выключено.
    Ubuntu 12.10 x64

    ОтветитьУдалить
    Ответы
    1. К слову, если запускать скайп sudo skype - все ок.
      А если без sudo То такая вот ошибка.

      Удалить
  12. Точно такая же проблема и система.Попробовал установить вашим методом - не получилось.Только после этой команды ////sudo dpkg -i skype-ubuntu*.deb///
    пишет ///dpkg: error processing skype-ubuntu-precise_4.1.0.20-1_i386.deb (--install):
    архитектура пакета (i386) не соответствует архитектуре системы (amd64)
    При обработке следующих пакетов произошли ошибки:
    skype-ubuntu-precise_4.1.0.20-1_i386.deb///

    ОтветитьУдалить
    Ответы
    1. Я об этой проблеме говорю, если что.
      /Не могу установить скайп т.к он выдает ошибку Неправильная архитектура 'i386'
      Можете как-то помочь с установкой?/

      Админ, помоги пожалуйста.

      Удалить
    2. Самая последняя версия Skype сейчас есть в Центре приложений. Установи оттуда. Он устанавливается без проблем.
      Удачи.

      Удалить
    3. Пытался, но не получается. Вот что пишет центр приложений и терминал.
      http://yadi.sk/d/VVGzGdYB3K9RH

      пробовал sudo apt-get install -f -не помогло,
      пробовал sudo apt-get install libxss1
      cd /tmp
      wget -c http://goo.gl/XaHpa -O skype-ubuntu-precise_4.1.0.20-1_i386.deb
      sudo dpkg -i skype-ubuntu*.deb --тоже не помогло
      Не знаю, что делать.

      Удалить
    4. Кто может помочь с этим?

      Удалить
    5. Попробуй выполнить это:

      sudo add-apt-repository ppa:upubuntu-com/chat

      sudo apt-get update

      sudo apt-get install skype

      Может эти команды помогут.

      Удалить
    6. Все тоже самое. Не помогло.

      Удалить
    7. Проблема с зависимостями пакета. Выполни вот эту команду: sudo apt-get install -f
      И попробуй ещё раз установку.

      Удалить
    8. После этой команды пишет

      E: Не удалось получить доступ к файлу блокировки /var/lib/dpkg/lock - open (11: Ресурс временно недоступен)
      E: Не удалось выполнить блокировку управляющего каталога (/var/lib/dpkg/); он уже используется другим процессом?

      Удалить
    9. У тебя в системе запущен какой-то процесс. Закрой все приложения, перезагрузи систему и повтори команду.

      Удалить
    10. Выключил все. Перезагрузил. Выполнил вот эти команды
      sudo apt-get install -f
      sudo add-apt-repository ppa:upubuntu-com/chat
      sudo apt-get update
      sudo apt-get install skype

      Все таже ошибка,что и на скриншоте.

      Пакеты, имеющие неудовлетворённые зависимости:
      skype : Зависит: skype-bin но он не может быть установлен
      E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

      Удалить
    11. Синаптик показывает, что нет пакетов с ошибками.

      Удалить
    12. Возможно ты подключал какие-то репозитории, а затем удалял их. Если это так, то выполни ещё эту команду: sudo apt-get install ppa-purge, а затем проведи установку.

      Удалить
  13. Выполнил эту команду, в результате --обновлено 0, установлено 5 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

    Установил. Потом попробовал установить опять Скайп, но все таже ошибка.

    ОтветитьУдалить
    Ответы
    1. А у тебя в Источники приложений вот эти репозитории подключены?

      [im]http://i011.radikal.ru/1303/6d/2cf8be1fb60c.jpg[/im]

      Удалить
    2. Да. Все Ок там. http://yadi.sk/d/fpmH4gLg3KCzW

      Удалить
    3. Вижу. Косяк какой-то в системе. Не знаю что ты устанавливал и удалял, и правильно ли всё делал? Так как после установки системы Skype загружается "на ура".

      Удалить
    4. Да у меня тоже постоянно все "на ура" устанавливалось всегда. Тот же Скайп - никогда проблем не было.
      Систему 12.10х64 переустановил 2 дня назад с образа на отдельный раздел диска, которым пользуюсь давно и не было проблем с ним. Настраивал все по вашему блогу. Попутн0 стоит и Виндовс 7 х32. Я понимаю, что какой-то косяк в системе, но как его исправить?

      Удалить
    5. А почему у тебя Виндовс 7 х32, а Ubuntu 12.10х64? Может быть в этом причина?

      Удалить
  14. Хм... Возможно. Не задумывался над этим.
    Я точно не понимаю, но если Убунту установлена на отдельный раздел диска, то разве как-то будут пересекаться зависимости х32 Винды и х64 Убунты?
    Это может быть реальная проблема или только предположение?

    (Виндовс для работы и других членов семьи висит)

    ОтветитьУдалить
    Ответы
    1. Нет, пеесекаться они не будут, но если архитектура твоего компьютера 32-bit, то и систему такую же нужно устанавливать. Ведь Windows не ты устанавливал? А он 32-bit. Вот я о чём.

      Удалить
    2. Я понял, что вы имеете ввиду. Просто до этого всегда пользовался так и раньше, проблем не было. И сейчас, кроме Скайпа, Убунту отлично работает и все другие приложения в ней тоже. Если я переутановлю Винду с х64 архитектурой, это решит проблему?

      Во всяком случае, спасибо большое за помощь. Завтра подумаю еще и может установлю Винду 64 биттную.

      Удалить
    3. Нет. Если уж переустанавливать, то Ubuntu.

      Удалить
  15. У меня тоже стоят две ОС windows 7x32 и linux mint(cinnamon) 14x64 Скайп установился сразу и без косяков из репозитария.windows не трогай и еще на windows тоже стоит Скайп и все настройки одинаковы с linux.Удачи.

    ОтветитьУдалить
  16. Скайп встал без проблем, но никак не могу разобраться со звуком. Вернее с его отсутствием... на тесте её слышу, а себя потом нет.

    ОтветитьУдалить
    Ответы
    1. Кликни на значок динамика в трее - Параметры звука -Вход, добавь громкость или поменяй там микрофон и попробуй ещё раз Тестовый вызов.

      Удалить
  17. Не помогло. Обнаружил еще проблемку - изображения тож нет !!!

    ОтветитьУдалить
  18. ... если микрофон меняю то и её не слышу ...

    ОтветитьУдалить
  19. Почему хоть он с qmmp конфликтует?

    ОтветитьУдалить