31 октября 2012

Установить ядро Linux Kernel 3.6.4 в Ubuntu 12.10/12.04/Linux Mint 13


Ядро Linux Kernel 3.6.4 уже четвертый технический выпуск ядра серии 3.6, который был выпущен совсем недавно.

Познакомиться с изменениями ядра Linux Kernel 3.6.4, можно ЗДЕСЬ.

Установка ядра 3.6.4 доступна для следующих дистрибутивов:

Ubuntu 12.10/12.04/11.10 и старше
Linux Mint 13/12 и старше

Установка Linux Kernel 3.6.4

Откройте терминал и выполните следующие команды на свой страх и риск:

cd /tmp

wget http://dl.dropbox.com/u/47950494/upubuntu.com/linux-kernel-3.6.4 -O linux-kernel-3.6.4

chmod +x linux-kernel-3.6.4

sudo sh linux-kernel-3.6.4

Перезагрузите систему, чтобы завершить установку.

После нового входа в систему, вы можете проверить текущую версию ядра с помощью команды:

uname -r

Для удаления ядра Linux Kernel 3.6.4, чтобы вернуться к предыдущей версии, выполните следующую команду:

sudo apt-get purge linux-image-3.6.4-030604

В случае возникновения проблем с новым ядром в системе, почитайте ЗДЕСЬ, как разрешить их.
 
Удачи.

16 комментариев :

  1. Что-то нет кометов.Может все зависли?

    ОтветитьУдалить
  2. Подскажите, раньше было 4 файла для обновления ядра, а теперь 3. Куда пропал файл linux-headers-*-*_all.deb ? И можно ли обновляться если до этого я обновлял ядро с помощью 4 файлов?

    ОтветитьУдалить
    Ответы
    1. Насколько я понимаю, без этого пакета нельзя установить проприетарные драйверы. Так что новость бесполезная в общем.

      Удалить
  3. Поставил это ядро, неудачно. До этого стояло 3.6.0.
    Криво запустилась Unity(без верхней панели), драйвер nvidia, второй экран... На этом эксперемент был закончен, загрузил предыдущее ядро, а это удалил.

    ОтветитьУдалить
  4. У меня свободный драйвер nouveau не работает с веткой 3.6. А теперь и нвидиа не пашет. ACPI на моем компе ему тоже не нравится. 12.04

    ОтветитьУдалить
    Ответы
    1. Где-то тут читал,что перед установкой нового ядра нужно деактивировать драйвер nVidia/

      Удалить
    2. По идее должен сработать dkms...

      Удалить
  5. Неудачно, при установке стало ругаться на дрова nvidia (в итоге слетели), откатился на 3.6.3...

    ОтветитьУдалить
  6. Мне непонятно почему админ публикует все время какие-то левые сцылко? Вот этот сайт, откуда качают ядра: http://kernel.ubuntu.com/~kernel-ppa/mainline/

    ОтветитьУдалить
    Ответы
    1. Надо ж чем то личный dropbox занять))))

      Удалить
  7. Последнее ядро которое без проблем работает с 12.04 3.5.7

    ОтветитьУдалить
  8. Я например вообще никакие ядра не обновляю установлена 12.10 с ядром 3.5 и всё работает!!

    ОтветитьУдалить
  9. Ребят, проясните вопрос. Вот тут http://kernel.ubuntu.com/~kernel-ppa/mainline/ последнее ядро для quantal 3.6.3 которое у меня собственно и стоит. 3.6.4 и уже 3.6.5 собирались только для raring. Вопрос это что за ядро предлагается поставить ? От raring?

    ОтветитьУдалить
    Ответы
    1. Почему это ТОЛЬКО для raring?Вот у меня к примеру стоит 10.04 с ядром от quantal'а(3.5.3 версия) и всё прекрасно работает.А в raring'е скорей всего будет 3.7 стоять(хотя RC-версии есть и для Quantal)

      Удалить
  10. Спасибо- обновил...ранее -но повторил и всё ок http://rlu.ru/c19

    ОтветитьУдалить