22 января 2015

Установить индикатор последних уведомлений в Ubuntu

Индикаторы в Ubuntu – это небольшие программы, умеющие отображать разную полезную информацию в системном трее.
Основная цель индикаторов – предоставить быстрый доступ к некоторой информации в контекстном меню, кликом на индикаторе.

Все важные системные события или оповещения обычно отображаются в виде стандартного системного уведомления, всплывающего в правом верхнем углу монитора длительностью 10 секунд, а затем самопроизвольно исчезает.
Однако, если вы немного отвлеклись или отошли от компьютера, то могли пропустить какое-то важное для вас уведомление. В этом случае вам поможет установка индикатора последних уведомлений.


Установка индикатора последних уведомлений в Ubuntu 14.04 и старше

Откройте терминал (Ctrl+Alt+T), скопируйте и выполните следующие команды:

sudo add-apt-repository ppa:jconti/recent-notifications
sudo apt-get update
sudo apt-get install  indicator-notifications

Для его появления в трее нужно перезагрузить систему или применить сочетание клавиш Alt+F2, ввести unity и нажать Enter, для перезапуска окружения Unity.

После каждого входа в систему индикатор последних уведомлений будет автоматически появляться в трее.

Индикатор по мере получения извещений меняет свой цвет с серого на зелёный, с возможностью очистки контекстного меню от прочитанных извещений кнопкой Clear.

Удаление индикатора последних уведомлений

Если вы решили удалить индикатор, выполните эти команды,

sudo add-apt-repository -r ppa:jconti/recent-notifications
sudo apt-get update
sudo apt-get remove --purge indicator-notifications

Удачи.

9 комментариев :

  1. W: Не удалось получить http://ppa.launchpad.net/jconti/recent-notifications/ubuntu/dists/utopic/main/binary-amd64/Packages 404 Not Found

    W: Не удалось получить http://ppa.launchpad.net/jconti/recent-notifications/ubuntu/dists/utopic/main/binary-i386/Packages 404 Not Found
    в Убунту 14.10

    ОтветитьУдалить
    Ответы
    1. ===в Ubuntu 14.04 и старше====

      Под "старше" Владимир имел в виду "более старых версий", а не "выше по номеру". В репозитории нет версии для 14.10

      Удалить
    2. Даш - программы и обновления - Другое ПО - http://ppa.launchpad.net/jconti/recent-notifications/ubuntu - Изменить - строчка Дистрибутив там замените utopic на trusty. :)

      Удалить
  2. а он умеет автоматически удалять устаревшие
    сообщения из списка, чтобы не нажимать каждый
    раз "clear"? иначе это какая-то тамагоча получается...

    ОтветитьУдалить
  3. очень нужная штучка, спасибо, установил, работает.

    ОтветитьУдалить
  4. в XFCE не работает. Хотя в версии 12.04 аналогичный плагин работал без вопросов.

    ОтветитьУдалить
  5. Почему-то из-за него unity-panel-indicator начинает увеличивать потребление оперативки...
    Пришлось удалить (такая же проблема была когда ставил еще на Ubuntu12.04_Unity). Ubuntu 14.04_Unity

    ОтветитьУдалить