04 февраля 2013

Установить ядро Linux Kernel 3.7.6 в Ubuntu/Linux Mint


Ядро Linux Kernel 3.7.6 является шестым техническим выпуском ядра серии 3.7, с  улучшениями и различными исправлениями ошибок. Установка этого ядра очень проста. Вы можете скачать соответствующие deb пакеты ЗДЕСЬ и установить их в Центре приложений Ubuntu. Или просто следуйте приведенным ниже инструкциям, которые помогут вам установить новое ядро несколькими командами в терминале.
Некоторые изменения и исправления в этом последнем ядре можно посмотреть в changelog:

Установить это ядро командами ниже, можно ​​в следующих дистрибутивах Linux:

    Ubuntu 12.10/12.04/11.10 и старше
    Linux Mint 14/13/12 и старше


Установка ядра Linux Kernel 3.7.6

Откройте терминал, скопируйте и выполните эту последовательность команд, на свой страх и риск:

cd /tmp

wget http://dl.dropbox.com/u/47950494/upubuntu.com/kernel-3.7.6 -O kernel-3.7.6

chmod +x kernel-3.7.6

sudo sh kernel-3.7.6

По окончании установки, закройте все приложения и перезагрузите компьютер следующей командой:

sudo reboot

Графика Nvidia и устранение возможных неисправностей.

Если у вас возникнут неожиданные проблемы с драйвером Nvidia, вы можете исправить вашу систему, используя следующие инструкции:

Нажмите CTRL+ALT+F2 и выполните следующие команды:

cd /usr/src/linux-headers-3.7.6-030706/arch/x86/include

sudo cp -v generated/asm/unistd* ./asm

sudo apt-get install --reinstall nvidia-current

После успешного входа в систему, проверьте установленное ядро командой в терминале:

uname -r

Вывод команды должен быть таким:



Удаление ядра Linux Kernel 3.7.6

В случае, если вы хотите удалить ядро 3.7.6 из системы и вернуться к ранее установленному, выполните следующую команду:

sudo apt-get purge linux-image-3.7.6*

Как вернуться к ранее установленному ядру, инструкция ЗДЕСЬ.

  Удачи.

57 комментариев :

  1. Ответы
    1. Торопишся "батенька"!

      Удалить
  2. шмель не работает на 3.7.х ((( хотя может что то сам не так ставлю :)

    ОтветитьУдалить
    Ответы
    1. Возможно нужно переустановить Bumblebee.

      Удалить
    2. Не, похоже они там что-то не то наворотили. Ставил разные версии ядер, читал мануалы. Шмель не видит процессорского драйвера. Ждем обновления шмеля.

      Удалить
    3. Все вышесказанное характерно только для версии ядра 3.7.х, на 3.5.х все работает.

      Удалить
  3. Ответы
    1. Шмель-Bumblebee для видеокарт Nvidia Optimus.

      Удалить
  4. Жить стало лучше.
    Жить стало веселей.

    ОтветитьУдалить
  5. Што??? О_о Опять??? )))

    ОтветитьУдалить
  6. (12.04) Nvidia драйвера - поставить не удалось никак , ни через терминал (испробовалл 5 скриптов и на старые и на новые дрова ) , ни через стандартный установщик , ни по приведенному выше скрипту - вот что пишет :
    cp: не удалось выполнить stat для «generated/asm/unistd*»: Нет такого файла или каталога

    Пошел даже из любопытства на полную установку системы с ноля - обновил ядро - результат - такой же шиш.
    В обшем с кажым новым ядром проблем с Nvidia становилось все больше и больше ну а сегодняшнее просто клинический апофеоз.

    ОтветитьУдалить
    Ответы
    1. Да это не с ядром, а с Nvidia. Не зря Линус (разработчик ядра) им средний палец показывал.

      Удалить
    2. Через Synaptiс тоже не выходит поставить , судя по тому что там видно - все уже вроде стоит , но хрена не работает , и переустановить не все получается ну вообщем началось .....

      Удалить
    3. Аналогичная беда. Причём на 3.7.3 было так же. Но каким то чудом встали, потом. Далее два обновления гладко. А сейчас даже не знаю.

      Удалить
  7. а что дождаться нормальных и проверенных ядер через менеджер обновлений слабо, да?!

    ОтветитьУдалить
  8. менеджер обновления это хорошо. а телом подвигать еще лучше

    ОтветитьУдалить
  9. Навернулась у меня 12.04
    Пишу из Винды.
    Восстанавливать буду уже завтра.

    ОтветитьУдалить
    Ответы
    1. Бэкап ещё никто не отменял!!!

      Удалить
  10. Тоже система слетела. Предыдущее ядро запускаться отказалось. Переустановил. Что-то неудачненько слепили однако.

    ОтветитьУдалить
  11. Что-то они зачастили... как всегда все работает нормально в Минт13!

    ОтветитьУдалить
  12. Попробовал обновить в 11.10.
    Установилось, а, вот, запускаться напрочь отказалось.
    Пробовал и nVidia переустановить, т.к. моя карточка совсэм старый и Unity только в 2D работает, не помогло.
    Пробовал и в Recovery Mode лечиться. Бесполезно. Не хочет запускаться.
    Вернулся к рабочему ядру...

    ОтветитьУдалить
  13. обновил. Нареканий и замечаний нет

    ОтветитьУдалить
  14. При установке пара-тройка ерроров была. После ребута с первого раза не стартанула, после хард ресета компа завелась. Ошибок в работе, что интересно, не наблюдаю. Надя х64.

    ОтветитьУдалить
  15. Linuxойды, куда делась Ваша параноидальность? Пользуйтесь первоисточниками. Берите ядро отсюда
    http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7.6-raring/
    и устанавливайте по инструкции отсюда
    http://www.distrogeeks.com/upgrade-linux-kernel-ubuntu/
    Качайте ядро отдельно и устанавливайте по аналогии, ибо по инструкции ядро старое. Но установка не отличается. ИМХО, качать ядро на dropbox небезопасно.

    P. S. Ядра разные для 64 и 32 бит дистрибутивов. См. вторую ссылку.

    ОтветитьУдалить
    Ответы
    1. Видимо ты не внимательно читал статью. В самом начале даётся ссылка установку deb пакетов. Не стоит повторяться в комментарии.

      Удалить
    2. Все таки на Вы принято начинать разговор. "Начинающие" выберут вариант с dropbox'ом, а первый вариант никак не описан и не прокомментирован. Хотя он намного универсальнее и вызывает меньше проблем.

      Привыкайте пользоваться проверенными источниками, а не файлообменниками на которые любой желающий может поместить любую информацию.

      P. S. Также, было бы полезным разместить ссылку на первоисточник, собственно вот: http://www.upubuntu.com/2013/02/installupgrade-to-linux-kernel-376-in.html
      Уважайте чужой труд. OpenSource все же.

      P. P. S. Я как раз начинающий линуксоид...

      Удалить
    3. Приветствую начинающего линуксоида. Как раз ссылка на первоисточник есть. Не совсем понятно, чего бояться линуксоиду в файлообменниках, это не Windows с вирусами.
      А на счёт Ты или Вы, так в интернете нет ни возраста, ни рода, есть пользователи. И я не против когда ко мне также обращаются на ты. Здесь не должно быть ни каких обид. Вот когда мы будем переписываться в личку, так сказать, то тогда - да.

      Удалить
    4. Тем не менее, обращение на Вы никого не оскорбит, а вот обращение на Ты может. Забыли об этом конфузе.
      ИМХО, так вот "начинающие" привыкнут устанавливать все программы из файлообменников и в один прекрасный день установять себе rootkit или какую-либо другую вредоносную программу с правами администратора... Иллюзия безопасности linux.

      Удалить
    5. Кого оскорбит обращение на Ты, не обращаться больше, вот и всё. Это моё правило и на этом ресурсе правила устанавливаю я. Надо это учесть впредь. Интернет бескрайний. Найди другой ресурс. Я силком ни кого не тяну на сайт, тем более обидчивых.
      На счёт rootkit, так это к Windows. Не надо путать дырявый Windows с безопасным Linux. И ни какой иллюзии здесь нет. Я пользуюсь Linux шестой год (файлообменниками в том числе) и пока не встретил ни одного rootkit или что-то подобное. Не надо пугать пользователей безосновательно. Аргументы Windows здесь не годятся

      Удалить
    6. Я с Админом согласен, ИМХО, в том смысле, что если лезешь на чужой блог, то своё недовольство чем-либо оставь при себе! А если к "первоисточнику", то пусть товарищ сольёт КОД, отредактирует под себя, после скомпилирует, установит и радуется, никто не запрещает! Моё НО: Lunux - относительно безопасен, не заблуждайтесь, соблюдение элементарной безопасности юзверем никто не отменял, ИМХО. При желании можно положить любую систему.

      Удалить
  16. Аргумент http://vms.drweb.com/virus/?i=1957835
    Гугл даст больше информации о "вредоносных программах" в linux.
    Моя цель была не Вас переубедить, а донести полезную информацию до пользователей, чтобы они уделяли больше внимания обдумыванию своих действий.
    За сим откланиваюсь.

    ОтветитьУдалить
  17. Если ты закроешь двери для тьмы, то как в них проникнет свет? И, прежде чем требовать к себе обращения, нужно, по меньшей мере, как-то представиться, ты- анонимный линуксоид, поучающий гражданин...

    ОтветитьУдалить
  18. Для света есть окна.

    ОтветитьУдалить
    Ответы
    1. В 8-ых окнах ловите радугу... ))) И не имейте обыкновения портить другим настроение!

      Удалить
    2. добавочка: Я тоже начинающий, но от незнания предмета не лезу в .... И Google - сын ошибок трудных, и Windows - парадоксов друг, и Linux - Бог Изобретатель.© Поиск в помощь! Сообщество линукс - огромно! У меня на этот комп 8-ка отказалась устанавливаться, поставил Надю х64. Поначалу тяжеловато, потом привыкаешь )))

      Удалить
    3. Этот комментарий был удален автором.

      Удалить
    4. По поводу Windows 8. Производитель материнских плат AsRock не гарантирует работу linux-дистрибутивов на своих материнских платах. Есть достаточное количество оборудования и их соотношения (в том числе и данных МП и старого оборудования), которое не поддерживается в linux. Если Вы не сталкивались с этим, это не говорит о том, что этого нет. Доводов можно привести много. Только подтверждайте свои доводы фактами. Не вырывайте фразы из контекста.
      Речь о другом: Вы считаете безопасным устанавливать из недостоверных источников ядро своей любимой операционной системы? Вы считаете безопасным устанавливать из НЕДОСТОВЕРНЫХ источников любой пакет? Тут даже о всеми любимых "дырах" не надо упоминать. Зачем они нужны, когда пользователь сам скачает, установит и даст права рута программе? С чем, вообще, Вы пытаетесь здесь поспорить??? Это базовые правила.

      Удалить
    5. "Откройте терминал, скопируйте и выполните эту последовательность команд, НА СВОЙ СТРАХ И РИСК"- остановись уже...

      Удалить
    6. Тро-ло-ло

      Удалить
  19. Не своетую ставить это ядро для тех кто использует драйвер от nvidia, шаманил два часа, так и не заставил работать..., на 1.7.5 - заводится с полпинка.

    ОтветитьУдалить
    Ответы
    1. Модули драйвера не цепляются :( уже много что перепробовал, остаюсь на 1.7.5

      Удалить
  20. Добрый день. у меня стоит Linux mint 13 Mate 32-bit,3,2,0-23-generic. в линуксе пол года .надо ли мне вообще устанавливать свежее ядро? Особых проблем нет ,только микрофон не работает в скайп . помочь не смогли на форуме минт,может ядро новое поможет? спасибо.

    ОтветитьУдалить
    Ответы
    1. Лучше не устанавливай, если новичок в Linux. А что со звуком в Skype? Может чем-то смогу помочь.

      Удалить
  21. Чтобы микрофон работал в скайпе в Минт13,нужно сделать следующее:
    1. Удаление PulseAudio.

    1.1 Завершаем работу PulseAudio:
    killall pulseaudio

    1.2 Удаляем не нужные пакеты:
    sudo apt-get remove pulseaudio gstreamer0.10-pulseaudio -y

    1.3 Изменяем настройки gstreamer:
    gconftool-2 -s --type string /desktop/gnome/sound/default_mixer_device "alsamixer"
    gconftool-2 -s --type list --list-type string /desktop/gnome/sound/default_mixer_tracks "[Master]"
    gconftool-2 -s --type boolean /desktop/gnome/sound/enable_esd false
    gconftool-2 -s --type string /system/gstreamer/0.10/default/audiosink "alsasink"
    gconftool-2 -s --type string /system/gstreamer/0.10/default/audiosrc "alsasrc"
    gconftool-2 -s --type string /system/gstreamer/0.10/default/chataudiosink "alsasink"
    gconftool-2 -s --type string /system/gstreamer/0.10/default/musicaudiosink "alsasink"

    1.4 Добавляем репозиторий, содержащий измененный апплет громкости и пакеты, для нормальной работы без PulseAudio:
    sudo add-apt-repository ppa:dtl131/ppa

    1.5 Обновляем списки репозиториев и обновляем пакеты:
    sudo apt-get update
    sudo apt-get upgrade

    1.6 Перезагружаемся

    1.7 Добавляем апплет звука на панель.
    Для этого жмем правой кнопкой мыши на панели → Добавить на панель… → в списке выбираем Регулятор громкости.

    ОтветитьУдалить
  22. мне помог совет http://www.mintlinux.ru/forum/thread547-4.html Я научился пользоваться редактором gedit ,и через него сделал идзменение буквально сегодня и предвтавляете все получилось.! спасибо вам за отзывчивость.!

    ОтветитьУдалить
  23. Такая проблема - выбираю при загрузке Recovery mode после чего по экрану бегут белые буквы и цифры, а потом просто чёрный экран и всё.
    Сама система нормально загружается и работает, а вот режим восстановления нет. Кто знает как решить такую проблему?

    ОтветитьУдалить
    Ответы
    1. Попробуй сделать восстановление GRUB по инструкции ЗДЕСЬ.

      Удалить
  24. Может Вы и мне поможете .у меня нетбук Aser aspire one 722 после установки убунту 12.10 перестал работать внутренний микрофон. Похожая проблема не только у меня, как я поняла это касается всех асеров этой серии.

    ОтветитьУдалить
    Ответы
    1. Можно попробовать ядро обновить,а может глючит PulseAudio,как его заменить я писал выше,на МИНТ13 после проделанных манипуляций микрофон заработал!

      Удалить
    2. Да, я надеюсь в насторойках вы уже поковырялись и все испробывали?

      Удалить
    3. Надо установить pavucontrol: sudo apt-get install pavucontrol затем открыть его в терминале: pavucontrol и убрать флажок с одного микрофона, т.к. в Aser aspire one 722 микрофон - моно.

      Правый клик на ссылке и Открыть ссылку:

      http://s019.radikal.ru/i603/1302/97/4a4c0b402c2a.jpg

      Удалить
  25. Сделала по инструкции . Теперь не работает не только input но и output.

    ОтветитьУдалить
    Ответы
    1. На панели значек звука-правой кнопкой-настройки и там настраиваем входной и выходной сигнал.Точно сейчас не подскажу т.к. сижу под ХР на работе.Там ставте галочки и ползунки регулируйте все получится

      Удалить
    2. Наново установила pulseaudio командой sudo apt-get install pulseaudio затем сделала как на этой картинке http://s019.radikal.ru/i603/1302/97/4a4c0b402c2a.jpg
      sudo apt-get install pavucontrol затем открыть его в терминале: pavucontrol и убрать флажок с одного микрофона, т.к. в Aser aspire one 722 микрофон - моно. После этого микрофон заработал. До этого прошерстила англоязычные и русские форумы убунту и наконец решение оказалось таким простым. Сорры за флуд. Может кому-нибудь пригодится.

      Удалить