28 ноября 2012

Установка клиента UbuntuOne в Linux Mint 14/13


Ubuntu One — онлайн-хранилище, разрабатываемое компанией Canonical, для пользователей Ubuntu, предназначенное для обмена файлами и синхронизации между компьютерами и мобильными устройствами, а также сервис потоковой музыки, с помощью которого можно прослушивать загруженную музыку на мобильных устройствах с Android, iPhone или iPad.
Cервис бесплатно предоставляет 5 Гб дискового пространства для хранения данных, а дополнительное место и сервис потоковой музыки доступны на платной основе. С 15 августа 2012 года доступно получение дополнительного места путем приглашения новых пользователей. За каждого приглашенного дается 500 мегабайт в хранилище. Максимальное количество получаемого таким образом места составляет 20 Гб.



Установка клиента UbuntuOne

Для установки клиента UbuntuOne в Linux Mint 14, выполните следующие команды:

sudo add-apt-repository ppa:ubuntuone/stable
sudo apt-get update
sudo apt-get install ubuntuone-client ubuntuone-control-panel-qt ubuntuone-control-panel

Для установки клиента UbuntuOne в Linux Mint 13, выполните эти команды:

sudo add-apt-repository ppa:ubuntuone/stable
sudo apt-get update
sudo apt-get install ubuntuone-control-panel-gtk ubuntuone-client


Вот и всё. Храните свои файлы в облаке вместе с Ubuntu One.

Удачи.

11 комментариев :

  1. А как насчет платной подписки на доп. место?

    ОтветитьУдалить
  2. Лучше narod.yandex.ru ничего нет

    ОтветитьУдалить
  3. Mint-13 cinnamon. При установке клиента Ubuntu One в терминале выходит ошибка:
    Пакеты, имеющие неудовлетворённые зависимости:
    ubuntuone-control-panel-gtk : Зависит: ubuntuone-control-panel-qt (= 3.0.1-0ubuntu1) но он не будет установлен
    E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
    Может кто что посоветует по этому поводу? А то жаль, успешно пользовался сервисом на других системах(U-12.04, E-13.04)

    ОтветитьУдалить
    Ответы
    1. Статья 2012-го года, времени много прошло, похоже, репозиторий подвергся "ревизии". Попробуй

      sudo apt-get install ubuntuone-client ubuntuone-control-panel-gtk ubuntuone-client-proxy ubuntuone-control-panel-qt
      (или вообще без gtk)

      и запустить

      ubuntuone-installer

      Удалить
    2. С gtk не вышло:
      цитата:
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
      или же используете нестабильную версию дистрибутива, где запрошенные вами
      пакеты ещё не созданы или были удалены из Incoming.
      Следующая информация, возможно, поможет вам:

      Пакеты, имеющие неудовлетворённые зависимости:
      ubuntuone-control-panel-gtk : Зависит: ubuntuone-control-panel-qt (= 3.0.1-0ubuntu1) но 4.2.0-0ubuntu1~precise1 будет установлен
      ubuntuone-control-panel-qt : Ломает: ubuntuone-control-panel-gtk но 3.0.1-0ubuntu1 будет установлен
      E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

      Без gtk установка клиента прошла нормально, установка ubuntuone упирается в ошибку(http://ubuntuone.com/2mKCQI8BoJnBafOLMuguNS). Может дело непоправимое, системное, т.к. Менеджер обновлений тоже даёт такую ошибку со времени установки системы.

      Удалить
    3. Я, к сожалению, сам не использую ни UbuntuOne, ни Минт. У меня сложилось впечатление, что происходит конфликт версий пакетов из официального репозитория Минт, и из того, что подключается вручную. Возможно, в Минт 13 сторонний реп вообще не нужен. Попробуйте сделать, во первых, sudo apt-get install -f и если это не поможет, тогда, думаю, лучше вычистить репозиторий и все пакеты с помощью sudo ppa-purge ppa:ubuntuone/stable и посмотреть в synaptic, на предмет, какие пакеты ubuntuone есть в официальных репах, их и устанавливать. Пуглить "ubuntuone mint 13" тоже не помешает :)

      Удалить
    4. Спасибо за участие, попробую.

      Удалить
    5. Покопался. По первому пункту ничего не обновилось, по второму - нет такой команды. Видимо я сам что- то не то делал, т.к.:
      С тормозами переустановил через менеджер программ клиента и установщик, перезагрузился и новая установка прошла успешно, облако на месте.
      Спасибо, успехов! До встречи в сети.

      Удалить
    6. Вам того же. Вдогонку, на всякий случай, PPA Purge - "это консольная утилита, которая производит откат всех пакетов, установленных из указанного PPA, на версии, доступные в официальных репозиториях Ubuntu".
      То есть, она не только деактивирует репозиторий, но и удаляет пакеты, из него установленные, а обновленные из него - откатывает на старые версии. Очень удобно. Вроде она должна быть в официальных репозиториях, но если вдруг нет, то вот:

      sudo add-apt-repository ppa:nilarimogard/webupd8
      sudo apt-get update
      sudo apt-get install ppa-purge

      Удалить
    7. Благодарю, положил добрый совет в облачную копилочку.

      Удалить