20 октября 2012

Как правильно обновить Ubuntu 12.04 до Ubuntu 12.10



Для того чтобы обновить Ubuntu 12.04 до Ubuntu 12.10, необходимо выполнить ряд действий, чтобы в дальнейшем не возникало проблем в новой системе.

1. Актуализируйте Ubuntu 12.04, выполнив следующие команды в терминале:

sudo apt-get update

sudo apt-get upgrade

Если после выполнения команды upgrade будет предложено обновление программ, ОБЯЗАТЕЛЬНО обновите их.

2. Откройте Источники приложений следующей командой:

sudo software-properties-gtk




Перейдите на вкладку Обновления, в пункте Сообщить мне о новой версии Ubuntu нужно выбрать Для любой новой версии и закройте окно Источники приложений.

3. Далее выполните команду в терминале для определения новой версии Ubuntu 12.10:

sudo update-manager -d




Введите свой пароль и нажмите Enter.

После выполнения команды должен открыться Менеджер обновлений, который сообщит вам о том, что доступен для установки новый релиз дистрибутива Ubuntu 12.10.

Закройте все работающие приложения, нажмите кнопку Обновить и следуйте инструкциям обновления релиза.
Во время обновления вам будет предложено отключить сторонние репозитории, согласитесь. Далее во время обновления будут появляться окна с различными предложениями на изменения параметров того или иного приложения, если вы затрудняетесь ответить, просто соглашайтесь, а также будет предложено подтвердить ваш пароль - подтвердите.

Дождитесь окончания обновления, не используя ни какие приложения.
Продолжительность обновления будет зависеть от скорости вашего интернет-соединения.
По окончании обновления вам будет предложено перезагрузить компьютер. Перезагрузите.

4. После перезагрузки и входа уже в Ubuntu 12.10, откройте Источники приложений:

sudo software-properties-gtk



Во вкладке Другое ПО  подключите сторонние репозитории, которые были отключены во время обновления.

Вот и всё.

Удачи.

46 комментариев :

  1. супер спасибо подажду месяц или 2 когда 12.10 закроют баги

    ОтветитьУдалить
  2. После обновления вроде бы c большего работает, а вот подключить сторонние репозитории не получается, пишет:
    Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
    gpg: /tmp/tmphdwb45/trustdb.gpg: создана таблица доверий
    И галочки не ставятся. Кто нибудь сталкивался?

    ОтветитьУдалить
    Ответы
    1. Вероятно в прошлой системе ты изменял настройки шрифтов или устанавливал дополнительные шрифты. Нужно открыть в текстовом редакторе настройки шрифтов следующей командой: sudo gedit /etc/fonts/conf.d/50-user.conf и изменить 9-ю строку, как тебе пишет терминал. Возможно после этих изменений всё исправится.

      Удалить
  3. Вот 9 строка: ~/.fonts.conf</include
    Если подскажите что на что изменить изменить, буду благодарен.(пробовал её удалить, ставить no вместо yes, не помогло).

    ОтветитьУдалить
  4. Прошу прощения: ~/.fonts.conf.d

    ОтветитьУдалить
  5. Не получается вставить :(

    ОтветитьУдалить
  6. Не получается вставить :( - чего?

    ОтветитьУдалить
  7. содержание злополучной 9 строки

    ОтветитьУдалить
    Ответы
    1. А шрифты менял или устанавливал раньше?

      Удалить
  8. Сложно вспомнить, по моему нет. Ещё с 10.04 настройки были.

    ОтветитьУдалить
    Ответы
    1. Вот терминал и пишет, что устаревшие настройки шрифтов. Но если основные репозитории работают, то ни чего страшного, просто на сторонние не будешь получать обновления и всё. А система будет обновляться.

      Удалить
  9. Почистил кеш, переустановил fontconfig, на шрифты по прежнему ругается, но галочки начали ставиться/сниматься, везде кроме сторонних источников, что в принципе не мешает их добавить заново.
    Админ, спасибо за участие.

    ОтветитьУдалить
  10. Мне написал "невозможно вычислить обновление". Обидно. А репы уже переписал. Обновлю переустановкой. Ни разу еще не обновился

    ОтветитьУдалить
    Ответы
    1. Иногда в таких случаях помогает команда: sudo apt-get install -f

      Удалить
    2. Не помогло и не помогло ..... upgrade -f Как говориться ни ножничками ни ломом. Переустановил с диска.

      Удалить
  11. После обновления решил удалить ненужные проги. В итоге как-то удалил - "Параметры системы". Как эта прога называется, чтоб установить ее обратно?

    ОтветитьУдалить
  12. А после обновления все настройки, что делались ранее слетят? Это заново надо настраивать учетки в почтовике, в скайпе, закладки в опере и т.д. ???

    ОтветитьУдалить
    Ответы
    1. Как бы не должны слетать, в основном не слетают. Пароли у меня сохраняются на всё что можно после обновления.
      После обновления нельзя уже откатиться назад. Но в случае с 12.04-12.10 это и не понадобится.


      Оффтоп: С Оперой я рекомендую вам зарегистрироваться на http://my.opera.com/community/ у вас будет свой аккаунт. Вы можете войти в него с любой Оперы установленной на любом компьютере (например в гостях), и у вас появятся все ваши закладки, если в зайдёте с паролем на свой аккаунт + почтовый ящик от Оперы, блог и фотохостинг.

      Удалить
  13. Обновился. И с обновлением последующим ядра. Наверное успешно. Без переустановки. Единственное, когда все загрузилось и пошло обновление, был запрос на замену конфигурационного файла - библиотека какая-то, в ней все старые настройки были. Я не стал заменять этот файл, а оставил старый.
    Поэтому из визуального могу сказать следующее:
    1. Разрешение монитора стало выше, ощутимее выше.
    2. Скорость загрузки не увеличилась, а вот скорость открытия приложений выросла. Почти мгновенно все открывается.
    3. Читал жалобы на отсутствие глобального меню в офисе - нет такого косяка. Меню есть, открывается нормально.
    4. Настройки не слетели кроме почтовика - теперь только из Баша открываю, ну и ладно.
    А так все тип топ, полет нормальный....

    ОтветитьУдалить
  14. Да. А в Опере всё-же откройте аккаунт, и тогда все ваши закладки в Опере будут вам доступны с любого компьютера с Оперой. Ссылка: https://my.opera.com/community/signup/

    ОтветитьУдалить
  15. 12.10 гно.покрайней мере мой DELL отказываеться работать нормально и стабильно.не возможно подключить сторонние источники,видео драйвер вообще беда,кнопки,например терминал,при нажатии большой кукиш происходит,впрям как на кривой ВИСТЕ.два раза обновлял,в итоге вернулся на 12.04.

    ОтветитьУдалить
    Ответы
    1. У меня очень хорошо обновилась до 12.10 на Lenovo B550. А сейчас я поставил чистую систему.

      Удалить
    2. хорошо обновилось на Asus K50IE, все заметно ускорилось, нашел пару багов, но некритично.на десктопе пока что оставил 12.04

      Удалить
  16. Может ручки не оттуда растут? Или с головой проблемы? Не получается через обновление, переустанови с ноля. Ты хаишь пот непонятным причинам, не описал, что делал и что получилось. Корректнее надо быть и терпимее.

    ОтветитьУдалить
    Ответы
    1. А вот хорошо бы без личных разборок.

      Удалить
  17. После обновления почти все источники пришлось править вручную: по непонятной причине в software-properties-gtk нельзя было проставить ни одной галочки. Кроме того в домашнем каталоге появилась папка fontconfig и при запуске любого приложения из терминала в нём выводятся предупреждения "Having multiple values in isn't supported and may not works as expected" для нескольки строк в файлах //etc/fonts/conf.d/65-culmus.conf и etc/fonts/conf.d/90-fonts-nanum-coding.conf. И что с этим делать непонятно. А так всё работает.

    ОтветитьУдалить
  18. после обновления заблокированы все источники приложений...
    что делать?

    ОтветитьУдалить
    Ответы
    1. Открой sources.list: sudo gedit /etc/apt/sources.list и раскомментируй (убери знак решётки) с репозиториев, которые заблокированы, сохрани и закрой gedit. Затем выполни команды:
      sudo apt-get update
      sudo apt-get dist-upgrade.

      Удалить
  19. Пардон, я, помоему, не совсем понял что нужно менять...
    вот часть из sources.list
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu quantal partner
    deb-src http://archive.canonical.com/ubuntu quantal partner

    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    deb http://extras.ubuntu.com/ubuntu quantal main
    deb-src http://extras.ubuntu.com/ubuntu quantal main
    deb http://archive.canonical.com/ quantal partner
    deb-src http://archive.canonical.com/ quantal partner
    deb http://archive.ubuntu.com/ubuntu quantal-backports restricted main multiverse universe


    Что удалять?

    ОтветитьУдалить
  20. Раскомментируй первые две строки:
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    Вот так:
    'partner' repository.
    This software is not part of Ubuntu, but is offered by Canonical and the

    ОтветитьУдалить
  21. Добрый вечер! Можно сказать я только пользователь Линукса Майя, к сожалению очень плохо разбирающаяся не то что в тонкостях оного, но и в общих настройках в том числе. Установила Майю на новый нетбук. Все было замечательно, работала как часики 3 месяца, обновляла сама раза 2, почему то он не просил обновления, а надо было входить в менеджер самой и обновляться, и вот два дня назад стала обновлять, после обновления исчезли иконки со всех окон , сворачивание, разворачивание, и закрытие окна. А при обновлении пишет что несовпадение со многими пакетами, я насчитала их 14 штук. И еще выдал окошко вот с такой надписью

    Не удалось получить http://packages.linuxmint.com/dists/maya/import/i18n/Translation-ru_RU Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/import/i18n/Translation-ru Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/import/i18n/Translation-en Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/main/i18n/Translation-ru_RU Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/main/i18n/Translation-ru Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/main/i18n/Translation-en Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/upstream/i18n/Translation-ru_RU Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/upstream/i18n/Translation-ru Невозможно соединиться с packages.linuxmint.com: http:
    Не удалось получить http://packages.linuxmint.com/dists/maya/upstream/i18n/Translation-en Невозможно соединиться с packages.linuxmint.com: http:
    Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

    Подскажите пожалуйста что можно сделать в моей ситуации.

    ОтветитьУдалить
    Ответы
    1. Елена, к сожалению я не знаю. что за обновление было сделано, но подозреваю - обновление дистрибутива, раз комментарий написан здесь. Обновление дистрибутива для Linux Mint и Ubuntu проходит по-разному. Это надо иметь ввиду.

      Удалить
    2. И теперь ничего сделать нельзя?

      Удалить
    3. К сожалению только переустановить систему, т.к. Вы её сломали.

      Удалить
    4. попробуйте Y PPA Manager-может помочь....

      Удалить
    5. sudo add-apt-repository ppa:webupd8team/y-ppa-manager
      sudo apt-get update
      sudo apt-get install y-ppa-manager

      Удалить
    6. Елена, хоть, наверное, уже и поздно, но всё равно напишу. У меня подобная ошибка бывает на свежеустановленном Linux Mint. Рискну предположить, что у них периодически возникают проблемы с доступностью репозиториев.

      Удалить
  22. И еще один вопрос лучше установить Майю или Надю?

    ОтветитьУдалить
    Ответы
    1. Тут Вам решать, т.к. Maya на 5 лет поддержки, а Nadya только на 1.5 года. Но Mint 14 для меня - более продвинутый дистрибутив, в нём не надо устанавливать флажки для раскладки и пр. прибамбасы - всё по умолчанию и мн. другое. Так что. Вот так. Решайте. А как установить дистрибутив на тоже место на жёстком дисеке, почитать можно ЗДЕСЬ.

      Удалить
  23. А саму Nadya какую скачать, дайте пожалуйста ссылку)а то на сайте написаны и 32 и 64 разрядные, а для меня это сложно какую выбрать по незнанию...но ведь надо учиться)

    ОтветитьУдалить
    Ответы
    1. Ну это зависит от архитектуры Вашего компьютера, которую нужно Вам проверить командой в терминале: arch Если терминал выдаст i686 (i386) = 32 bit, а если x86_64 = 64 bit, такой дистрибутив и нужно выбрать для загрузки. Вот и всё.

      Удалить
  24. Здравствуйте, уважаемые администраторы! У меня возникла проблема: После обновления Ubuntu 10.10 до версии 12.04 перестала работать программа PhotoPrint. Причём не выводится окно с какой-нибудь ошибкой. Программа просто не открывается. Подскажите, пожалуйста, какой-нибудь способ устранения этой проблемы.

    ОтветитьУдалить
    Ответы
    1. Во-первых хотелось бы заметить, что обновление дистрибутива не всегда проходит гладко. это зависит от установленных пользователем дополнительных программ и ещё от ряда других причин. Тем более такое длинное обновление: Ubuntu 10.10 - 12.04. Лучше сделать бэкап важных файлов и переустановить, конечно. Но можно попробовать удалить PhotoPrint из Центра приложений или командой в терминале: sudo apt-get remove photoprint, а затем вновь установить. Возможно поможет.

      Удалить
  25. Помогите решить проблему, не могу обновиться до 12.10
    При обновлении пишит такую ошибку:


    Ошибка при обновлении

    При обновлении возникла проблема. Обычно это бывает вызвано проблемами в сети. Проверьте сетевые подключения и повторите попытку.

    Но инет у меня через кабель и всё просто летает, при 100 Мбит/c
    В сети нашёл несколько советов но они к сожалению не поМогли решить .....

    ОтветитьУдалить